summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-02-08 13:02:43 +0000
committerHanno Boeck <hanno@gentoo.org>2008-02-08 13:02:43 +0000
commit2594bd7431f3ada1e650c2a1bc0dc23e93387457 (patch)
tree916863266668a5652dfa15f0c9687376ef4b18fd /net-analyzer/openvas-libnasl
parentinitial openvas-libraries commit (diff)
downloadhistorical-2594bd7431f3ada1e650c2a1bc0dc23e93387457.tar.gz
historical-2594bd7431f3ada1e650c2a1bc0dc23e93387457.tar.bz2
historical-2594bd7431f3ada1e650c2a1bc0dc23e93387457.zip
initial commit of openvas-libnasl
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'net-analyzer/openvas-libnasl')
-rw-r--r--net-analyzer/openvas-libnasl/ChangeLog11
-rw-r--r--net-analyzer/openvas-libnasl/files/openvas-libnasl-1.0.0-Makefile.patch33
-rw-r--r--net-analyzer/openvas-libnasl/metadata.xml6
-rw-r--r--net-analyzer/openvas-libnasl/openvas-libnasl-1.0.0.ebuild26
4 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/openvas-libnasl/ChangeLog b/net-analyzer/openvas-libnasl/ChangeLog
new file mode 100644
index 000000000000..455c8f232ea3
--- /dev/null
+++ b/net-analyzer/openvas-libnasl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/openvas-libnasl
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-libnasl/ChangeLog,v 1.1 2008/02/08 13:02:43 hanno Exp $
+
+*openvas-libnasl-1.0.0 (08 Feb 2008)
+
+ 08 Feb 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/openvas-libnasl-1.0.0-Makefile.patch, +metadata.xml,
+ +openvas-libnasl-1.0.0.ebuild:
+ Initial commit of openvas.
+
diff --git a/net-analyzer/openvas-libnasl/files/openvas-libnasl-1.0.0-Makefile.patch b/net-analyzer/openvas-libnasl/files/openvas-libnasl-1.0.0-Makefile.patch
new file mode 100644
index 000000000000..f5cfd262f7c6
--- /dev/null
+++ b/net-analyzer/openvas-libnasl/files/openvas-libnasl-1.0.0-Makefile.patch
@@ -0,0 +1,33 @@
+--- openvas-libnasl-1.0.0-orig/nasl/Makefile 2008-01-17 13:54:34.000000000 +0100
++++ openvas-libnasl-1.0.0/nasl/Makefile 2008-01-17 13:57:11.000000000 +0100
+@@ -26,7 +26,7 @@
+ NESSUS_CFLAGS= -I../include $(OPTIMIZE) `$(LIBOPENVASCONFIG) --cflags` `$(GPGME_CONFIG) --cflags` -DNESSUS_EXTENSIONS
+ NESSUS_LIBS = $(LIBS) `$(LIBOPENVASCONFIG) --libs` `$(GPGME_CONFIG) --libs`
+
+-NESSUS_INCLUDE=`sh ./cflags`
++NESSUS_INCLUDE = $(NESSUS_CFLAGS) $(include) $(DEFS)
+
+ YACC = bison
+ YFLAGS = -d -v -t -p nasl
+@@ -88,18 +88,15 @@
+ nasl_debug.lo
+
+ COMPILE = $(LIBTOOL) $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
+-all : cflags libopenvasnasl.la openvas-nasl
++all : libopenvasnasl.la openvas-nasl
+
+ .c.o:
+ $(COMPILE) -c $<
+-cflags : Makefile
+- @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
+- @chmod +x cflags
+
+-openvas-nasl : cflags $(OBJS) nasl.c
++openvas-nasl : $(OBJS) libopenvasnasl.la nasl.c
+ $(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o openvas-nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
+
+-libopenvasnasl.la : cflags $(OBJS)
++libopenvasnasl.la : $(OBJS)
+ $(COMPILE) $(NESSUS_LIBS) -o libopenvasnasl.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
diff --git a/net-analyzer/openvas-libnasl/metadata.xml b/net-analyzer/openvas-libnasl/metadata.xml
new file mode 100644
index 000000000000..efa54454de71
--- /dev/null
+++ b/net-analyzer/openvas-libnasl/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/openvas-libnasl/openvas-libnasl-1.0.0.ebuild b/net-analyzer/openvas-libnasl/openvas-libnasl-1.0.0.ebuild
new file mode 100644
index 000000000000..ad9903349998
--- /dev/null
+++ b/net-analyzer/openvas-libnasl/openvas-libnasl-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-libnasl/openvas-libnasl-1.0.0.ebuild,v 1.1 2008/02/08 13:02:43 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="A remote security scanner for Linux (openvas-libnasl)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/406/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-analyzer/openvas-libraries"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/openvas-libnasl-1.0.0-Makefile.patch"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc ChangeLog || die "dodoc failed"
+}