summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-11-01 21:15:57 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-11-01 21:15:57 +0000
commita96a5fad7c3ebae4042438c16848e2b79bbd4b78 (patch)
treefad6cf10e53c3bfc5abb7032656720069937a820 /net-analyzer/pchar/pchar-1.5.ebuild
parentStable on x86 wrt bug #148913. (diff)
downloadhistorical-a96a5fad7c3ebae4042438c16848e2b79bbd4b78.tar.gz
historical-a96a5fad7c3ebae4042438c16848e2b79bbd4b78.tar.bz2
historical-a96a5fad7c3ebae4042438c16848e2b79bbd4b78.zip
Re-add snmp USE flag (bug #152701). Thanks to Francisco Javier <ffelix@sshinf.com> for the patch.
Package-Manager: portage-2.1.2_pre3-r7
Diffstat (limited to 'net-analyzer/pchar/pchar-1.5.ebuild')
-rw-r--r--net-analyzer/pchar/pchar-1.5.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-analyzer/pchar/pchar-1.5.ebuild b/net-analyzer/pchar/pchar-1.5.ebuild
index 4e8f0673f851..5ab15ff66428 100644
--- a/net-analyzer/pchar/pchar-1.5.ebuild
+++ b/net-analyzer/pchar/pchar-1.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pchar/pchar-1.5.ebuild,v 1.2 2006/03/24 17:46:30 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pchar/pchar-1.5.ebuild,v 1.3 2006/11/01 21:15:57 chutzpah Exp $
+
+inherit eutils autotools
DESCRIPTION="Internet bandwidth, latency, and loss of links analyzer."
HOMEPAGE="http://www.kitchenlab.org/www/bmah/Software/pchar/"
@@ -9,12 +11,22 @@ SRC_URI="http://www.kitchenlab.org/www/bmah/Software/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ipv6 pcap"
+IUSE="ipv6 pcap snmp"
DEPEND=">=dev-libs/openssl-0.9.7
+ snmp? ( net-analyzer/net-snmp )
pcap? ( net-libs/libpcap )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-snmp.patch
+}
+
src_compile() {
+ eautoreconf
+
econf --without-suid \
$(use_with ipv6) \
$(use_with snmp snmp /usr/lib) \