summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-09 17:30:04 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-09 17:30:04 +0000
commit918c6cf9b1d0463ac1cae81f784ca057e38df56c (patch)
tree4cc1dffe7105f3e534cd07f5e8b9daa4a7ae7840 /net-analyzer/tcpdump
parentremove stale imlib 1.9.11 mask (diff)
downloadhistorical-918c6cf9b1d0463ac1cae81f784ca057e38df56c.tar.gz
historical-918c6cf9b1d0463ac1cae81f784ca057e38df56c.tar.bz2
historical-918c6cf9b1d0463ac1cae81f784ca057e38df56c.zip
new version, fixes a security vuln
Diffstat (limited to 'net-analyzer/tcpdump')
-rw-r--r--net-analyzer/tcpdump/ChangeLog7
-rw-r--r--net-analyzer/tcpdump/files/digest-tcpdump-3.6.21
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.6.2.ebuild38
3 files changed, 45 insertions, 1 deletions
diff --git a/net-analyzer/tcpdump/ChangeLog b/net-analyzer/tcpdump/ChangeLog
index 05a436b81701..19cf495a6dff 100644
--- a/net-analyzer/tcpdump/ChangeLog
+++ b/net-analyzer/tcpdump/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-analyzer/tcpdump
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.2 2002/05/09 17:30:04 spider Exp $
+
+*tcpdump-3.6.2 (9 May 2002)
+ 9 May 2002; Spider <spider@gentoo.org> tcpdump-3.6.2.ebuild :
+ Updated version on tcpdump.org, fixes security vulnerability.
+
*tcpdump-3.6.1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-analyzer/tcpdump/files/digest-tcpdump-3.6.2 b/net-analyzer/tcpdump/files/digest-tcpdump-3.6.2
new file mode 100644
index 000000000000..22a5109041e7
--- /dev/null
+++ b/net-analyzer/tcpdump/files/digest-tcpdump-3.6.2
@@ -0,0 +1 @@
+MD5 6bc8da35f9eed4e675bfdf04ce312248 tcpdump-3.6.2.tar.gz 380635
diff --git a/net-analyzer/tcpdump/tcpdump-3.6.2.ebuild b/net-analyzer/tcpdump/tcpdump-3.6.2.ebuild
new file mode 100644
index 000000000000..358a3e22e43b
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.6.2.ebuild,v 1.1 2002/05/09 17:30:04 spider Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="http://www.tcpdump.org/release/${A}
+ http://www.jp.tcpdump.org/release/${A}"
+HOMEPAGE="http://www.tcpdump.org/"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.6.9 )
+ >=net-libs/libpcap-0.6.2"
+
+RDEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.6.9 )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use ssl`" ] ; then
+ myconf="--without-crypto"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr --enable-ipv6 $myconf
+#--disable-ipv6
+ try make CCOPT="$CFLAGS"
+}
+
+src_install() {
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc README FILES VERSION CHANGES
+}
+
+
+