summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-24 07:16:11 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-24 07:16:11 +0000
commit01d52f11bd1a18b501a81e65434577a59da1129b (patch)
tree95295f01680ec3b2df3841fc2849a730d0639278 /net-analyzer
parentmarked x86 per bug 417343 (diff)
downloadhistorical-01d52f11bd1a18b501a81e65434577a59da1129b.tar.gz
historical-01d52f11bd1a18b501a81e65434577a59da1129b.tar.bz2
historical-01d52f11bd1a18b501a81e65434577a59da1129b.zip
Initial import (bug 108224)
Package-Manager: portage-2.1.10.62/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/dietsniff/ChangeLog10
-rw-r--r--net-analyzer/dietsniff/Manifest14
-rw-r--r--net-analyzer/dietsniff/dietsniff-0.4.ebuild44
-rw-r--r--net-analyzer/dietsniff/metadata.xml24
4 files changed, 92 insertions, 0 deletions
diff --git a/net-analyzer/dietsniff/ChangeLog b/net-analyzer/dietsniff/ChangeLog
new file mode 100644
index 000000000000..422809bd8c6f
--- /dev/null
+++ b/net-analyzer/dietsniff/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/dietsniff
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dietsniff/ChangeLog,v 1.1 2012/05/24 07:16:11 xmw Exp $
+
+*dietsniff-0.4 (24 May 2012)
+
+ 24 May 2012; Michael Weber <xmw@gentoo.org> +dietsniff-0.4.ebuild,
+ +metadata.xml:
+ Initial import (bug 108224)
+
diff --git a/net-analyzer/dietsniff/Manifest b/net-analyzer/dietsniff/Manifest
new file mode 100644
index 000000000000..e040fc7f8cb5
--- /dev/null
+++ b/net-analyzer/dietsniff/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST dietsniff-0.4.tar.gz 14375 RMD160 eb7ac3d75be7bbe77c24ea777dd2975aa7443102 SHA1 39727e4dc6f0daf8cbd6680d612c34168a2e37d8 SHA256 e8c38570b7c51080fcc8b274ffd1a423dca42793a4d304fd2ead96cde327c798
+EBUILD dietsniff-0.4.ebuild 1002 RMD160 0ec6a9c80801ca1b6710c6679b492ae6326fbd49 SHA1 24cb89be7a896a01f0c8c4cd19242e43b4008e1f SHA256 63bb25d0d8030c3224b3beaf2c4656a2875102248d1c7c4c0b9063577dd5f1c9
+MISC ChangeLog 361 RMD160 58752ce8aee1f09fd7391c0810998fc9ab4791dd SHA1 c03832cb1f4de973e2530f48975222c171631418 SHA256 f1a6fb73ad52a5ccdf974f1b2ae2985cdfed694e48dc4ed2dab8693503a9ee2f
+MISC metadata.xml 852 RMD160 68eff8960940305546ee51aac7ade477943c60ae SHA1 8b21ba80a1627417a60a07b6cc471faa48bdb15d SHA256 d59112535095c9c28c0d510f35352b04be182a4f400fe1e8be073412cd6f941f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk+94D0ACgkQknrdDGLu8JDQZgD+OGiP8aFyuVQKrMIWKNjpG0nA
+tRV0nPrsYT8Z+D62olgA/i6qnHWgDhHwFVH+JcvjYq6/DYO0J3u2g0/rj+qzOP2v
+=FGRE
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/dietsniff/dietsniff-0.4.ebuild b/net-analyzer/dietsniff/dietsniff-0.4.ebuild
new file mode 100644
index 000000000000..ba6fadef17a6
--- /dev/null
+++ b/net-analyzer/dietsniff/dietsniff-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dietsniff/dietsniff-0.4.ebuild,v 1.1 2012/05/24 07:16:11 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="small and static packet sniffer based on dietlibc and libowfat"
+HOMEPAGE="https://github.com/hynek/dietsniff"
+SRC_URI="https://github.com/hynek/dietsniff/tarball/a80c0e64b3 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-libs/libowfat
+ dev-libs/dietlibc"
+
+src_unpack() {
+ default
+
+ mv *-${PN}-* ${P} || die
+}
+
+src_prepare() {
+ sed -e '/^prefix=/s:=.*:=/usr:' \
+ -e '/^MAN1DIR=/s:man/man1:share/man/man1:' \
+ -e '/^CC/s:=:?=:' \
+ -e '/^CFLAGS/s:=:+=:' \
+ -e '/^LDFLAGS/s:=-s:+=:' \
+ -e '/^dietsniff/,+3s: -o : $(LDFLAGS) -o :' \
+ -e '/^dietsniff/,+3s:strip:#strip:' \
+ -i Makefile
+ export CC="diet -Os $(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/net-analyzer/dietsniff/metadata.xml b/net-analyzer/dietsniff/metadata.xml
new file mode 100644
index 000000000000..f60778796746
--- /dev/null
+++ b/net-analyzer/dietsniff/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+<upstream>
+ <bugs-to>https://github.com/hynek/dietsniff/issues</bugs-to>
+ <maintainer status="active">
+ <email>hs@ox.cx</email>
+ <name>Hynek Schlawack</name>
+ </maintainer>
+</upstream>
+<longdescription>
+dietsniff is a network-debugging tool like tcpdump or ethereal. The
+difference to those powerful tools however is that dietsniff is linked
+against Felix von Leitner's dietlibc and doesn't require libpcap.
+Therefore it's really small while being static. dietsniff's most
+useful scenario is probably to sniff the packets into a pcap-logfile which
+can be later viewed using more user friendly applications.
+</longdescription>
+</pkgmetadata>
+