summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRajiv Aaron Manglani <rajiv@gentoo.org>2003-02-28 07:00:03 +0000
committerRajiv Aaron Manglani <rajiv@gentoo.org>2003-02-28 07:00:03 +0000
commitef83934f8becd1712d69e897bfca7b34ffb448ab (patch)
tree5c5f690f761e7a885265e82d697cda44fbb088f9 /net-dns/dnstop/dnstop-20030124.ebuild
parentadd missing dependency (diff)
downloadhistorical-ef83934f8becd1712d69e897bfca7b34ffb448ab.tar.gz
historical-ef83934f8becd1712d69e897bfca7b34ffb448ab.tar.bz2
historical-ef83934f8becd1712d69e897bfca7b34ffb448ab.zip
Created initial ebuild.
Diffstat (limited to 'net-dns/dnstop/dnstop-20030124.ebuild')
-rw-r--r--net-dns/dnstop/dnstop-20030124.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-dns/dnstop/dnstop-20030124.ebuild b/net-dns/dnstop/dnstop-20030124.ebuild
new file mode 100644
index 000000000000..8334b6f396c8
--- /dev/null
+++ b/net-dns/dnstop/dnstop-20030124.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/dnstop-20030124.ebuild,v 1.1 2003/02/28 07:00:03 rajiv Exp $
+
+DESCRIPTION="Displays various tables of DNS traffic on your network."
+HOMEPAGE="http://dnstop.measurement-factory.com/"
+SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc"
+
+IUSE=""
+DEPEND=">=libpcap-0.7.1-r2"
+
+S=${WORKDIR}
+
+src_compile() {
+ cp Makefile Makefile.orig
+ sed -e "s:^CFLAGS=.*$:CFLAGS=${CFLAGS} -DUSE_PPP:" \
+ Makefile.orig > Makefile
+
+ emake || die
+}
+
+src_install() {
+ dobin dnstop
+ doman dnstop.8
+ dodoc LICENSE
+}