summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-10-19 14:10:26 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-10-19 14:10:26 +0000
commitb89821befaaae2dab4cfa19ea73cbe25c4be9267 (patch)
tree065df0da33ff17873b0d18257a5c399182d4b02b /net-dns
parentTry to fix bug #67681 by explicitly enabling javahl (diff)
downloadhistorical-b89821befaaae2dab4cfa19ea73cbe25c4be9267.tar.gz
historical-b89821befaaae2dab4cfa19ea73cbe25c4be9267.tar.bz2
historical-b89821befaaae2dab4cfa19ea73cbe25c4be9267.zip
Fixed deprecated head and tail usage, closes #67995. Optimized ebuild a bit. Added sys-apps/coreutils to RDEPEND. Set myself as maintainer.
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dlint/ChangeLog8
-rw-r--r--net-dns/dlint/Manifest15
-rw-r--r--net-dns/dlint/dlint-1.4.0-r1.ebuild35
-rw-r--r--net-dns/dlint/files/digest-dlint-1.4.0-r11
-rw-r--r--net-dns/dlint/metadata.xml9
5 files changed, 66 insertions, 2 deletions
diff --git a/net-dns/dlint/ChangeLog b/net-dns/dlint/ChangeLog
index fa66936d1bea..604a1e6b9c28 100644
--- a/net-dns/dlint/ChangeLog
+++ b/net-dns/dlint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/dlint
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/ChangeLog,v 1.5 2004/06/24 22:34:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/ChangeLog,v 1.6 2004/10/19 14:10:26 ticho Exp $
+
+ 19 Oct 2004; Andrej Kacian <ticho@gentoo.org> :
+ Fix deprecated use of head(1) and tail(1). Closes #67995, reported by Ray
+ Booysen <bugzilla.gentoo@rjb.za.net>. Also, optimized the ebuild a bit.
+ Added sys-apps/coreutils to DEPEND, since head and tail are provided by that
+ package. And finally, set myself as maintainer for dlint.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-dns/dlint/Manifest b/net-dns/dlint/Manifest
index c7f45518d973..e6df998b4e43 100644
--- a/net-dns/dlint/Manifest
+++ b/net-dns/dlint/Manifest
@@ -1,3 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 6e54d2acc280131e3a9a20ce998322db ChangeLog 1078
MD5 31c1b06680bc1b1ceb6de5e3662b09e9 dlint-1.4.0.ebuild 868
-MD5 b3e7063fa2b4990bbd6a57208e632d28 ChangeLog 741
+MD5 552e7f9eb455a38bbbd0bba59f1d5eda dlint-1.4.0-r1.ebuild 945
+MD5 0f516c20d49629e662ef970814e48522 metadata.xml 253
MD5 4885c47ebf525bab4ff5af0f22fc14c7 files/digest-dlint-1.4.0 61
+MD5 4885c47ebf525bab4ff5af0f22fc14c7 files/digest-dlint-1.4.0-r1 61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBdSBd10xuJSrg3/sRAuSaAJ9APcgRYvQxA2L+lIDaZebuCm5zQgCeOfbS
+5c2lvZYYA6zi57vcwGnnT1Y=
+=qvlb
+-----END PGP SIGNATURE-----
diff --git a/net-dns/dlint/dlint-1.4.0-r1.ebuild b/net-dns/dlint/dlint-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..4a999fd1c443
--- /dev/null
+++ b/net-dns/dlint/dlint-1.4.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0-r1.ebuild,v 1.1 2004/10/19 14:10:26 ticho Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P/-/}
+DESCRIPTION="Dlint analyzes any DNS zone you specify, and reports any problems it finds by displaying errors and warnings"
+SRC_URI="http://www.domtools.com/pub/${P/-/}.tar.gz"
+HOMEPAGE="http://www.domtools.com/dns/dlint.shtml"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+LICENSE="GPL-2"
+
+DEPEND=""
+RDEPEND="sys-apps/coreutils
+ net-dns/bind-tools
+ dev-lang/perl
+ app-shells/bash"
+
+src_compile() {
+ sed -i -e 's:rrfilt=\"/usr/local/bin/digparse\":rrfilt=\"/usr/bin/digparse\":' \
+ dlint
+ sed -i -e "s:head -:head -n :g" dlint
+ sed -i -e "s:tail +:tail -n +:g" dlint
+}
+
+src_install () {
+ dobin digparse
+ dobin dlint
+ doman dlint.1
+ dodoc BUGS COPYING INSTALL README CHANGES COPYRIGHT TESTCASES
+}
diff --git a/net-dns/dlint/files/digest-dlint-1.4.0-r1 b/net-dns/dlint/files/digest-dlint-1.4.0-r1
new file mode 100644
index 000000000000..4c5312ff26b3
--- /dev/null
+++ b/net-dns/dlint/files/digest-dlint-1.4.0-r1
@@ -0,0 +1 @@
+MD5 9fc692ab461af132a52a27a8dae1e07a dlint1.4.0.tar.gz 23007
diff --git a/net-dns/dlint/metadata.xml b/net-dns/dlint/metadata.xml
new file mode 100644
index 000000000000..c807e0bd930b
--- /dev/null
+++ b/net-dns/dlint/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ticho@gentoo.org</email>
+ <name>Andrej Kacian</name>
+ </maintainer>
+</pkgmetadata>