summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-10-04 00:13:06 +0000
committerJason Wever <weeve@gentoo.org>2003-10-04 00:13:06 +0000
commit78debc749ccd086fa9d4ce0a8a89097acfdcc751 (patch)
tree2cfcba66daa85dc7542f6d546c4d4c0df6e56ded /net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild
parentVersion bump to 0.5.2, fixes bug #30245. (diff)
downloadhistorical-78debc749ccd086fa9d4ce0a8a89097acfdcc751.tar.gz
historical-78debc749ccd086fa9d4ce0a8a89097acfdcc751.tar.bz2
historical-78debc749ccd086fa9d4ce0a8a89097acfdcc751.zip
Version bump to 0.5.2, fixes bug #30245.
Diffstat (limited to 'net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild')
-rw-r--r--net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild b/net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild
new file mode 100644
index 000000000000..c4808cc7f24e
--- /dev/null
+++ b/net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipkungfu/ipkungfu-0.5.2.ebuild,v 1.1 2003/10/04 00:13:02 weeve Exp $
+
+inherit eutils
+
+DESCRIPTION="A nice iptables firewall script"
+HOMEPAGE="http://www.linuxkungfu.org/"
+SRC_URI="http://www.linuxkungfu.org/ipkungfu/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND="virtual/glibc
+ net-firewall/iptables"
+
+
+src_unpack() {
+ unpack ${A}
+
+ # man page comes bzip2'd, so bunzip2 it.
+ cd ${WORKDIR}/${P}/files
+ bunzip2 ipkungfu.8.bz2
+}
+
+src_install() {
+
+ # Package comes with a hard coded shell script, so here we
+ # replicate what they did, but so it's compatible with portage.
+
+ # Install shell script executable
+ dosbin ipkungfu
+
+ # Install Gentoo init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ipkungfu.init ipkungfu
+
+ # Install config files into /etc
+ dodir /etc/ipkungfu
+ insinto /etc/ipkungfu
+ doins files/*.conf
+
+ # Install man page
+ doman files/ipkungfu.8
+
+ # Install documentation
+ dodoc COPYRIGHT Changelog FAQ INSTALL README gpl.txt
+}
+
+
+pkg_postinst() {
+ einfo "Be sure to edit the config files"
+ einfo "in /etc/ipkungfu before running"
+}
+