summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-22 08:25:51 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-22 08:25:51 +0000
commitabf8f81920d297f57632f9269abcebb9a8796fef (patch)
treef8530d67c780c6e50f879cfcce4b734c44763fd6 /net-firewall/shorewall-shell
parentVersion bump. Removed old. (diff)
downloadhistorical-abf8f81920d297f57632f9269abcebb9a8796fef.tar.gz
historical-abf8f81920d297f57632f9269abcebb9a8796fef.tar.bz2
historical-abf8f81920d297f57632f9269abcebb9a8796fef.zip
Version bump, bug #255437, thank Vieri for all work.
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'net-firewall/shorewall-shell')
-rw-r--r--net-firewall/shorewall-shell/ChangeLog11
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.15.ebuild54
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.2.4.ebuild55
3 files changed, 118 insertions, 2 deletions
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index 54bef55ad083..a34ae10ede2f 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/shorewall-shell
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.20 2008/11/21 11:33:37 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.21 2009/01/22 08:24:52 pva Exp $
+
+*shorewall-shell-4.2.4 (22 Jan 2009)
+*shorewall-shell-4.0.15 (22 Jan 2009)
+
+ 22 Jan 2009; Peter Volkov <pva@gentoo.org> +shorewall-shell-4.0.15.ebuild,
+ +shorewall-shell-4.2.4.ebuild:
+ Version bump, bug #255437, thank Vieri for all work.
*shorewall-shell-4.2.1 (21 Nov 2008)
*shorewall-shell-4.0.14.1 (21 Nov 2008)
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.15.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.15.ebuild
new file mode 100644
index 000000000000..c22ec1ecb31c
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.15.ebuild,v 1.1 2009/01/22 08:24:52 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # shorewall-common version to use (ignoring upstream "compatibility matrix" for now as it is not always updated at the same time as the software is released)
+
+MY_PN="${PN/-shell/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.2.4.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.2.4.ebuild
new file mode 100644
index 000000000000..f1d71e5e9594
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.2.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.2.4.ebuild,v 1.1 2009/01/22 08:24:52 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # shorewall-common version to use (ignoring upstream "compatibility matrix" for now as it is not always updated at the same time as the software is released)
+
+MY_PN="${PN/-shell/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+RDEPEND="${DEPEND}"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}