summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-01-03 08:51:20 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-01-03 08:51:20 +0000
commit3e27c16856caa9df379fd4b05410fe4c834c8e3a (patch)
treef9c0cec14165d95969cac5bbf2df5e2192f64274 /net-firewall/shorewall
parentConvert make_desktop_entry() comment block to be eclass-manpages conform, #39... (diff)
downloadhistorical-3e27c16856caa9df379fd4b05410fe4c834c8e3a.tar.gz
historical-3e27c16856caa9df379fd4b05410fe4c834c8e3a.tar.bz2
historical-3e27c16856caa9df379fd4b05410fe4c834c8e3a.zip
Version Bump
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/ChangeLog10
-rw-r--r--net-firewall/shorewall/shorewall-4.4.27.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index d2006e63ab8a..673670ec881d 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.199 2011/11/13 14:55:09 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.200 2012/01/03 08:51:20 constanze Exp $
+
+*shorewall-4.4.27 (03 Jan 2012)
+
+ 03 Jan 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-4.4.27.ebuild:
+ Version bump
13 Nov 2011; Markus Meier <maekke@gentoo.org> shorewall-4.4.23.2.ebuild:
x86 stable, bug #388195
diff --git a/net-firewall/shorewall/shorewall-4.4.27.ebuild b/net-firewall/shorewall/shorewall-4.4.27.ebuild
new file mode 100644
index 000000000000..a3ae42eab59a
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.4.27.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.4.27.ebuild,v 1.1 2012/01/03 08:51:20 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}"
+MY_P_DOCS="${P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}
+
+pkg_postinst() {
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+}