summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-16 19:36:00 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-16 19:36:00 +0000
commit11483df79c396727b79ec31a725177f05f29d69e (patch)
tree7bddad52a7ffc639c6f4f45c93c28c4071b8794e /net-fs/nfs-utils
parentAdded digest (diff)
downloadhistorical-11483df79c396727b79ec31a725177f05f29d69e.tar.gz
historical-11483df79c396727b79ec31a725177f05f29d69e.tar.bz2
historical-11483df79c396727b79ec31a725177f05f29d69e.zip
Updated nfs-utils for new init system
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-0.3.1-r61
-rw-r--r--net-fs/nfs-utils/files/nfs-0.3.1-r6125
-rw-r--r--net-fs/nfs-utils/files/nfsmount-0.3.1-r645
-rw-r--r--net-fs/nfs-utils/nfs-utils-0.3.1-r6.ebuild50
4 files changed, 221 insertions, 0 deletions
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-0.3.1-r6 b/net-fs/nfs-utils/files/digest-nfs-utils-0.3.1-r6
new file mode 100644
index 000000000000..d20ba330f224
--- /dev/null
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-0.3.1-r6
@@ -0,0 +1 @@
+MD5 7acac2d055067d48bf5bc4b4d0fc630f nfs-utils-0.3.1.tar.gz
diff --git a/net-fs/nfs-utils/files/nfs-0.3.1-r6 b/net-fs/nfs-utils/files/nfs-0.3.1-r6
new file mode 100644
index 000000000000..dd44496a3104
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-0.3.1-r6
@@ -0,0 +1,125 @@
+#!/sbin/runscript
+
+#---------------------------------------------------------------------------
+# This script starts/stops the following
+# rpc.statd if necessary (also checked by init.d/nfsmount)
+# rpd.rquotad
+# rpd.nfsd
+# rpc.mountd
+#
+# (17 Aug 2001 agriffis)
+#---------------------------------------------------------------------------
+
+# These can be overridden in /etc/rc.d/config/basic if desired
+RPCNFSDCOUNT=8 # Number of servers to be started up by default
+RPCMOUNTDOPTS=
+
+# This variable is used for controlling whether or not to run exportfs -ua;
+# see stop() for more information
+RESTARTING=no
+
+opts="start stop restart reload"
+
+depend() {
+ need net portmap
+}
+
+start_statd() {
+ # Don't start rpc.statd if already started by init.d/nfsmount
+ killall -0 rpc.statd &>/dev/null && return 0
+ ebegin "Starting NFS statd"
+ start-stop-daemon --start --quiet --exec /sbin/rpc.statd 1>&2
+ eend $? "Error starting NFS statd"
+}
+
+stop_statd() {
+ # Don't stop rpc.statd if it's in use by init.d/nfsmount.
+ mount -t nfs | grep -q . && return 0
+ # Make sure it's actually running
+ killall -0 rpc.statd &>/dev/null || return 0
+ # Okay, all tests passed, stop rpc.statd
+ ebegin "Stopping NFS statd"
+ start-stop-daemon --stop --quiet --exec /sbin/rpc.statd 1>&2
+ eend $? "Error stopping NFS statd"
+}
+
+start() {
+ if [ "$NFSSERVER" = "yes" ]
+ then
+ start_statd
+
+ if grep -q '^/' /etc/exports &>/dev/null; then
+ ebegin "Exporting NFS directories"
+ /sbin/exportfs -r 1>&2
+ eend $? "Error exporting NFS directories"
+ fi
+
+ ebegin "Starting NFS rquotad"
+ start-stop-daemon --start --quiet --exec /sbin/rpc.rquotad 1>&2
+ eend $? "Error starting NFS rquotad"
+
+ ebegin "Starting NFS daemon"
+ start-stop-daemon --start --quiet --exec \
+ /sbin/rpc.nfsd -- $RPCNFSDCOUNT 1>&2
+ eend $? "Error starting NFS daemon"
+
+ # Check if we support NFSv3
+ ebegin "Starting NFS mountd"
+ rpcinfo -u localhost nfs 3 &>/dev/null || \
+ RPCMOUNTDOPTS="$RPCMOUNTDOPTS --no-nfs-version 3"
+ start-stop-daemon --start --quiet --exec \
+ /sbin/rpc.mountd -- $RPCMOUNTDOPTS 1>&2
+ eend $? "Error starting NFS mountd"
+ fi
+}
+
+stop() {
+ # Don't check NFSSERVER variable since it might have changed,
+ # instead use --oknodo to smooth things over
+ ebegin "Stopping NFS mountd"
+ start-stop-daemon --stop --quiet --oknodo \
+ --exec /sbin/rpc.mountd 1>&2
+ eend $? "Error stopping NFS mountd"
+
+ ebegin "Stopping NFS daemon"
+ start-stop-daemon --stop --quiet --oknodo \
+ --name nfsd --user root --signal 2 1>&2
+ eend $? "Error stopping NFS daemon"
+
+ ebegin "Stopping NFS rquotad"
+ start-stop-daemon --stop --quiet --oknodo \
+ --exec /sbin/rpc.rquotad 1>&2
+ eend $? "Error stopping NFS rquotad"
+
+ # When simply restarting the NFS server, running "exportfs -ua"
+ # probably isn't what the user wants. Running it causes all
+ # entries listed in xtab to be removed from the kernel export
+ # tables, and the xtab file is cleared. This effectively shuts
+ # down all NFS activity, leaving all clients holding stale NFS
+ # filehandles, /even/ when the NFS server has restarted.
+ #
+ # This is what you would want if you were shutting down the NFS
+ # server for good, or for a long period of time, but not when the
+ # NFS server will be running again in short order. In this case,
+ # then "exportfs -r" will reread the xtab, and all the current
+ # clients will be able to resume NFS activity, /without/ needing
+ # to umount/(re)mount the filesystem.
+ if [ "$RESTARTING" = no ]; then
+ ebegin "Unexporting NFS directories"
+ /sbin/exportfs -ua 1>&2
+ eend $? "Error unexporting NFS directories"
+ fi
+
+ stop_statd
+}
+
+reload() {
+ /sbin/exportfs -r
+}
+
+restart() {
+ # See comment in stop() regarding exportfs -ua
+ RESTARTING=yes
+ stop
+ start
+}
diff --git a/net-fs/nfs-utils/files/nfsmount-0.3.1-r6 b/net-fs/nfs-utils/files/nfsmount-0.3.1-r6
new file mode 100644
index 000000000000..bb9d64a2acbf
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfsmount-0.3.1-r6
@@ -0,0 +1,45 @@
+#!/sbin/runscript
+
+opts="start stop restart"
+
+depend() {
+ need net portmap
+}
+
+start_statd() {
+ # Don't start rpc.statd if already started by init.d/nfs
+ killall -0 rpc.statd &>/dev/null && return 0
+ ebegin "Starting NFS statd"
+ start-stop-daemon --start --quiet --exec /sbin/rpc.statd 1>&2
+ eend $? "Error starting NFS statd"
+}
+
+stop_statd() {
+ # Don't stop rpc.statd if it's in use by init.d/nfs
+ killall -0 nfsd &>/dev/null && return 0
+ # Make sure it's actually running
+ killall -0 rpc.statd &>/dev/null || return 0
+ # Okay, all tests passed, stop rpc.statd
+ ebegin "Stopping NFS statd"
+ start-stop-daemon --stop --quiet --exec /sbin/rpc.statd 1>&2
+ eend $? "Error stopping NFS statd"
+}
+
+start() {
+ start_statd
+ ebegin "Mounting NFS filesystems"
+ mount -a -t nfs
+ eend $? "Error mounting NFS filesystems"
+}
+
+stop() {
+ ebegin "Unmounting NFS filesystems"
+ umount -a -t nfs
+ eend $? "Error unmounting NFS filesystems"
+ stop_statd
+}
+
+restart() {
+ stop
+ start
+}
diff --git a/net-fs/nfs-utils/nfs-utils-0.3.1-r6.ebuild b/net-fs/nfs-utils/nfs-utils-0.3.1-r6.ebuild
new file mode 100644
index 000000000000..187dcefb55e2
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-0.3.1-r6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Originally written by Achim Gottinger <achim@gentoo.org>
+# Heavily updated for nfs-utils-0.3.1 by Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-0.3.1-r6.ebuild,v 1.1 2001/09/16 19:36:00 agriffis Exp $
+
+A=$P.tar.gz
+S=$WORKDIR/$P
+DESCRIPTION="kernel NFS daemons"
+SRC_URI="http://download.sourceforge.net/nfs/$A"
+HOMEPAGE="http://nfs.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+RDEPEND="virtual/glibc net-nds/portmap"
+
+src_unpack() {
+ unpack $A || die
+ cd $S || die
+ patch -p1 < $FILESDIR/$PF-gentoo.diff || die
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/ \
+ --mandir=/usr/share/man \
+ --with-statedir=/var/lib/nfs \
+ --enable-nfsv3 || die
+ if ! use tcpd; then
+ cp config.mk config.mk.orig
+ sed -e "s:-lwrap::" -e "s:-DHAVE_TCP_WRAPPER::" \
+ config.mk.orig > config.mk
+ fi
+ make || die
+}
+
+src_install() {
+ # MANDIR doesn't pick up install_prefix
+ make install install_prefix=$D MANDIR=$D/usr/share/man || die
+ install -m 644 $FILESDIR/exports-$PVR $D/etc/exports || die
+ dodoc ChangeLog COPYING README
+ docinto linux-nfs
+ dodoc linux-nfs/*
+ # Install init scripts in the new rc6 location
+ mkdir -p $D/etc/init.d $D/etc/runlevels/default
+ install -m 755 $FILESDIR/nfs-$PVR $D/etc/init.d/nfs || die
+ install -m 755 $FILESDIR/nfsmount-$PVR $D/etc/init.d/nfsmount || die
+ ln -s ../../init.d/nfs{,mount} $D/etc/runlevels/default || die
+}