summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-28 05:24:13 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-28 05:24:13 +0000
commit2976aa64c576eb5d76d265f70f3a9097dfdeb3ac (patch)
treedc5a008a22e16e21bc4ea4f991bba0890fae4a1b /net-fs
parentAdded DarcNES a multi-system emulator (diff)
downloadhistorical-2976aa64c576eb5d76d265f70f3a9097dfdeb3ac.tar.gz
historical-2976aa64c576eb5d76d265f70f3a9097dfdeb3ac.tar.bz2
historical-2976aa64c576eb5d76d265f70f3a9097dfdeb3ac.zip
Dependencie fixes
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/autofs-3.1.7-r1.ebuild19
-rw-r--r--net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild13
-rw-r--r--net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild19
3 files changed, 31 insertions, 20 deletions
diff --git a/net-fs/autofs/autofs-3.1.7-r1.ebuild b/net-fs/autofs/autofs-3.1.7-r1.ebuild
index bbff7f9741e4..ca190e188a96 100644
--- a/net-fs/autofs/autofs-3.1.7-r1.ebuild
+++ b/net-fs/autofs/autofs-3.1.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-3.1.7-r1.ebuild,v 1.1 2001/01/18 18:22:11 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-3.1.7-r1.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
A=${P}.tar.bz2
S=${WORKDIR}/${P}
@@ -10,8 +10,8 @@ SRC_URI="ftp://ftp.kernel.org/pub/linux/daemons/autofs/${A}
ftp://ftp.de.kernel.org/pub/linux/daemons/autofs/${A}
ftp://ftp.uk.kernel.org/pub/linux/daemons/autofs/${A}"
-DEPEND=">=sys-libs/glibc-2.1.3
- >=net-nds/openldap-1.2"
+DEPEND="virtual/glibc
+ ldap? ( =net-nds/openlpad-1.2.11-r2 )"
src_unpack() {
unpack ${A}
@@ -19,14 +19,17 @@ src_unpack() {
patch -p0 < ${FILESDIR}/automount.diff
}
-src_compile() {
- cd ${S}
- try ./configure --host=${HOST} --prefix=/usr
+src_compile() {
+ local myconf
+ if [ -z "`use ldap`" ] ; then
+ myconf="--without-openldap"
+ fi
+ try ./configure --host=${HOST} --prefix=/usr $myconf
try make
}
-src_install() {
- cd ${S}
+src_install() {
+
into /usr
dosbin daemon/automount
insinto /usr/lib/autofs
diff --git a/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild b/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild
index b924858c838d..e4b9d1210af7 100644
--- a/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild
+++ b/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild,v 1.1 2000/11/26 20:54:18 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.4.99.0.20001108.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
P=netatalk-1.4.99-0.20001108
A=${P}.tar.gz
@@ -10,11 +10,14 @@ DESCRIPTION="Apple-Talk"
SRC_URI="http://download.sourceforge.net/netatalk/${A}"
HOMEPAGE="http://netatakl.sourceforge.net"
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3"
+DEPEND="virtual/glibc
+ pam? ( sys-libs/pam-0.7 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ sys-apps/shadow"
+
+src_compile() {
+
-src_compile() {
- cd ${S}
try ./configure --prefix=/usr --host=${CHOST} \
--with-pam --with-shadow --with-tcp-wrappers
diff --git a/net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild b/net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild
index 68f90c5847a8..1b080e08b8c9 100644
--- a/net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild,v 1.2 2001/04/23 17:29:38 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-0.2.1-r3.ebuild,v 1.3 2001/05/28 05:24:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,8 +9,8 @@ DESCRIPTION="Kernel NFS-Server"
SRC_URI="ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/"${A}
HOMEPAGE="http://nfs.sourceforge.net"
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3"
+DEPEND="virtual/glibc
+ tcpd? ( sys-apps/tcp-wrappers )"
src_unpack() {
unpack ${A}
@@ -20,15 +20,20 @@ src_unpack() {
src_compile() {
try ./configure --mandir=${D}/usr/share/man --with-statedir=/var/lib/nfs \
--prefix=${D} --exec-prefix=${D}
+ if [ -z "`use tcpd`" ] ; then
+ cp config.mk config.mk.orig
+ sed -e "s:-lwrap::" -e "s:-DHAVE_TCP_WRAPPER::" \
+ config.mk.orig > config.mk
+ fi
try make
}
-src_install() {
- cd ${S}
+src_install() {
+
try make install STATEDIR=${D}/var/lib/nfs
dodir /etc/rc.d/init.d
- cp ${O}/files/nfs ${D}/etc/rc.d/init.d
- cp ${O}/files/exports ${D}/etc
+ cp ${FILESDIR}/nfs ${D}/etc/rc.d/init.d
+ cp ${FILESDIR}/exports ${D}/etc
dodoc ChangeLog COPYING README
docinto linux-nfs
dodoc linux-nfs/*