summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-11 14:13:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-11 14:13:10 +0000
commitb41dccd65c46e6b9bfca0b76d3eae0ed8ecaa010 (patch)
treeb96977fded00ef8dbb652c65e24e331fa629ee40 /net-ftp/kftpgrabber
parentFix spelling issues, bug #112160. (diff)
downloadhistorical-b41dccd65c46e6b9bfca0b76d3eae0ed8ecaa010.tar.gz
historical-b41dccd65c46e6b9bfca0b76d3eae0ed8ecaa010.tar.bz2
historical-b41dccd65c46e6b9bfca0b76d3eae0ed8ecaa010.zip
Added patches to compile using Qt 3.3.5 (stricter uic) and GCC4 (stricter compiler).
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-ftp/kftpgrabber')
-rw-r--r--net-ftp/kftpgrabber/ChangeLog8
-rw-r--r--net-ftp/kftpgrabber/Manifest18
-rw-r--r--net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch70
-rw-r--r--net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch26
-rw-r--r--net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild11
5 files changed, 127 insertions, 6 deletions
diff --git a/net-ftp/kftpgrabber/ChangeLog b/net-ftp/kftpgrabber/ChangeLog
index d3827c95e13a..05b86b69d51b 100644
--- a/net-ftp/kftpgrabber/ChangeLog
+++ b/net-ftp/kftpgrabber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/kftpgrabber
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/ChangeLog,v 1.7 2005/07/28 14:24:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/ChangeLog,v 1.8 2005/11/11 14:13:10 flameeyes Exp $
+
+ 11 Nov 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kftpgrabber-0.6.0-gcc4.patch, +files/kftpgrabber-0.6.0-uic.patch,
+ kftpgrabber-0.6.0.ebuild:
+ Added patches to compile using Qt 3.3.5 (stricter uic) and GCC4 (stricter
+ compiler).
28 Jul 2005; Caleb Tennis <caleb@gentoo.org> -kftpgrabber-0.5.0.ebuild:
Remove old build
diff --git a/net-ftp/kftpgrabber/Manifest b/net-ftp/kftpgrabber/Manifest
index 9da234e28551..0e54bdb74045 100644
--- a/net-ftp/kftpgrabber/Manifest
+++ b/net-ftp/kftpgrabber/Manifest
@@ -1,4 +1,16 @@
-MD5 6f5f4d442878b5be833a487c912fdea2 kftpgrabber-0.6.0.ebuild 542
-MD5 16471c268055299cd411923d937d913c ChangeLog 1023
-MD5 02039d51ca4a42817775fd436dfaa956 metadata.xml 157
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 70d2ec6d51ac5cd293c55f85678bfde5 ChangeLog 1273
MD5 655b1b8780d7db4a2af5b6ce1ce0cfd8 files/digest-kftpgrabber-0.6.0 71
+MD5 288e8f880999088f99c5d33c19b875f3 files/kftpgrabber-0.6.0-gcc4.patch 2222
+MD5 225f4b81821c40c533b31665a32de321 files/kftpgrabber-0.6.0-uic.patch 1049
+MD5 6063a712f85738f73e99c5e5a691b229 kftpgrabber-0.6.0.ebuild 663
+MD5 02039d51ca4a42817775fd436dfaa956 metadata.xml 157
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDdKcKAiZjviIA2XgRArETAKDkSKBB5CYK9LmWC2Kc5cTTa5YALwCfdRBf
+5EU4Lb5+7TvwR0VSvGUBtXc=
+=LXjJ
+-----END PGP SIGNATURE-----
diff --git a/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch
new file mode 100644
index 000000000000..0f51868bc0ea
--- /dev/null
+++ b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch
@@ -0,0 +1,70 @@
+Index: kftpgrabber-0.6.0/kftpgrabber/src/kftptransfer.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/kftptransfer.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/kftptransfer.h
+@@ -44,6 +44,7 @@
+ #include <kurl.h>
+
+ class KFTPSession;
++class KFTPQueueManager;
+
+ namespace KFTPQueue {
+
+@@ -61,8 +62,8 @@ This class is the base class for all tra
+ class Transfer : public QObject
+ {
+ friend class TransferDir;
+-friend class KFTPQueueManager;
+-friend class KFTPSession;
++friend class ::KFTPQueueManager;
++friend class ::KFTPSession;
+ Q_OBJECT
+ public:
+ enum Status {
+Index: kftpgrabber-0.6.0/kftpgrabber/src/kftptransferfile.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/kftptransferfile.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/kftptransferfile.h
+@@ -39,6 +39,7 @@
+ #include "kftptransfer.h"
+
+ class KFTPSessionConnection;
++class KFTPQueueManager;
+
+ namespace KFTPNetwork {
+ class Error;
+@@ -54,7 +55,7 @@ namespace KFTPQueue {
+ class TransferFile : public Transfer
+ {
+ Q_OBJECT
+-friend class KFTPQueueManager;
++friend class ::KFTPQueueManager;
+ public:
+ TransferFile(QObject *parent);
+ ~TransferFile();
+Index: kftpgrabber-0.6.0/kftpgrabber/src/widgets/filedirview/kftpfilepropsplugin.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/widgets/filedirview/kftpfilepropsplugin.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/widgets/filedirview/kftpfilepropsplugin.h
+@@ -41,6 +41,8 @@
+
+ #include "kftpclientthread.h"
+
++class KFTPSession;
++
+ /**
+ This is a plugin for displaying remote file properties using standard KDE file properties dialog.
+
+Index: kftpgrabber-0.6.0/kftpgrabber/src/widgets/kftpservermanagementlistview.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/widgets/kftpservermanagementlistview.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/widgets/kftpservermanagementlistview.h
+@@ -48,7 +48,7 @@ class KFTPSession;
+ class KListViewItem;
+ class KFTPClientThr;
+ class KActionCollection;
+-
++class KFTPServerManagementDialog;
+
+ /**
+ * @author Blacknator
diff --git a/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch
new file mode 100644
index 000000000000..83da5136f212
--- /dev/null
+++ b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch
@@ -0,0 +1,26 @@
+Index: kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpqueueeditorlayout.ui
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/ui/kftpqueueeditorlayout.ui
++++ kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpqueueeditorlayout.ui
+@@ -322,9 +322,6 @@
+ </images>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+- <includehint>kftpserverlineedit.h</includehint>
+- <includehint>kpassdlg.h</includehint>
+- <includehint>kftpserverlineedit.h</includehint>
+ <includehint>kpassdlg.h</includehint>
+ </includehints>
+ </UI>
+Index: kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpsearchlayout.ui
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/ui/kftpsearchlayout.ui
++++ kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpsearchlayout.ui
+@@ -240,7 +240,6 @@
+ </images>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+- <includehint>kftpserverlineedit.h</includehint>
+ <includehint>kpassdlg.h</includehint>
+ </includehints>
+ </UI>
diff --git a/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild b/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild
index 915900e8b572..431b8594efcf 100644
--- a/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild
+++ b/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild,v 1.3 2005/07/26 13:44:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild,v 1.4 2005/11/11 14:13:10 flameeyes Exp $
-inherit kde
+inherit kde eutils
DESCRIPTION="A graphical FTP client for KDE."
HOMEPAGE="http://kftpgrabber.sourceforge.net/"
@@ -18,3 +18,10 @@ DEPEND="dev-libs/openssl"
# TODO: support for dev-libs/qsa
need-kde 3.3
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch "${FILESDIR}/${P}-uic.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}