summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-06-19 06:13:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-06-19 06:13:50 +0000
commit4937f2e7d47b924ab11997b74dead77289b09282 (patch)
treedfd9aa57936339b3ac415a4c933285843aeb4a3c /net-ftp/lftp/lftp-3.1.4.ebuild
parentEd Presutti says: eclair now needs sqlite3 (diff)
downloadhistorical-4937f2e7d47b924ab11997b74dead77289b09282.tar.gz
historical-4937f2e7d47b924ab11997b74dead77289b09282.tar.bz2
historical-4937f2e7d47b924ab11997b74dead77289b09282.zip
version bump
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-ftp/lftp/lftp-3.1.4.ebuild')
-rw-r--r--net-ftp/lftp/lftp-3.1.4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-ftp/lftp/lftp-3.1.4.ebuild b/net-ftp/lftp/lftp-3.1.4.ebuild
new file mode 100644
index 000000000000..2a8a6f32e2db
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.1.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.1.4.ebuild,v 1.1 2005/06/19 06:13:50 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program"
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
+IUSE="ssl socks5 nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )
+ virtual/libc
+ !ppc-macos? ( sys-libs/readline
+ socks5? ( >=net-proxy/dante-1.1.12 )
+ )
+ sys-apps/gawk
+ sys-devel/bison
+ sys-devel/libtool"
+
+RDEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ virtual/libc
+ !ppc-macos? ( sys-libs/readline
+ socks5? ( >=net-proxy/dante-1.1.12 )
+ )"
+
+src_compile() {
+ local myconf="`use_enable nls`"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}