summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-12-29 23:30:13 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-12-29 23:30:13 +0000
commitbd10d4146909a40d03d3efce90160d8226de5088 (patch)
tree038ca30fae733f8bff3fe28788c44d808eb99938 /net-ftp/proftpd/files
parentInitial import (diff)
downloadhistorical-bd10d4146909a40d03d3efce90160d8226de5088.tar.gz
historical-bd10d4146909a40d03d3efce90160d8226de5088.tar.bz2
historical-bd10d4146909a40d03d3efce90160d8226de5088.zip
Fixes USE=nls and build failure(sparc) on Gentoo/FreeBSD. Thanks to Dmitri Bogomolov and Naohiro Aota (bug #354295) and Tibor Vago (bug #393189)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'net-ftp/proftpd/files')
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3682.patch146
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3728.patch11
2 files changed, 157 insertions, 0 deletions
diff --git a/net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3682.patch b/net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3682.patch
new file mode 100644
index 000000000000..c6ebef741a47
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3682.patch
@@ -0,0 +1,146 @@
+--- configure
++++ configure
+@@ -15457,7 +15457,7 @@
+ fi
+
+
+- { echo "$as_me:$LINENO: checking for iconv_open in -liconv" >&5
++ { echo "$as_me:$LINENO: checking for iconv_open in -liconv" >&5
+ echo $ECHO_N "checking for iconv_open in -liconv... $ECHO_C" >&6; }
+ if test "${ac_cv_lib_iconv_iconv_open+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+@@ -15533,6 +15533,82 @@
+ ENABLE_NLS="1"
+
+ else
++ { echo "$as_me:$LINENO: checking for libiconv_open in -liconv" >&5
++echo $ECHO_N "checking for libiconv_open in -liconv... $ECHO_C" >&6; }
++if test "${ac_cv_lib_iconv_libiconv_open+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-liconv $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any GCC internal prototype to avoid an error.
++ Use char because int might match the return type of a GCC
++ builtin and then its argument prototype would still apply. */
++#ifdef __cplusplus
++extern "C"
++#endif
++char libiconv_open ();
++int
++main ()
++{
++return libiconv_open ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (ac_try="$ac_link"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_link") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } && {
++ test -z "$ac_c_werror_flag" ||
++ test ! -s conftest.err
++ } && test -s conftest$ac_exeext &&
++ $as_test_x conftest$ac_exeext; then
++ ac_cv_lib_iconv_libiconv_open=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_cv_lib_iconv_libiconv_open=no
++fi
++
++rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_lib_iconv_libiconv_open" >&5
++echo "${ECHO_T}$ac_cv_lib_iconv_libiconv_open" >&6; }
++if test $ac_cv_lib_iconv_libiconv_open = yes; then
++ LIBS="$LIBS -liconv"
++
++cat >>confdefs.h <<\_ACEOF
++#define HAVE_LIBICONV 1
++_ACEOF
++
++
++cat >>confdefs.h <<\_ACEOF
++#define PR_USE_NLS 1
++_ACEOF
++
++ ENABLE_NLS="1"
++
++else
+ { echo "$as_me:$LINENO: checking for iconv_open in -lc" >&5
+ echo $ECHO_N "checking for iconv_open in -lc... $ECHO_C" >&6; }
+ if test "${ac_cv_lib_c_iconv_open+set}" = set; then
+@@ -15600,7 +15676,7 @@
+ #define PR_USE_NLS 1
+ _ACEOF
+
+- ENABLE_NLS="1"
++ ENABLE_NLS="1"
+
+ else
+ { { echo "$as_me:$LINENO: error: libiconv support, required for NLS, not present -- aborting" >&5
+@@ -15609,6 +15685,9 @@
+
+ fi
+
++
++fi
++
+
+ fi
+
+--- configure.in
++++ configure.in
+@@ -715,18 +715,26 @@
+ )
+
+ dnl Similarly, the libiconv library is only needed on some non-GNU
+- dnl systems.
++ dnl systems. Note that some systems redefine the iconv_open function
++ dnl to something else (Bug#3682), e.g. libiconv_open.
+ AC_CHECK_LIB(iconv, iconv_open,
+ [LIBS="$LIBS -liconv"
+ AC_DEFINE(HAVE_LIBICONV, 1, [Define if libiconv is present.])
+ AC_DEFINE(PR_USE_NLS, 1, [Define if using NLS support.])
+ ENABLE_NLS="1"
+ ],
+- [AC_CHECK_LIB(c, iconv_open,
+- [AC_DEFINE(PR_USE_NLS, 1, [Define if using NLS support.])
++ [AC_CHECK_LIB(iconv, libiconv_open,
++ [LIBS="$LIBS -liconv"
++ AC_DEFINE(HAVE_LIBICONV, 1, [Define if libiconv is present.])
++ AC_DEFINE(PR_USE_NLS, 1, [Define if using NLS support.])
+ ENABLE_NLS="1"
+ ],
+- [AC_MSG_ERROR([libiconv support, required for NLS, not present -- aborting])]
++ [AC_CHECK_LIB(c, iconv_open,
++ [AC_DEFINE(PR_USE_NLS, 1, [Define if using NLS support.])
++ ENABLE_NLS="1"
++ ],
++ [AC_MSG_ERROR([libiconv support, required for NLS, not present -- aborting])]
++ ])
+ ])
+ )
+ fi
diff --git a/net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3728.patch b/net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3728.patch
new file mode 100644
index 000000000000..8f656dd8a899
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.3.4a-ubug-3728.patch
@@ -0,0 +1,11 @@
+--- src/wtmp.c
++++ src/wtmp.c
+@@ -42,7 +42,7 @@
+ !(defined(LINUX) || defined(__hpux) || defined (_AIX))
+ /* This "auxilliary" utmp doesn't exist under linux. */
+
+-#if defined(__sparcv9) && !defined(__NetBSD__)
++#if defined(__sparcv9) && !defined(__NetBSD__) && !defined(__FreeBSD__)
+ struct futmpx utx;
+ time_t t;
+