summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-12-15 19:04:17 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-12-15 19:04:17 +0000
commitc8989c7caca90a997bb5b5d66fa17b720a77c06c (patch)
treecd65468b32b00ad716d96d99306c7562e45fffbf /net-ftp
parentUpdate, security advisory #35866 (diff)
downloadhistorical-c8989c7caca90a997bb5b5d66fa17b720a77c06c.tar.gz
historical-c8989c7caca90a997bb5b5d66fa17b720a77c06c.tar.bz2
historical-c8989c7caca90a997bb5b5d66fa17b720a77c06c.zip
Update, security advisory #35866
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/Manifest4
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.101
-rw-r--r--net-ftp/lftp/lftp-2.6.10.ebuild53
3 files changed, 56 insertions, 2 deletions
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index b150ee25ab0e..6944fb19f948 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1,5 +1,5 @@
MD5 87a127e2d12bd6030401957fdef829fa lftp-2.5.4-r1.ebuild 1234
-MD5 2e1849f7938ee7a06e0ae9b6c283eae9 ChangeLog 5096
+MD5 cfcdaff10d2d4b4d72331570505a40d2 ChangeLog 5217
MD5 18477b1232fc6f3f0eb8ab2f55073fd5 lftp-2.6.2.ebuild 1605
MD5 7d8cdc34af7fd9ac47db4832ab8c2407 lftp-2.6.3.ebuild 1426
MD5 1a7eb0a431eca5daa8c74690cc3e7a1d lftp-2.6.4.ebuild 1408
@@ -7,7 +7,7 @@ MD5 d4ed32462097adfb3aa551d252d5e35f lftp-2.6.5.ebuild 1773
MD5 64ab3dacc5e1a56a179575d8d784d8bd lftp-2.6.6.ebuild 1660
MD5 d944e75cb2b4582f25561b96dfe66c66 lftp-2.6.7.ebuild 1352
MD5 809e9a90894ca9f06065a21a48fbb78c lftp-2.6.8.ebuild 1350
-MD5 809e9a90894ca9f06065a21a48fbb78c lftp-2.6.10.ebuild 1350
+MD5 7dc6abd5cb858d8b233abb65de6ccb77 lftp-2.6.10.ebuild 1352
MD5 096d8792a2b0989e03d9a39f8f5a2495 files/configure-lftp-2.6.2.diff 717
MD5 b39ba922d0d3b3f4a352d25f38d88364 files/digest-lftp-2.5.4-r1 64
MD5 f2a4efd6f8acc770b7e2603e9340d0e9 files/digest-lftp-2.6.2 64
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.10 b/net-ftp/lftp/files/digest-lftp-2.6.10
new file mode 100644
index 000000000000..eba7e6f4657c
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.10
@@ -0,0 +1 @@
+MD5 851387ab94bad8013d20ba7d3758b603 lftp-2.6.10.tar.bz2 1198513
diff --git a/net-ftp/lftp/lftp-2.6.10.ebuild b/net-ftp/lftp/lftp-2.6.10.ebuild
new file mode 100644
index 000000000000..2128550f8d9e
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.10.ebuild,v 1.1 2003/12/15 19:04:01 spider Exp $
+
+IUSE="ssl socks5 nls"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf}
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}