summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-03-15 01:48:19 +0000
committerDon Seiler <rizzo@gentoo.org>2004-03-15 01:48:19 +0000
commit665adfc7b3376753c9778fd2e8bccb4d735c322e (patch)
treeece274b88c6eb173f0fe3972a2c9344fb053dfa5 /net-im/gaim-encryption
parentmasked pre testing version (diff)
downloadhistorical-665adfc7b3376753c9778fd2e8bccb4d735c322e.tar.gz
historical-665adfc7b3376753c9778fd2e8bccb4d735c322e.tar.bz2
historical-665adfc7b3376753c9778fd2e8bccb4d735c322e.zip
Version bump
Diffstat (limited to 'net-im/gaim-encryption')
-rw-r--r--net-im/gaim-encryption/ChangeLog7
-rw-r--r--net-im/gaim-encryption/Manifest4
-rw-r--r--net-im/gaim-encryption/files/digest-gaim-encryption-2.221
-rw-r--r--net-im/gaim-encryption/gaim-encryption-2.22.ebuild44
4 files changed, 54 insertions, 2 deletions
diff --git a/net-im/gaim-encryption/ChangeLog b/net-im/gaim-encryption/ChangeLog
index 8e92c9051ebf..3cb18d70e55b 100644
--- a/net-im/gaim-encryption/ChangeLog
+++ b/net-im/gaim-encryption/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim-encryption
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.10 2004/03/14 01:54:47 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.11 2004/03/15 01:48:19 rizzo Exp $
+
+*gaim-encryption-2.22 (14 Mar 2004)
+
+ 14 Mar 2004; Don Seiler <rizzo@gentoo.org>; gaim-encryption-2.22.ebuild:
+ Version bump
13 Mar 2004; Stephen P. Becker <geoman@gentoo.org>
gaim-encryption-2.21.ebuild:
diff --git a/net-im/gaim-encryption/Manifest b/net-im/gaim-encryption/Manifest
index ed153557e831..30fe29551c6e 100644
--- a/net-im/gaim-encryption/Manifest
+++ b/net-im/gaim-encryption/Manifest
@@ -1,6 +1,8 @@
MD5 1a3a656f9f5bb8cc6d403a0f3423f695 gaim-encryption-2.21.ebuild 1271
MD5 468715cbb02c451fb44c06d10dcf11a3 gaim-encryption-2.20.ebuild 1464
-MD5 cb380a0ce0b187cdc81ab7628d558e7d ChangeLog 1443
+MD5 c6e53f605ded7f737465718abf460559 ChangeLog 1570
MD5 ab7db4bf9ff48c8de9da14fd12f6c15c metadata.xml 344
+MD5 80ac5dfa84869a365a4109e3e04e28b8 gaim-encryption-2.22.ebuild 1277
MD5 2d4cba4b020540e7e00c1f2e015302e7 files/digest-gaim-encryption-2.20 72
MD5 24597e0458ae20c16bf8a8b363de4af4 files/digest-gaim-encryption-2.21 72
+MD5 2d945bd60bd6d47a3adbddb2184e3354 files/digest-gaim-encryption-2.22 72
diff --git a/net-im/gaim-encryption/files/digest-gaim-encryption-2.22 b/net-im/gaim-encryption/files/digest-gaim-encryption-2.22
new file mode 100644
index 000000000000..2d6e7903e754
--- /dev/null
+++ b/net-im/gaim-encryption/files/digest-gaim-encryption-2.22
@@ -0,0 +1 @@
+MD5 7d1f24cba9d4c33344951caf9be94538 gaim-encryption-2.22.tar.gz 356607
diff --git a/net-im/gaim-encryption/gaim-encryption-2.22.ebuild b/net-im/gaim-encryption/gaim-encryption-2.22.ebuild
new file mode 100644
index 000000000000..a1593693cbf4
--- /dev/null
+++ b/net-im/gaim-encryption/gaim-encryption-2.22.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/gaim-encryption-2.22.ebuild,v 1.1 2004/03/15 01:48:19 rizzo Exp $
+
+IUSE=""
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~hppa ~mips"
+
+DEPEND=">=net-im/gaim-0.75-r8
+ || ( dev-libs/nss net-www/mozilla )"
+
+src_compile() {
+
+ local myconf
+ myconf="--with-gaim=/usr/include/gaim"
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ has_version dev-libs/nss && {
+ # Only need to specify this if no pkgconfig from mozilla
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+ }
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG COPYING INSTALL NOTES README TODO VERSION WISHLIST
+}