summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Pasternak <reb@gentoo.org>2006-03-05 12:08:12 +0000
committerKarol Pasternak <reb@gentoo.org>2006-03-05 12:08:12 +0000
commit65b0bafedc4438f51561df6e5bd9a44dcc726064 (patch)
treeade5fa80c6555df4339846ef2c1089b55117e4f4 /net-im/kf/kf-0.5.4.1.ebuild
parentimported ebuild from gentoo.de (diff)
downloadhistorical-65b0bafedc4438f51561df6e5bd9a44dcc726064.tar.gz
historical-65b0bafedc4438f51561df6e5bd9a44dcc726064.tar.bz2
historical-65b0bafedc4438f51561df6e5bd9a44dcc726064.zip
version bump, bug #83418
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'net-im/kf/kf-0.5.4.1.ebuild')
-rw-r--r--net-im/kf/kf-0.5.4.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-im/kf/kf-0.5.4.1.ebuild b/net-im/kf/kf-0.5.4.1.ebuild
new file mode 100644
index 000000000000..c435f86ee9ea
--- /dev/null
+++ b/net-im/kf/kf-0.5.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.5.4.1.ebuild,v 1.1 2006/03/05 12:08:12 reb Exp $
+
+inherit eutils
+
+DESCRIPTION="kf is a simple Jabber messenger."
+HOMEPAGE="http://kf.jabberstudio.org/"
+SRC_URI="http://files.jabberstudio.org/kf/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="spell debug"
+DEPEND=">=x11-libs/gtk+-2
+ >=net-libs/loudmouth-0.16
+ >=gnome-base/libglade-2
+ spell? ( >=app-text/gtkspell-2.0.4 )"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # wrong use of typedef struct _KfJispManager
+ epatch "${FILESDIR}"/${P}-typedef_KfJispManager.patch
+}
+src_compile() {
+ econf $(use_enable spell gtkspell) \
+ $(use_enable debug) || die 'econf failed'
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install DESTDIR=${D} || die 'make install failed'
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}