summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-02-08 04:05:42 +0000
committerChris Houser <chouser@gentoo.org>2002-02-08 04:05:42 +0000
commit5002dbed81aca67e96855e47eb468d93b48c6580 (patch)
tree222e609afaf78ae293d9bd153dd0af643f510271 /net-im/silc-client
parentfurther ebuild implementation (diff)
downloadhistorical-5002dbed81aca67e96855e47eb468d93b48c6580.tar.gz
historical-5002dbed81aca67e96855e47eb468d93b48c6580.tar.bz2
historical-5002dbed81aca67e96855e47eb468d93b48c6580.zip
First ebuild, bug 553. Thanks Stein Magnus Jodal.
Diffstat (limited to 'net-im/silc-client')
-rw-r--r--net-im/silc-client/files/digest-silc-client-0.7.6.21
-rw-r--r--net-im/silc-client/silc-client-0.7.6.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-im/silc-client/files/digest-silc-client-0.7.6.2 b/net-im/silc-client/files/digest-silc-client-0.7.6.2
new file mode 100644
index 000000000000..81d262b485c7
--- /dev/null
+++ b/net-im/silc-client/files/digest-silc-client-0.7.6.2
@@ -0,0 +1 @@
+MD5 d8df7fa7dbfb30bfd3bc7f0471285f3e silc-client-0.7.6.2.tar.gz 1495040
diff --git a/net-im/silc-client/silc-client-0.7.6.2.ebuild b/net-im/silc-client/silc-client-0.7.6.2.ebuild
new file mode 100644
index 000000000000..f2d7e02fad5f
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.7.6.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Stein Magnus Jodal <stein.magnus@jodal.no>
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-irc/silc-client/silc-client-0.7.6.2.ebuild,v 1.0 2002/02/05 21:23:54 drobbins Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.gz"
+HOMEPAGE="http://silcnet.org"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.0
+ sys-libs/ncurses"
+
+src_compile() {
+
+ # Edit these if you like
+ myconf="--with-ncurses"
+
+ if [ "`use ipv6`" ]; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ if [ "`use socks5`" ]; then
+ myconf="${myconf} --with-socks5"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/silc/help \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-simdir=/usr/lib/silc/modules \
+ --with-logsdir=/var/log/silc \
+ ${myconf} || die "./configure failed"
+
+ # Parallel make doesn't work consistantly
+ make || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ rmdir ${D}/usr/include
+}