summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-03-11 23:25:07 +0000
committerChuck Short <zul@gentoo.org>2004-03-11 23:25:07 +0000
commitac12546eedcb3d382600ea7c6fb86c562b59a372 (patch)
treebd816422af78880609cc005e87bfff78940e2e46 /net-im/silc-toolkit
parentVersion bump (diff)
downloadhistorical-ac12546eedcb3d382600ea7c6fb86c562b59a372.tar.gz
historical-ac12546eedcb3d382600ea7c6fb86c562b59a372.tar.bz2
historical-ac12546eedcb3d382600ea7c6fb86c562b59a372.zip
Version bump
Diffstat (limited to 'net-im/silc-toolkit')
-rw-r--r--net-im/silc-toolkit/Manifest4
-rw-r--r--net-im/silc-toolkit/files/digest-silc-toolkit-0.9.121
-rw-r--r--net-im/silc-toolkit/silc-toolkit-0.9.12.ebuild60
3 files changed, 63 insertions, 2 deletions
diff --git a/net-im/silc-toolkit/Manifest b/net-im/silc-toolkit/Manifest
index 0c2fa90293f5..5e1e20d53b94 100644
--- a/net-im/silc-toolkit/Manifest
+++ b/net-im/silc-toolkit/Manifest
@@ -1,6 +1,6 @@
-MD5 d4e22fd3557f4d0b5c9290f64236a8fd silc-toolkit-0.9.12.ebuild 1462
+MD5 e368d12cebbda6228ff83863be1d9d59 silc-toolkit-0.9.12.ebuild 1460
MD5 d4e22fd3557f4d0b5c9290f64236a8fd silc-toolkit-0.9.11.ebuild 1462
-MD5 d11a43ed80ec86c5d5faf23119a1e16f ChangeLog 949
+MD5 2d791d7c6ac3a6c7cfa735a1cb5e4ce9 ChangeLog 1089
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 fb8ec07974670c54b2a181f99789190f silc-toolkit-0.9.11-r1.ebuild 2047
MD5 f40b47266698753b0bc58c24ce9aac4e files/digest-silc-toolkit-0.9.11-r1 73
diff --git a/net-im/silc-toolkit/files/digest-silc-toolkit-0.9.12 b/net-im/silc-toolkit/files/digest-silc-toolkit-0.9.12
new file mode 100644
index 000000000000..e96a95d05314
--- /dev/null
+++ b/net-im/silc-toolkit/files/digest-silc-toolkit-0.9.12
@@ -0,0 +1 @@
+MD5 f859d51fcd5284cc1bdaad0cf33a8e6a silc-toolkit-0.9.12.tar.bz2 2547108
diff --git a/net-im/silc-toolkit/silc-toolkit-0.9.12.ebuild b/net-im/silc-toolkit/silc-toolkit-0.9.12.ebuild
new file mode 100644
index 000000000000..80f9bf71f59a
--- /dev/null
+++ b/net-im/silc-toolkit/silc-toolkit-0.9.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/silc-toolkit-0.9.12.ebuild,v 1.1 2004/03/11 23:24:55 zul Exp $
+
+IUSE="client server debug ipv6"
+
+DESCRIPTION="Software development toolkit which provides full SILC protocol implementation for application developers."
+HOMEPAGE="http://silcnet.org"
+SRC_URI="http://silcnet.org/download/toolkit/sources/silc-toolkit-${PV}.tar.bz2"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/glibc
+ !net-im/silc-client"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--prefix=${D}/usr \
+ --datadir=${D}/usr/share/silc \
+ --mandir=${D}/usr/man \
+ --includedir=${D}/usr/include/${PN} \
+ --sysconfdir=${D}/usr/share/silc/etc \
+ --with-etcdir=${D}/etc/silc \
+ --with-simdir=${D}/usr/share/silc/modules \
+ --with-docdir=${D}/usr/share/doc/${P} \
+ --with-logsdir=${D}/var/log/silc"
+
+ if [ "${DEBUG}" ]
+ then
+ einfo "debugging"
+ myconf="${myconf} --enable-debug"
+ fi
+
+ use ipv6 \
+ && myconf="${myconf} --enable-ipv6"
+
+ use client \
+ && myconf="${myconf}" \
+ || myconf="${myconf} --without-irssi"
+
+ use server \
+ && myconf="${myconf}" \
+ || myconf="${myconf} --without-silcd"
+
+ econf ${myconf} || die "./configure failed"
+ make || die "make failed"
+}
+
+src_install() {
+ make install
+ mv ${D}/usr/tutorial ${D}/usr/share/doc/${P}
+}