summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-09 21:59:23 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-09 21:59:23 +0000
commit3081c6e5dd08b369cde525e9460388915051b758 (patch)
tree80b9b4c8019ef2bd656e7e82abb546cf1f1c93c2 /net-im
parentAdded msn fix. Submitted by Patrick McLean <chutzpah@videotron.ca> in #23625. (diff)
downloadhistorical-3081c6e5dd08b369cde525e9460388915051b758.tar.gz
historical-3081c6e5dd08b369cde525e9460388915051b758.tar.bz2
historical-3081c6e5dd08b369cde525e9460388915051b758.zip
Added msn fix. Submitted by Patrick McLean <chutzpah@videotron.ca> in #23625.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.64-r13
-rw-r--r--net-im/gaim/gaim-0.64-r1.ebuild69
3 files changed, 74 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index db433f9eb813..2bb7a767acc0 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,6 +1,6 @@
-MD5 74290c6c71b207e18461ddd06954f202 ChangeLog 8785
+MD5 949865782f5fbc27e3dd6bb170e7bf3d ChangeLog 8964
MD5 c312c7f2f86088e2cbae1c306fb009ee gaim-0.59.9-r1.ebuild 2173
-MD5 29b330bcc536941c9fb8845ec878ef00 gaim-0.64-r1.ebuild 1968
+MD5 a3c0608f7a1027191eb33177114b2c65 gaim-0.64-r1.ebuild 1971
MD5 63f5d5add45a34870e61e2e39d70b919 gaim-0.63-r1.ebuild 1835
MD5 28b86e85d913fa061b0d2bf34114005f gaim-0.64.ebuild 1838
MD5 07beb4e67f5dd8cafed146e45b919144 files/digest-gaim-0.59.9-r1 128
diff --git a/net-im/gaim/files/digest-gaim-0.64-r1 b/net-im/gaim/files/digest-gaim-0.64-r1
new file mode 100644
index 000000000000..83ca12cade3a
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.64-r1
@@ -0,0 +1,3 @@
+MD5 8876251a650a8341ca6969a4f5334082 gaim-0.64.tar.bz2 2559531
+MD5 e486c7a8cf2dc79d03a0a08c6aeaab64 gaim-0.64-msncrashes-20030705-0044.diff 8987
+MD5 c008810b46ba1ea4ea581615acdc68b6 encrypt-1.20.tar.gz 38074
diff --git a/net-im/gaim/gaim-0.64-r1.ebuild b/net-im/gaim/gaim-0.64-r1.ebuild
new file mode 100644
index 000000000000..70f96dc6af30
--- /dev/null
+++ b/net-im/gaim/gaim-0.64-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.64-r1.ebuild,v 1.1 2003/07/09 21:59:12 mholzer Exp $
+
+IUSE="nls perl spell ssl nas"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=1.20
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ http://www.chipx86.com/gaim-0.64-msncrashes-20030705-0044.diff
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-x86 ~ppc -alpha -sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ nls? ( sys-devel/gettext )
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/openssl )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${P}
+ epatch ${DISTDIR}/gaim-0.64-msncrashes-20030705-0044.diff
+
+ use ssl && {
+ cd ${S}/plugins
+ unpack encrypt-${EV}.tar.gz
+ cd encrypt
+ epatch patchfile.0.63
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.rog or the gaim-encryption project."
+ ewarn
+ fi
+}