summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-06-17 00:10:17 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-06-17 00:10:17 +0000
commit1772294cedfab4e9e316aeff39e3c7050939d1a8 (patch)
tree3d54cb7b4061dd4ddf1d0224ebee576f5000287b /net-irc/bitchx
parentmade several db-3 and db-1 deps allow later revisions (diff)
downloadhistorical-1772294cedfab4e9e316aeff39e3c7050939d1a8.tar.gz
historical-1772294cedfab4e9e316aeff39e3c7050939d1a8.tar.bz2
historical-1772294cedfab4e9e316aeff39e3c7050939d1a8.zip
Since bitchx is generally known to be a console IRC client, I split the ebuild
into two: bitchx (console) and bitchx-gtk (gtk version, installs in /opt/gnome). This makes it easier for GNOME people who want the console version, and avoids confusion. Yes, we shouldn't to this for every package, but for this one it makes sense. Also fixed a typo and added >=media-libs/imlib-1.9 to bitchx-gtk.
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/bitchx-1.0.18-r2.ebuild51
1 files changed, 8 insertions, 43 deletions
diff --git a/net-irc/bitchx/bitchx-1.0.18-r2.ebuild b/net-irc/bitchx/bitchx-1.0.18-r2.ebuild
index 653edc24e78b..4c78d64f023a 100644
--- a/net-irc/bitchx/bitchx-1.0.18-r2.ebuild
+++ b/net-irc/bitchx/bitchx-1.0.18-r2.ebuild
@@ -1,21 +1,15 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.18-r2.ebuild,v 1.3 2001/06/06 16:55:51 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.18-r2.ebuild,v 1.4 2001/06/17 00:10:14 drobbins Exp $
-P=
A=ircii-pana-1.0c18.tar.gz
S=${WORKDIR}/BitchX
DESCRIPTION="An IRC Client"
SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${A}"
HOMEPAGE="http://www.bitchx.com/"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=media-libs/audiofile-0.2.1
- ssl? ( >=dev-libs/openssl-0.9.6 )
- gnome? ( >=gnome-base/gnome-libs-1.2.4 )
- esd? ( >=media-sound/esound-0.2.22 )"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.1 ssl? ( >=dev-libs/openssl-0.9.6 )"
src_unpack() {
unpack ${A}
@@ -24,51 +18,22 @@ src_unpack() {
}
src_compile() {
-
local myopts
- if [ -n "`use gnome`" ]
- then
- myopts="--with-gtk --prefix=/opt/gnome"
- else
- myopts="--prefix=/usr"
- fi
- if [ -n "`use esd`" ]
- then
- myopts="$myopts --with-esd"
- fi
if [ -n "`use ssl`" ]
then
myopts="$myopts --with-ssl"
fi
- try ./configure ${myopts} --host=${CHOST} --build=${CHOST}\
- --enable-cdrom --enable-ipv6 --with-plugins --enable-sound
+ try ./configure --prefix=/usr --without-gtk --without-esd ${myopts} --host=${CHOST} --build=${CHOST}\
+ --enable-cdrom --enable-ipv6 --with-plugins --disable-sound
try make
-
}
src_install () {
- if [ -n "`use gnome`" ]
- then
- try make prefix=${D}/opt/gnome install
-# insinto /opt/gnome/share/gnome/apps/Internet
-# doins gtkBitchX.desktop
-# insinto /opt/gnome/share/pixmaps
-# doins BitchX.png
- cd ${D}/opt/gnome/bin
- rm gtkBitchX
- ln -sf gtkBichX-1.0c18 gtkBitchX
- chmod -x ${D}/opt/gnome/lib/bx/plugins/BitchX.hints
- else
- try make prefix=${D}/usr install
- cd ${D}/usr/bin
- rm gtkBitchX
- ln -sf BichX-1.0c18 BitchX
- chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
- fi
-
- #ln -sf ${D}/usr/bin/${P} BitchX
-
+ try make prefix=${D}/usr install
+ cd ${D}/usr/bin
+ rm -f gtkBitchX
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
cd ${S}
dodoc Changelog README* IPv6-support