summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-04 16:36:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-04 16:36:34 +0000
commit195b85c845ac36638c28556e61c65d9bf56fee4a (patch)
tree415eb7b319a8454b43edefb9f416af4da4af4712 /net-libs/ldns/ldns-1.6.3.ebuild
parentMarked ~hppa (bug #294277). (diff)
downloadhistorical-195b85c845ac36638c28556e61c65d9bf56fee4a.tar.gz
historical-195b85c845ac36638c28556e61c65d9bf56fee4a.tar.bz2
historical-195b85c845ac36638c28556e61c65d9bf56fee4a.zip
Version bumped.
Package-Manager: portage-2.1.7.10/cvs/Linux x86_64
Diffstat (limited to 'net-libs/ldns/ldns-1.6.3.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.6.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/ldns/ldns-1.6.3.ebuild b/net-libs/ldns/ldns-1.6.3.ebuild
new file mode 100644
index 000000000000..3282630280f1
--- /dev/null
+++ b/net-libs/ldns/ldns-1.6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.3.ebuild,v 1.1 2009/12/04 16:36:34 matsuu Exp $
+
+EAPI="2"
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ssl vim-syntax"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7 )"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) \
+ --disable-rpath || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ emake doxygen || die "emake doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changelog README* || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim || die "doins libdns.vim failed"
+ fi
+}