summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-02-24 12:28:18 +0000
committerMart Raudsepp <leio@gentoo.org>2008-02-24 12:28:18 +0000
commitb3fe92267caac0b9960411db11f70bf6eb9957c0 (patch)
tree4e4667f4634daeaa0889144bbfa5b74ae3d585e6 /net-libs/libsoup/libsoup-2.2.105-r1.ebuild
parentalpha/ia64/sparc stable (diff)
downloadhistorical-b3fe92267caac0b9960411db11f70bf6eb9957c0.tar.gz
historical-b3fe92267caac0b9960411db11f70bf6eb9957c0.tar.bz2
historical-b3fe92267caac0b9960411db11f70bf6eb9957c0.zip
Fix gtk-docs not showing up in devhelp; also clean up an ancient version that was hanging around only due to it being last stable mips version, but gnutls does not have a stable mips version anymore
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-libs/libsoup/libsoup-2.2.105-r1.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-2.2.105-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libsoup/libsoup-2.2.105-r1.ebuild b/net-libs/libsoup/libsoup-2.2.105-r1.ebuild
new file mode 100644
index 000000000000..751e8481d20e
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.2.105-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.2.105-r1.ebuild,v 1.1 2008/02/24 12:28:17 leio Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=dev-libs/libxml2-2
+ ssl? ( >=net-libs/gnutls-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable ssl)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix GNOME bug #518384 - API docs not found by devhelp
+ epatch "${FILESDIR}/${P}-fix-devhelp-docs.patch"
+ mv "${S}/docs/reference/html/libsoup.devhelp" "${S}/docs/reference/html/libsoup-2.2.devhelp"
+ mv "${S}/docs/reference/html/libsoup.devhelp2" "${S}/docs/reference/html/libsoup-2.2.devhelp2"
+}