summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-10 15:37:16 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-10 15:37:16 +0000
commit20f210b544699407f65cb41362a430a1d90aab1c (patch)
treecc29e9e18f830d307c3ba25b32628b46cc3b4579 /net-libs/serf/serf-1.1.1.ebuild
parentVersion bump wrt bug #446676. (diff)
downloadhistorical-20f210b544699407f65cb41362a430a1d90aab1c.tar.gz
historical-20f210b544699407f65cb41362a430a1d90aab1c.tar.bz2
historical-20f210b544699407f65cb41362a430a1d90aab1c.zip
Add static-libs USE flag, wrt bug #446722
Package-Manager: portage-2.2.0_alpha144/cvs/Linux x86_64
Diffstat (limited to 'net-libs/serf/serf-1.1.1.ebuild')
-rw-r--r--net-libs/serf/serf-1.1.1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-libs/serf/serf-1.1.1.ebuild b/net-libs/serf/serf-1.1.1.ebuild
index 5b6e30f7d1e6..8ab0984d85bb 100644
--- a/net-libs/serf/serf-1.1.1.ebuild
+++ b/net-libs/serf/serf-1.1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/serf/serf-1.1.1.ebuild,v 1.2 2012/12/10 12:23:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/serf/serf-1.1.1.ebuild,v 1.3 2012/12/10 15:37:11 pinkbyte Exp $
EAPI="4"
-inherit autotools eutils
+inherit autotools eutils multilib
DESCRIPTION="HTTP client library"
HOMEPAGE="http://code.google.com/p/serf/"
@@ -13,7 +13,7 @@ SRC_URI="http://serf.googlecode.com/files/${P}.tar.bz2"
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x64-macos"
-IUSE=""
+IUSE="static-libs"
DEPEND="dev-libs/apr:1
dev-libs/apr-util:1
@@ -32,3 +32,11 @@ src_configure() {
--with-apr-util="${EPREFIX}/usr/bin/apu-1-config" \
--with-openssl="${EPREFIX}/usr"
}
+
+src_install() {
+ default
+ if use !static-libs; then
+ rm "${ED}/usr/$(get_libdir)"/*.a || die 'remove static libs failed'
+ prune_libtool_files
+ fi
+}