summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-11-12 22:51:52 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-11-12 22:51:52 +0000
commite43b8fbc59a57dd53e00f8907dd7703db252e623 (patch)
tree90770e3922ea7617e667c158bce4c4e537683755 /net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild
parentVersion bump. (diff)
downloadhistorical-e43b8fbc59a57dd53e00f8907dd7703db252e623.tar.gz
historical-e43b8fbc59a57dd53e00f8907dd7703db252e623.tar.bz2
historical-e43b8fbc59a57dd53e00f8907dd7703db252e623.zip
Version bump.
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild')
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild
new file mode 100644
index 000000000000..b159d4b188ab
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.8.1.ebuild,v 1.1 2009/11/12 22:51:52 eva Exp $
+
+EAPI="2"
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.73
+ >=dev-lang/python-2.3"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}