summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-10 21:06:20 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-10 21:06:20 +0000
commitba2dd159b074f512c0f3d8c0a24ff5a5c77bff9c (patch)
tree873b82816fc524347dad7978f009f5ca67a19765 /net-mail/evolution
parentA useful tool, like mii-tool (diff)
downloadhistorical-ba2dd159b074f512c0f3d8c0a24ff5a5c77bff9c.tar.gz
historical-ba2dd159b074f512c0f3d8c0a24ff5a5c77bff9c.tar.bz2
historical-ba2dd159b074f512c0f3d8c0a24ff5a5c77bff9c.zip
misc fixes
Diffstat (limited to 'net-mail/evolution')
-rw-r--r--net-mail/evolution/ChangeLog5
-rw-r--r--net-mail/evolution/evolution-1.1.90.ebuild5
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-utf8.patch21
3 files changed, 27 insertions, 4 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 36823230ec40..5ee6bbb10ae3 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,9 +1,10 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.28 2002/11/10 13:10:35 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.29 2002/11/10 21:06:20 azarah Exp $
10 Nov 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.1.90.ebuild :
- Update some USE flags. Add patches from Mandrake.
+ Update some USE flags. Add patches from Mandrake. Add utf8 patch. Fix
+ screwup with enabling NSS support.
*evolution-1.1.90 (9 Nov 2002)
diff --git a/net-mail/evolution/evolution-1.1.90.ebuild b/net-mail/evolution/evolution-1.1.90.ebuild
index b0100d72a30a..22502944b689 100644
--- a/net-mail/evolution/evolution-1.1.90.ebuild
+++ b/net-mail/evolution/evolution-1.1.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.1.90.ebuild,v 1.2 2002/11/10 13:10:35 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.1.90.ebuild,v 1.3 2002/11/10 21:06:20 azarah Exp $
IUSE="ssl nls mozilla ldap doc spell pda ipv6"
@@ -62,6 +62,7 @@ src_unpack() {
patch -p1 < ${FILESDIR}/${P}-kde.patch || die
patch -p1 < ${FILESDIR}/${P}-scrollkeeper.patch || die
patch -p1 < ${FILESDIR}/${P}-subversion.patch || die
+ patch -p1 < ${FILESDIR}/${P}-utf8.patch || die
# libtoolize to fix not all libs installing, and buggy .la files.
# also add the gnome-pilot.m4 to the macros directory to fix
@@ -122,7 +123,7 @@ src_compile() {
# Use Mozilla NSS libs if 'mozilla' *and* 'ssl' in USE
if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
- myconf="${myconf} --enable-nss=static \
+ myconf="${myconf} --enable-nss=yes \
--with-nspr-includes=${MOZILLA}/include/nspr \
--with-nspr-libs=${MOZILLA} \
--with-nss-includes=${MOZILLA}/include/nss \
diff --git a/net-mail/evolution/files/evolution-1.1.90-utf8.patch b/net-mail/evolution/files/evolution-1.1.90-utf8.patch
new file mode 100644
index 000000000000..a347d0fd1555
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-utf8.patch
@@ -0,0 +1,21 @@
+--- evolution-1.1.90/shell/e-shell-settings-dialog.c.orig 2002-10-26 08:47:09.000000000 +0200
++++ evolution-1.1.90/shell/e-shell-settings-dialog.c 2002-11-07 15:24:49.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include "e-util/e-lang-utils.h"
+
+ #include <gal/util/e-util.h>
++#include <gal/util/e-unicode-i18n.h>
+
+ #include <bonobo/bonobo-widget.h>
+ #include <bonobo/bonobo-exception.h>
+@@ -93,8 +94,8 @@
+ gdk_pixbuf_ref (icon);
+
+ page = g_new (Page, 1);
+- page->title = g_strdup (_(title));
+- page->description = g_strdup (_(description));
++ page->title = g_strdup (U_(title));
++ page->description = g_strdup (U_(description));
+ page->icon = icon;
+ page->type = type;
+ page->priority = priority;