summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-12-27 00:05:20 +0000
committerNick Hadaway <raker@gentoo.org>2002-12-27 00:05:20 +0000
commit2445be823285da728216ddcdc584705d2bc63b8c (patch)
tree63be1de48def823d68842f0c3ac78e1289d8a897 /net-mail/fetchmail
parentVersion bump. No patches required. New ssl certs directory. No (diff)
downloadhistorical-2445be823285da728216ddcdc584705d2bc63b8c.tar.gz
historical-2445be823285da728216ddcdc584705d2bc63b8c.tar.bz2
historical-2445be823285da728216ddcdc584705d2bc63b8c.zip
Enable ipv6.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog8
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.0-r1.ebuild89
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.0-r11
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.2.0-gentoo.diff46
4 files changed, 143 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 040769ee47ac..14ab7fdcf2d8 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.18 2002/12/16 22:48:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.19 2002/12/27 00:05:16 raker Exp $
+
+*fetchmail-6.2.0-r2 (26 Dec 2002)
+
+ 26 Dec 2002; Nick Hadaway <raker@gentoo.org> fetchmail-6.2.0-r1.ebuild,
+ digest-fetchmail-6.2.0-r1, files/fetchmail-6.2.0-gentoo.diff :
+ Enable ipv6 support.
16 Dec 2002; Aron Griffis <agriffis@gentoo.org> fetchmail-6.2.0.ebuild :
Added ~alpha to KEYWORDS
diff --git a/net-mail/fetchmail/fetchmail-6.2.0-r1.ebuild b/net-mail/fetchmail/fetchmail-6.2.0-r1.ebuild
new file mode 100644
index 000000000000..cf97d9db3c68
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.0-r1.ebuild,v 1.1 2002/12/27 00:05:20 raker Exp $
+
+IUSE="ssl nls"
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86 ~alpha"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/fetchmail-6.2.0-gentoo.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use ipv6 && myconf="${myconf} --enable-inet6" \
+ || myconf="${myconf} --disable-inet6"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+
+}
+
+src_install() {
+
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.0-r1 b/net-mail/fetchmail/files/digest-fetchmail-6.2.0-r1
new file mode 100644
index 000000000000..a9eb7075604d
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.0-r1
@@ -0,0 +1 @@
+MD5 1242753944ad242bb4312af6be08b810 fetchmail-6.2.0.tar.gz 1089936
diff --git a/net-mail/fetchmail/files/fetchmail-6.2.0-gentoo.diff b/net-mail/fetchmail/files/fetchmail-6.2.0-gentoo.diff
new file mode 100644
index 000000000000..ce2d0b4109cf
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.2.0-gentoo.diff
@@ -0,0 +1,46 @@
+--- fetchmail-6.1.2/pop2.c.old Thu Mar 22 08:45:35 2001
++++ fetchmail-6.1.2/pop2.c Thu Nov 28 22:47:51 2002
+@@ -129,8 +129,8 @@
+ {
+ "POP2", /* Post Office Protocol v2 */
+ #if INET6_ENABLE
+- "pop2", /* standard POP2 port */
+- "pop2", /* ssl POP2 port */
++ "pop-2", /* standard POP2 port */
++ "pop-2", /* ssl POP2 port */
+ #else /* INET6_ENABLE */
+ 109, /* standard POP2 port */
+ 109, /* ssl POP2 port - not */
+--- fetchmail-6.1.2/imap.c.old Thu Nov 28 22:52:07 2002
++++ fetchmail-6.1.2/imap.c Thu Nov 28 22:48:20 2002
+@@ -1012,7 +1012,7 @@
+ {
+ "IMAP", /* Internet Message Access Protocol */
+ #if INET6_ENABLE
+- "imap",
++ "imap2",
+ "imaps",
+ #else /* INET6_ENABLE */
+ 143, /* standard IMAP2bis/IMAP4 port */
+--- fetchmail-6.1.2/etrn.c.old Sun Mar 10 22:34:50 2002
++++ fetchmail-6.1.2/etrn.c Thu Nov 28 22:53:26 2002
+@@ -124,7 +124,7 @@
+ "ETRN", /* ESMTP ETRN extension */
+ #if INET6_ENABLE
+ "smtp", /* standard SMTP port */
+- "smtps", /* ssl SMTP port */
++ "ssmtp", /* ssl SMTP port */
+ #else /* INET6_ENABLE */
+ 25, /* standard SMTP port */
+ 465, /* ssl SMTP port */
+--- fetchmail-6.1.2/pop3.c.old Thu Oct 31 15:41:37 2002
++++ fetchmail-6.1.2/pop3.c Thu Nov 28 22:47:30 2002
+@@ -817,7 +817,7 @@
+ {
+ "POP3", /* Post Office Protocol v3 */
+ #if INET6_ENABLE
+- "pop3", /* standard POP3 port */
++ "pop-3", /* standard POP3 port */
+ "pop3s", /* ssl POP3 port */
+ #else /* INET6_ENABLE */
+ 110, /* standard POP3 port */