summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-03 17:16:02 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-03 17:16:02 +0000
commit5dbf9fb0b3095b212d1854d0c59c9627fdec41c8 (patch)
tree0933c597c48d8ab8edc8fa64aed71efb1799ad99 /net-mail/tpop3d
parentAdding new openal version. Needs testing, so masking for now. (diff)
downloadhistorical-5dbf9fb0b3095b212d1854d0c59c9627fdec41c8.tar.gz
historical-5dbf9fb0b3095b212d1854d0c59c9627fdec41c8.tar.bz2
historical-5dbf9fb0b3095b212d1854d0c59c9627fdec41c8.zip
header fix
Diffstat (limited to 'net-mail/tpop3d')
-rw-r--r--net-mail/tpop3d/Manifest3
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch36
-rw-r--r--net-mail/tpop3d/files/tpop3d-init6
3 files changed, 4 insertions, 41 deletions
diff --git a/net-mail/tpop3d/Manifest b/net-mail/tpop3d/Manifest
index ccf55b516569..040cadc001e8 100644
--- a/net-mail/tpop3d/Manifest
+++ b/net-mail/tpop3d/Manifest
@@ -4,5 +4,4 @@ MD5 3d65c6cff5d8227c1e1372fa58239918 tpop3d-1.4.2.ebuild 2500
MD5 ab040e5df6fb8f4c7addcf549d0b280f tpop3d-1.5.3.ebuild 2472
MD5 70073dfbe2bd93a7922b97c4f4cd3af2 files/digest-tpop3d-1.4.2 145
MD5 4a64dc0452c80fd14ebdfe21d889d235 files/digest-tpop3d-1.5.3 64
-MD5 b40cd6aa6ab9186588d4c6ab10167a8f files/tpop3d-1.5.2-fix-AV-problem.patch 1710
-MD5 9190b714d11bf56eaa8488012a167b70 files/tpop3d-init 702
+MD5 4aec7bd2614890bf787df5fbf006ee00 files/tpop3d-init 696
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch b/net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch
deleted file mode 100644
index b634b61e2d63..000000000000
--- a/net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- connection.c 14 Jul 2003 23:31:20 -0000 1.49
-+++ connection.c 30 Sep 2003 18:52:19 -0000
-@@ -381,9 +381,30 @@
- * Send a +OK... / -ERR... response to a message. Returns 1 on success or 0 on
- * failure. */
- int connection_sendresponse(connection c, const int success, const char *s) {
-- if (connection_send(c, success ? "+OK " : "-ERR ", success ? 4 : 5)
-- && connection_send(c, s, strlen(s))
-- && connection_send(c, "\r\n", 2)) {
-+ /*
-+ * For efficiency's sake, we should send this bit-by-bit, avoiding another
-+ * buffer copy. But unfortunately, there are POP3 clients in the world
-+ * so stupid that they assume a whole response will arrive in a single TCP
-+ * segment. Particular examples include POP3 virus-scanning proxies, such
-+ * as Norman ASA's, which was evidently written by somebody very lazy.
-+ *
-+ * Obviously there's no way to guarantee how the packets in a TCP stream
-+ * are disposed, in general, but we can increase the probability of success
-+ * by trying to ensure here that our response is contained in a single
-+ * write call. It still might get split up by the ioabs layer, but we have
-+ * to take our chances....
-+ */
-+ static char *buf;
-+ static size_t buflen;
-+ size_t l;
-+
-+ l = (success ? 6 : 7) + strlen(s);
-+
-+ if (!buf || buflen < l + 1)
-+ buf = xrealloc(buf, buflen = l + 1);
-+
-+ sprintf(buf, "%s %s\r\n", success ? "+OK" : "-ERR", s);
-+ if (connection_send(c, buf, l)) {
- if (verbose)
- log_print(LOG_DEBUG, _("connection_sendresponse: client %s: sent %s %s'"), c->idstr, success ? "+OK" : "-ERR", s);
- return 1;
diff --git a/net-mail/tpop3d/files/tpop3d-init b/net-mail/tpop3d/files/tpop3d-init
index 6f9f68b515a1..ec0b0190b491 100644
--- a/net-mail/tpop3d/files/tpop3d-init
+++ b/net-mail/tpop3d/files/tpop3d-init
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/files/tpop3d-init,v 1.1 2003/08/03 04:44:34 iggy Exp $
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/files/tpop3d-init,v 1.2 2004/03/03 17:16:02 mholzer Exp $
depend() {
need net