summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-03-20 20:38:18 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-03-20 20:38:18 +0000
commit43bb59844faef4f7fe7732c30f2277dca0e99806 (patch)
tree69cfbbcb8769eb3964475c977ea726a6fb6f1a84 /net-mail
parentgcc3 now uses the system zlib. (diff)
downloadhistorical-43bb59844faef4f7fe7732c30f2277dca0e99806.tar.gz
historical-43bb59844faef4f7fe7732c30f2277dca0e99806.tar.bz2
historical-43bb59844faef4f7fe7732c30f2277dca0e99806.zip
Changed gpgme use variable to gpg, since that seems to be our standard
as a global use variable.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.4-r11
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.7.4-r1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.4-r1 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.4-r1
new file mode 100644
index 000000000000..dc161d80397b
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.4-r1
@@ -0,0 +1 @@
+MD5 834607a29ab6aad64141e2d576c76e23 sylpheed-0.7.4claws.tar.gz 1840066
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.7.4-r1.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..e2f2290c7db0
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.7.4-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Desktop Team <desktop@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.7.4-r1.ebuild,v 1.1 2002/03/20 20:38:18 g2boojum Exp $
+
+S=${WORKDIR}/sylpheed-${PV}claws
+DESCRIPTION="Bleeding edge version of Sylpheed"
+SRC_URI="http://prdownloads.sourceforge.net/sylpheed-claws/sylpheed-${PV}claws.tar.gz"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+DEPEND=">=x11-libs/gtk+-1.2.6
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ spell? ( >=app-text/pspell-0.12.2 )
+ xface? ( >=media-libs/compface-1.4 )
+ jpilot? ( >=app-misc/jpilot-0.99 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ gpg? ( >=app-crypt/gpgme-0.2.3 )
+ nls? ( sys-devel/gettext )
+ "
+
+RDEPEND="$DEPEND"
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use gpg && myconf="${myconf} --enable-gpgme"
+
+ use gnome && \
+ myconf="${myconf} --enable-gdk-pixbuf" || \
+ myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib && \
+ myconf="${myconf} --enable-imlib" || \
+ myconf="${myconf} --disable-imlib"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use spell && myconf="${myconf} --enable-pspell"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use jpilot && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ use gnome || rm -rf ${D}/usr/share/gnome
+}