summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-18 03:08:42 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-18 03:08:42 +0000
commit6531a365c9b97cf04da7e83cb8ffe13a26484675 (patch)
tree137a338bcb16a4534b6373a95c50767516dafde6 /net-mail
parentminor dep fix (diff)
downloadhistorical-6531a365c9b97cf04da7e83cb8ffe13a26484675.tar.gz
historical-6531a365c9b97cf04da7e83cb8ffe13a26484675.tar.bz2
historical-6531a365c9b97cf04da7e83cb8ffe13a26484675.zip
New ebuild with threaded index patch and some compile warning fixes.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/ChangeLog9
-rw-r--r--net-mail/pine/files/digest-pine-4.44-r51
-rw-r--r--net-mail/pine/files/fancy.patch.bz2bin0 -> 37301 bytes
-rw-r--r--net-mail/pine/pine-4.44-r5.ebuild98
4 files changed, 107 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index 1514c596fe4a..b5ec1a0d47d9 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.5 2002/10/20 19:25:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.6 2002/11/18 03:08:42 raker Exp $
+
+*pine-4.44-r5 (17 Nov 2002)
+
+ 17 Nov 2002; Nick Hadaway <raker@gentoo.org> pine-4.44-r5.ebuild,
+ files/fancy.patch.bz2, files/digest-pine-4.44-r5 :
+ New pine ebuild with the threaded index patch and got rid of some
+ compile warnings.
*pine-4.44-r4 (15 Apr 2002)
diff --git a/net-mail/pine/files/digest-pine-4.44-r5 b/net-mail/pine/files/digest-pine-4.44-r5
new file mode 100644
index 000000000000..d23758358512
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.44-r5
@@ -0,0 +1 @@
+MD5 bb405bd52b9fd84b9a981626847cc098 pine4.44.tar.gz 3478476
diff --git a/net-mail/pine/files/fancy.patch.bz2 b/net-mail/pine/files/fancy.patch.bz2
new file mode 100644
index 000000000000..5d13c4df0e44
--- /dev/null
+++ b/net-mail/pine/files/fancy.patch.bz2
Binary files differ
diff --git a/net-mail/pine/pine-4.44-r5.ebuild b/net-mail/pine/pine-4.44-r5.ebuild
new file mode 100644
index 000000000000..d8f57b98f6da
--- /dev/null
+++ b/net-mail/pine/pine-4.44-r5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.44-r5.ebuild,v 1.1 2002/11/18 03:08:42 raker Exp $
+
+IUSE="ssl ldap"
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.washington.edu/pine/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+SLOT="0"
+LICENSE="PICO"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+
+src_unpack() {
+ unpack ${A}
+
+ # RH patches, although I've ignored the "RH" patch itself
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-fixhome.patch
+ patch -d ${S} -p0 < ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-passwd.patch
+ if [ "`use ldap`" ] ; then
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-boguswarning.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.31-segfix.patch
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-lockfile-perm.patch
+ patch -d ${S} -p1 < ${FILESDIR}/imap-2000-time.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.33-whitespace.patch
+ #patch -d ${S} -p1 < ${FILESDIR}/pine-4.44-multibyte.patch
+ bzcat ${FILESDIR}/fancy.patch.bz2 | patch -p0 || die "fancy patch failed"
+
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr/ssl SSLINCLUDE=/usr/include/openssl"
+ BUILDOPTS="${BUILDOPTS} SSLLIB=/usr/lib SSLTYPE=unix"
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+
+
+
+