summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRajiv Aaron Manglani <rajiv@gentoo.org>2003-09-16 06:11:50 +0000
committerRajiv Aaron Manglani <rajiv@gentoo.org>2003-09-16 06:11:50 +0000
commit8f0e88922f1d6f2e907866e496d6f1d018b3f63a (patch)
treef46535d920aa4639637101cb89235a0c0acb51c3 /net-mail
parentchappa patches are back. now using his 'all' set for 4.58 as of 2003-09-15. k... (diff)
downloadhistorical-8f0e88922f1d6f2e907866e496d6f1d018b3f63a.tar.gz
historical-8f0e88922f1d6f2e907866e496d6f1d018b3f63a.tar.bz2
historical-8f0e88922f1d6f2e907866e496d6f1d018b3f63a.zip
chappa patches are back. now using his 'all' set for 4.58 as of 2003-09-15. keyworded for testing.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/Manifest4
-rw-r--r--net-mail/pine/files/digest-pine-4.58-r12
-rw-r--r--net-mail/pine/pine-4.58-r1.ebuild133
3 files changed, 137 insertions, 2 deletions
diff --git a/net-mail/pine/Manifest b/net-mail/pine/Manifest
index ac2c4eb8d0c8..7117e4609dea 100644
--- a/net-mail/pine/Manifest
+++ b/net-mail/pine/Manifest
@@ -1,7 +1,7 @@
MD5 d1e5490be0d14f85b3ad82911fff3640 pine-4.58.ebuild 3312
MD5 4c37407d8c7106315e06cc267b1806dc pine-4.50-r4.ebuild 3509
-MD5 770c89dfc1c0e17343a0247f787e2c7c pine-4.58-r1.ebuild 3427
-MD5 174cd5dffc619a802b513d8676b5fbfa ChangeLog 6896
+MD5 a33d9cf73ee99c67dd5f075639c47a23 pine-4.58-r1.ebuild 3430
+MD5 6d2dca80f82de51229d1f1281d6648c3 ChangeLog 7105
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 873fcf60ddaa752f968a2af80441239b pine-4.56.ebuild 3422
MD5 c47b08cab6132957eef9c0d61862f951 files/digest-pine-4.50-r4 131
diff --git a/net-mail/pine/files/digest-pine-4.58-r1 b/net-mail/pine/files/digest-pine-4.58-r1
new file mode 100644
index 000000000000..c14d43b95bde
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.58-r1
@@ -0,0 +1,2 @@
+MD5 6135222a12f06b2dfceea5c1b736891e pine4.58.tar.bz2 2837321
+MD5 f52ba0a0bd3ad18d09d0df287be397ba pine-4.58-chappa-all-20030915.patch.gz 106988
diff --git a/net-mail/pine/pine-4.58-r1.ebuild b/net-mail/pine/pine-4.58-r1.ebuild
new file mode 100644
index 000000000000..c9282a7cd164
--- /dev/null
+++ b/net-mail/pine/pine-4.58-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.58-r1.ebuild,v 1.1 2003/09/16 06:11:46 rajiv Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+HOMEPAGE="http://www.washington.edu/pine/
+ http://www.math.washington.edu/~chappa/pine/patches/"
+SRC_URI="ftp://ftp.cac.washington.edu/pine/${PN}${PV}.tar.bz2
+ mirror://gentoo//${P}-chappa-all-20030915.patch.gz"
+
+LICENSE="PICO"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="ssl ldap debug"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ !net-mail/pine-maildir"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${PN}${PV}.tar.bz2
+ cd ${S}
+
+ epatch ${DISTDIR}/${P}-chappa-all-20030915.patch.gz || die
+
+ epatch ${FILESDIR}/pine-4.21-fixhome.patch || die
+
+ epatch ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+
+ if [ "`use ldap`" ] ; then
+ # link to shared ldap libs instead of static
+ epatch ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+
+ # Don't appear to need this anymore; as of pine-4.56
+ #epatch ${FILESDIR}/pine-4.40-boguswarning.patch
+
+ epatch ${FILESDIR}/pine-4.31-segfix.patch
+
+ epatch ${FILESDIR}/pine-4.40-lockfile-perm.patch
+
+ epatch ${FILESDIR}/imap-2000-time.patch
+
+ epatch ${FILESDIR}/pine-4.33-whitespace.patch
+
+ # bug #23336 - makes pine transparent in terms that support it
+ epatch ${FILESDIR}/transparency.patch
+
+ if [ `use debug` ]; then
+ cd ${S}/pine
+ sed -i \
+ -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ makefile.lnx || die "sed pine/makefile.lnx failed"
+ cd ${S}/pico
+ sed -i \
+ -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ makefile.lnx || die "sed pico/makefile.lnx failed"
+ else
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -i \
+ -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ makefile.lnx || die "sed pine/makefile.lnx failed"
+ cd ${S}/pico
+ sed -i \
+ -e "s:-g -DDEBUG:${CFLAGS}:" \
+ makefile.lnx || die "sed pico/makefile.lnx failed"
+ fi
+ cd ${S}/pine/osdep
+ sed -i \
+ -e "s:/usr/local/lib/pine.conf:/etc/pine.conf:" \
+ os-lnx.h || die "sed os-lnx.h failed"
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ cd ${S}/imap/src/osdep/unix
+ sed -i \
+ -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ Makefile || die "sed Makefile failed"
+ cd ${S}
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/
+}