summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-06-13 22:49:51 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-06-13 22:49:51 +0000
commitc289654391051b668c5d4251e141bcb9d2a540c4 (patch)
treecef340239d230567a8ecd696f0c5bfc3e0ad4112 /net-mail
parentdistutil-ize (diff)
downloadhistorical-c289654391051b668c5d4251e141bcb9d2a540c4.tar.gz
historical-c289654391051b668c5d4251e141bcb9d2a540c4.tar.bz2
historical-c289654391051b668c5d4251e141bcb9d2a540c4.zip
More fixage
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/postfix/ChangeLog6
-rw-r--r--net-mail/postfix/Manifest6
-rw-r--r--net-mail/postfix/postfix-2.0.10-r1.ebuild35
-rw-r--r--net-mail/postfix/postfix-2.0.9.ebuild35
4 files changed, 76 insertions, 6 deletions
diff --git a/net-mail/postfix/ChangeLog b/net-mail/postfix/ChangeLog
index d6649d21b836..fffd549f96c3 100644
--- a/net-mail/postfix/ChangeLog
+++ b/net-mail/postfix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/postfix
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.71 2003/06/13 22:36:56 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.72 2003/06/13 22:49:38 lostlogic Exp $
+
+ 13 Jun 2003; Brandon Low <lostlogic@gentoo.org> postfix-2.0.10-r1.ebuild,
+ postfix-2.0.9.ebuild:
+ Fix bug 15252 in stable versions as well
*postfix-2.0.12 (13 Jun 2003)
diff --git a/net-mail/postfix/Manifest b/net-mail/postfix/Manifest
index b3c6cb16725d..119b4afd5655 100644
--- a/net-mail/postfix/Manifest
+++ b/net-mail/postfix/Manifest
@@ -1,8 +1,8 @@
-MD5 e6a3d41964c3f27d3fc79b241df1b13d postfix-2.0.10-r1.ebuild 5394
-MD5 ead334460917ae4879673b31d59f46e8 postfix-2.0.9.ebuild 5471
+MD5 d3ff927dcfe6f64f38e4b11c111e1911 postfix-2.0.10-r1.ebuild 6177
+MD5 9d60a0de3a74ab26a7e74983933562d7 postfix-2.0.9.ebuild 6254
MD5 76726846989c0b6a5fc643d06b804e45 postfix-1.1.11.20020917-r1.ebuild 4945
MD5 c49a1772a81a27dba0c02daae56d31ad postfix-2.0.12.ebuild 6025
-MD5 c78d84e8f12a70f4e663662315c2fa7d ChangeLog 14842
+MD5 d2c27d0978f747ea01ff48101e26f896 ChangeLog 14986
MD5 9e1d40685d31e1afe455ada60b18cae9 postfix-2.0.11.ebuild 6026
MD5 c79b19f95cb38b8802966d7efb54bc60 postfix-1.1.11.20020917.ebuild 4924
MD5 a3eadfcfa0bf6f88ccff41e2d065745b files/postfix-2.0.8_patch.patch 552
diff --git a/net-mail/postfix/postfix-2.0.10-r1.ebuild b/net-mail/postfix/postfix-2.0.10-r1.ebuild
index cd11edda8ac0..e2ad43b2f04e 100644
--- a/net-mail/postfix/postfix-2.0.10-r1.ebuild
+++ b/net-mail/postfix/postfix-2.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.10-r1.ebuild,v 1.2 2003/06/10 00:48:39 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.10-r1.ebuild,v 1.3 2003/06/13 22:49:38 lostlogic Exp $
inherit eutils
@@ -47,6 +47,39 @@ pkg_setup() {
if ! grep -q ^mail:.*postfix /etc/group ; then
usermod -G mail postfix || die "problem adding user postfix to group mail"
fi
+
+ # Prevent mangling the smtpd.conf file
+ if [ ! -L ${ROOT}/usr/lib/sasl2/smtpd.conf ]
+ then
+ if [ -f ${ROOT}/usr/lib/sasl2/smtpd.conf ]
+ then
+ ebegin "Protecting your smtpd.conf file"
+ if [ ! -d ${ROOT}/etc/sasl2 ]
+ then
+ mkdir -p ${ROOT}/etc/sasl2
+ fi
+
+ # This shouldn't be necessary, but apparently
+ # Without it things can still get messy.
+ if [ -L ${ROOT}/etc/sasl2/smtpd.conf ]
+ then
+ rm ${ROOT}/etc/sasl2/smtpd.conf
+ fi
+
+ # If both files exist, make sure that we
+ # preserve a copy of each with the ._cfg
+ # system
+ if [ -f ${ROOT}/etc/sasl2/smtpd.conf ]
+ then
+ mv ${ROOT}/usr/lib/sasl2/smtpd.conf \
+ ${ROOT}/etc/sasl2/._cfg0000_smtpd.conf
+ else
+ mv ${ROOT}/usr/lib/sasl2/smtpd.conf ${ROOT}/etc/sasl2
+ fi
+ eend
+ fi
+ fi
+
}
src_unpack() {
diff --git a/net-mail/postfix/postfix-2.0.9.ebuild b/net-mail/postfix/postfix-2.0.9.ebuild
index f998f66c7d5a..25d085a5ee89 100644
--- a/net-mail/postfix/postfix-2.0.9.ebuild
+++ b/net-mail/postfix/postfix-2.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.9.ebuild,v 1.2 2003/04/19 02:55:27 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.9.ebuild,v 1.3 2003/06/13 22:49:38 lostlogic Exp $
inherit eutils
@@ -43,6 +43,39 @@ pkg_setup() {
if ! grep -q ^mail:.*postfix /etc/group ; then
usermod -G mail postfix || die "problem adding user postfix to group mail"
fi
+
+ # Prevent mangling the smtpd.conf file
+ if [ ! -L ${ROOT}/usr/lib/sasl2/smtpd.conf ]
+ then
+ if [ -f ${ROOT}/usr/lib/sasl2/smtpd.conf ]
+ then
+ ebegin "Protecting your smtpd.conf file"
+ if [ ! -d ${ROOT}/etc/sasl2 ]
+ then
+ mkdir -p ${ROOT}/etc/sasl2
+ fi
+
+ # This shouldn't be necessary, but apparently
+ # Without it things can still get messy.
+ if [ -L ${ROOT}/etc/sasl2/smtpd.conf ]
+ then
+ rm ${ROOT}/etc/sasl2/smtpd.conf
+ fi
+
+ # If both files exist, make sure that we
+ # preserve a copy of each with the ._cfg
+ # system
+ if [ -f ${ROOT}/etc/sasl2/smtpd.conf ]
+ then
+ mv ${ROOT}/usr/lib/sasl2/smtpd.conf \
+ ${ROOT}/etc/sasl2/._cfg0000_smtpd.conf
+ else
+ mv ${ROOT}/usr/lib/sasl2/smtpd.conf ${ROOT}/etc/sasl2
+ fi
+ eend
+ fi
+ fi
+
}
src_unpack() {