summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-03-21 19:31:49 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-03-21 19:31:49 +0000
commitc46e96639b32a9e96f878827eea0e8881734cba1 (patch)
treeab95481fb94781982a471fdfa1495838c0976ad5 /net-mail
parentfix wrong commit (diff)
downloadhistorical-c46e96639b32a9e96f878827eea0e8881734cba1.tar.gz
historical-c46e96639b32a9e96f878827eea0e8881734cba1.tar.bz2
historical-c46e96639b32a9e96f878827eea0e8881734cba1.zip
Added mandrake patches.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog9
-rw-r--r--net-mail/evolution/evolution-1.0.2-r1.ebuild149
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.2-r12
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.2.200203202
-rw-r--r--net-mail/evolution/files/evolution-1.0.2-conduit.patch10
-rw-r--r--net-mail/evolution/files/evolution-1.0.2-fileurl.patch11
-rw-r--r--net-mail/evolution/files/evolution-1.0.2-kde.patch20
-rw-r--r--net-mail/evolution/files/evolution-1.0.2-offline.patch214
-rw-r--r--net-mail/evolution/files/evolution-1.0.2-subversion.patch11
9 files changed, 427 insertions, 1 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 286f38d2b8ed..5ab4d3809769 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.2 2002/02/04 14:25:32 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.3 2002/03/21 19:31:48 g2boojum Exp $
+
+*evolution-1.0.2-r1 (21 Mar 2002)
+
+ 21 Mar 2002; G. Goodyear <g2boojum@gentoo.org> :
+
+ Added Mandrake patches. Hey, they're commented for a change.
+ Doesn't seem to fix the eaddress-conduit instantiation problem, though.
*evolution-1.0.1-r2 (1 Feb 2002)
diff --git a/net-mail/evolution/evolution-1.0.2-r1.ebuild b/net-mail/evolution/evolution-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..e22c67dac00d
--- /dev/null
+++ b/net-mail/evolution/evolution-1.0.2-r1.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Mikael Hallendal <hallski@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.2-r1.ebuild,v 1.1 2002/03/21 19:31:48 g2boojum Exp $
+
+DB3=db-3.1.17
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
+ ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
+ http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+RDEPEND=">=gnome-extra/bonobo-conf-0.14
+ >=gnome-base/bonobo-1.0.18
+ >=gnome-extra/gal-0.19
+ >=gnome-base/gconf-1.0.7
+ >=gnome-extra/gtkhtml-1.0.1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/gdk-pixbuf-0.14.0
+ >=dev-libs/libxml-1.8.16
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gnome-print-0.34
+ >=app-text/scrollkeeper-0.2
+ ssl? ( >=net-www/mozilla-0.9.6-r3 )
+ ldap? ( >=net-nds/openldap-2.0 )
+ mozilla? ( >=net-www/mozilla-0.9.6-r3 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.11
+ >=sys-devel/libtool-1.4.1-r1
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/filter-crash.patch
+ # add mandrake patches
+ # fix KDE detection
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch
+ # fix subversion in message header
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-subversion.patch
+ # fix file url given to helper apps
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-fileurl.patch
+ # fix crash in My Evolution when going offline
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-offline.patch
+ # call pilot conduit applet (not pilot link applet)
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch
+}
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+ make || die # make -j 4 doesn't work, use make
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf=""
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ if [ "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes"
+ fi
+
+ if [ "`use ssl`" ] ; then
+ myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nss-libs --without-nss-includes"
+ fi
+
+ # SSL needs NSPR libs ...
+ if [ "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-file-locking=no \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ # emake might not work, so fall back to make
+ emake || make || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Don't use DESTDIR it violates sandbox // Hallski
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ KDE_APPLNK_DIR=${D}/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
diff --git a/net-mail/evolution/files/digest-evolution-1.0.2-r1 b/net-mail/evolution/files/digest-evolution-1.0.2-r1
new file mode 100644
index 000000000000..b8f8e50540a2
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0.2-r1
@@ -0,0 +1,2 @@
+MD5 05ca33abfabeaa14b8fd61c682fddad3 evolution-1.0.2.tar.gz 12118839
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/digest-evolution-1.0.2.20020320 b/net-mail/evolution/files/digest-evolution-1.0.2.20020320
new file mode 100644
index 000000000000..3470c4f3a280
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0.2.20020320
@@ -0,0 +1,2 @@
+MD5 81f6b80d2cbf7799b3014122fa95c7cd evolution-1.0.2.20020320.tar.gz 11163418
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/evolution-1.0.2-conduit.patch b/net-mail/evolution/files/evolution-1.0.2-conduit.patch
new file mode 100644
index 000000000000..e235bdfc84b8
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.2-conduit.patch
@@ -0,0 +1,10 @@
+--- evolution-1.0.2/shell/e-shell-view-menu.c.orig Wed Dec 5 00:03:11 2001
++++ evolution-1.0.2/shell/e-shell-view-menu.c Tue Feb 26 15:08:43 2002
+@@ -567,6 +567,7 @@
+ {
+ char *args[] = {
+ "gpilotd-control-applet",
++ "--cap-id=1",
+ NULL
+ };
+ int pid;
diff --git a/net-mail/evolution/files/evolution-1.0.2-fileurl.patch b/net-mail/evolution/files/evolution-1.0.2-fileurl.patch
new file mode 100644
index 000000000000..49db817ab89f
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.2-fileurl.patch
@@ -0,0 +1,11 @@
+--- evolution-1.0.2/mail/mail-display.c.fileurl Mon Dec 10 20:55:20 2001
++++ evolution-1.0.2/mail/mail-display.c Mon Feb 25 19:18:49 2002
+@@ -311,7 +311,7 @@
+ }
+
+ command = g_strdup_printf ("%s %s%s &", app->command,
+- app->expects_uris == GNOME_VFS_MIME_APPLICATION_ARGUMENT_TYPE_URIS ? "file:" : "",
++ app->expects_uris == GNOME_VFS_MIME_APPLICATION_ARGUMENT_TYPE_URIS ? "file://" : "",
+ filename);
+ system (command);
+ g_free (command);
diff --git a/net-mail/evolution/files/evolution-1.0.2-kde.patch b/net-mail/evolution/files/evolution-1.0.2-kde.patch
new file mode 100644
index 000000000000..286f6687275a
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.2-kde.patch
@@ -0,0 +1,20 @@
+--- evolution-1.0.2/configure.in.orig Mon Feb 25 18:26:05 2002
++++ evolution-1.0.2/configure.in Mon Feb 25 19:01:52 2002
+@@ -990,14 +990,9 @@
+ if test -z "$with_kde_applnk_path"; then
+ with_kde_applnk_path="$prefix/share/applnk"
+ fi
+-if test -d "$with_kde_applnk_path" ; then
+- AC_MSG_RESULT("$with_kde_applnk_path" found)
+- AC_DEFINE(HAVE_KDE_APPLNK)
+- KDE_APPLNK_DIR="$with_kde_applnk_path"
+-else
+- AC_MSG_RESULT(not found)
+- KDE_APPLNK_DIR=""
+-fi
++AC_MSG_RESULT("$with_kde_applnk_path" found)
++AC_DEFINE(HAVE_KDE_APPLNK)
++KDE_APPLNK_DIR="$with_kde_applnk_path"
+ AM_CONDITIONAL(HAVE_KDE_APPLNK, test x"$KDE_APPLNK_DIR" != x)
+ AC_SUBST(KDE_APPLNK_DIR)
+
diff --git a/net-mail/evolution/files/evolution-1.0.2-offline.patch b/net-mail/evolution/files/evolution-1.0.2-offline.patch
new file mode 100644
index 000000000000..99a4c85a05ca
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.2-offline.patch
@@ -0,0 +1,214 @@
+--- evolution-1.0.2/my-evolution/e-summary-offline-handler.c.offline Wed Jan 23 18:50:45 2002
++++ evolution-1.0.2/my-evolution/e-summary-offline-handler.c Mon Feb 25 19:15:41 2002
+@@ -38,36 +38,63 @@
+ static BonoboXObjectClass *parent_class = NULL;
+
+ struct _ESummaryOfflineHandlerPriv {
+- ESummary *summary;
++ GSList *summaries;
+ GNOME_Evolution_OfflineProgressListener listener_interface;
+ };
+
+-GNOME_Evolution_ConnectionList *
+-e_summary_offline_handler_create_connection_list (ESummary *summary)
++/* ::destroy handler for the bookkeeping of the list of summary views. */
++
++static void
++summary_destroy_callback (GtkObject *object,
++ void *data)
++{
++ ESummaryOfflineHandler *offline_handler;
++ ESummaryOfflineHandlerPriv *priv;
++ ESummary *summary;
++
++ summary = E_SUMMARY (object);
++ offline_handler = E_SUMMARY_OFFLINE_HANDLER (data);
++ priv = offline_handler->priv;
++
++ priv->summaries = g_slist_remove (priv->summaries, summary);
++}
++
++static GNOME_Evolution_ConnectionList *
++create_connection_list (GSList *summaries)
+ {
+ GNOME_Evolution_ConnectionList *list;
+ GList *connections, *p;
++ GSList *sp;
+
+ list = GNOME_Evolution_ConnectionList__alloc ();
+ list->_length = 0;
+- list->_maximum = e_summary_count_connections (summary) + 1;
++ list->_maximum = 0;
++
++ /* Count the total number of connections first to make CORBA happy. */
++ for (sp = summaries; sp != NULL; sp = sp->next)
++ list->_maximum += e_summary_count_connections (E_SUMMARY (sp->data));
++
+ list->_buffer = CORBA_sequence_GNOME_Evolution_Connection_allocbuf (list->_maximum);
+
+- g_print ("_length: %d\n_maximum: %d\n", list->_length, list->_maximum);
+- connections = e_summary_add_connections (summary);
+- for (p = connections; p; p = p->next) {
+- ESummaryConnectionData *data;
+-
+- data = p->data;
+- list->_buffer[list->_length].hostName = CORBA_string_dup (data->hostname);
+- list->_buffer[list->_length].type = CORBA_string_dup (data->type);
+- list->_length++;
+-
+- g_free (data->hostname);
+- g_free (data->type);
+- g_free (data);
++ for (sp = summaries; sp != NULL; sp = sp->next) {
++ ESummary *summary;
++
++ summary = E_SUMMARY (sp->data);
++ connections = e_summary_add_connections (summary);
++ for (p = connections; p != NULL; p = p->next) {
++ ESummaryConnectionData *data;
++
++ data = p->data;
++ list->_buffer[list->_length].hostName = CORBA_string_dup (data->hostname);
++ list->_buffer[list->_length].type = CORBA_string_dup (data->type);
++ list->_length++;
++
++ g_free (data->hostname);
++ g_free (data->type);
++ g_free (data);
++ }
++ g_list_free (connections);
+ }
+- g_list_free (connections);
+
+ return list;
+ }
+@@ -78,10 +105,17 @@
+ CORBA_Environment *ev)
+ {
+ ESummaryOfflineHandler *offline_handler;
++ GSList *sp;
+
+ offline_handler = E_SUMMARY_OFFLINE_HANDLER (bonobo_object_from_servant (servant));
+- if (offline_handler->priv->summary != NULL) {
+- return offline_handler->priv->summary->online;
++
++ /* We are offline if all of the views are offline. */
++ for (sp = offline_handler->priv->summaries; sp != NULL; sp = sp->next) {
++ ESummary *summary;
++
++ summary = E_SUMMARY (sp->data);
++ if (summary->online)
++ return FALSE;
+ }
+
+ return TRUE;
+@@ -98,14 +132,7 @@
+ offline_handler = E_SUMMARY_OFFLINE_HANDLER (bonobo_object_from_servant (servant));
+ priv = offline_handler->priv;
+
+- if (priv->summary != NULL) {
+- *active_connection_list = e_summary_offline_handler_create_connection_list (priv->summary);
+- } else {
+- *active_connection_list = GNOME_Evolution_ConnectionList__alloc ();
+- (*active_connection_list)->_length = 0;
+- (*active_connection_list)->_maximum = 0;
+- (*active_connection_list)->_buffer = CORBA_sequence_GNOME_Evolution_Connection_allocbuf (0);
+- }
++ *active_connection_list = create_connection_list (priv->summaries);
+ }
+
+ static void
+@@ -122,7 +149,7 @@
+ g_return_if_fail (offline_handler != NULL);
+
+ priv = offline_handler->priv;
+- connection_list = e_summary_offline_handler_create_connection_list (summary);
++ connection_list = create_connection_list (priv->summaries);
+
+ CORBA_exception_init (&ev);
+
+@@ -143,14 +170,20 @@
+ {
+ ESummaryOfflineHandler *offline_handler;
+ ESummaryOfflineHandlerPriv *priv;
++ GSList *sp;
+
+ offline_handler = E_SUMMARY_OFFLINE_HANDLER (bonobo_object_from_servant (servant));
+ priv = offline_handler->priv;
+
+- if (priv->summary != NULL) {
+- priv->listener_interface = CORBA_Object_duplicate (progress_listener, ev);
+-
+- e_summary_set_online (priv->summary, progress_listener, FALSE, went_offline, offline_handler);
++ /* FIXME: If we have a progress already, then something is wrong and we
++ should raise an exception. */
++ priv->listener_interface = CORBA_Object_duplicate (progress_listener, &ev);
++
++ for (sp = priv->summaries; sp != NULL; sp = sp->next) {
++ ESummary *summary;
++
++ summary = E_SUMMARY (sp->data);
++ e_summary_set_online (summary, CORBA_OBJECT_NIL, FALSE, went_offline, offline_handler);
+ }
+ }
+
+@@ -159,10 +192,15 @@
+ CORBA_Environment *ev)
+ {
+ ESummaryOfflineHandler *offline_handler;
++ GSList *sp;
+
+ offline_handler = E_SUMMARY_OFFLINE_HANDLER (bonobo_object_from_servant (servant));
+- if (offline_handler->priv->summary != NULL) {
+- e_summary_set_online (offline_handler->priv->summary, NULL, TRUE, NULL, NULL);
++
++ for (sp = offline_handler->priv->summaries; sp != NULL; sp = sp->next) {
++ ESummary *summary;
++
++ summary = E_SUMMARY (sp->data);
++ e_summary_set_online (summary, CORBA_OBJECT_NIL, TRUE, NULL, NULL);
+ }
+ }
+
+@@ -188,7 +226,7 @@
+ CORBA_exception_free (&ev);
+ }
+
+- gtk_object_unref (GTK_OBJECT (priv->summary));
++ g_slist_free (priv->summaries);
+
+ offline_handler->priv = NULL;
+ g_free (priv);
+@@ -237,15 +275,18 @@
+ }
+
+ void
+-e_summary_offline_handler_set_summary (ESummaryOfflineHandler *handler,
++e_summary_offline_handler_add_summary (ESummaryOfflineHandler *handler,
+ ESummary *summary)
+ {
+ g_return_if_fail (handler != NULL);
+ g_return_if_fail (summary != NULL);
+ g_return_if_fail (IS_E_SUMMARY (summary));
+
+- handler->priv->summary = summary;
+- gtk_object_ref (GTK_OBJECT (summary));
++ handler->priv->summaries = g_slist_prepend (handler->priv->summaries,
++ summary);
++
++ gtk_signal_connect (GTK_OBJECT (summary), "destroy",
++ GTK_SIGNAL_FUNC (summary_destroy_callback), handler);
+ }
+
+ BONOBO_X_TYPE_FUNC_FULL (ESummaryOfflineHandler, GNOME_Evolution_Offline, PARENT_TYPE, e_summary_offline_handler);
+--- evolution-1.0.2/my-evolution/e-summary-factory.c.offline Sat Oct 27 18:59:44 2001
++++ evolution-1.0.2/my-evolution/e-summary-factory.c Mon Feb 25 19:15:48 2002
+@@ -138,7 +138,7 @@
+ return NULL;
+ }
+
+- e_summary_offline_handler_set_summary (handler, E_SUMMARY (summary));
++ e_summary_offline_handler_add_summary (handler, E_SUMMARY (summary));
+ gtk_widget_show (summary);
+
+ control = bonobo_control_new (summary);
diff --git a/net-mail/evolution/files/evolution-1.0.2-subversion.patch b/net-mail/evolution/files/evolution-1.0.2-subversion.patch
new file mode 100644
index 000000000000..0efebe96a064
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.2-subversion.patch
@@ -0,0 +1,11 @@
+--- evolution-1.0.2/mail/mail-ops.c.subversion Mon Dec 10 20:55:20 2001
++++ evolution-1.0.2/mail/mail-ops.c Mon Feb 25 19:07:31 2002
+@@ -430,7 +430,7 @@
+ XEvolution *xev;
+
+ camel_medium_add_header (CAMEL_MEDIUM (message), "X-Mailer",
+- "Evolution/" VERSION SUB_VERSION " " VERSION_COMMENT);
++ "Evolution/" VERSION "-" SUB_VERSION " " VERSION_COMMENT);
+
+ camel_mime_message_set_date (message, CAMEL_MESSAGE_DATE_CURRENT, 0);
+