summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-01-10 03:51:14 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-01-10 03:51:14 +0000
commitf02fce83afdd7530483d54a2ef2e32890378f25b (patch)
treefe6ab961606da57b822344f7622a390bf6f6defa /net-mail
parentversion bump #13099 (diff)
downloadhistorical-f02fce83afdd7530483d54a2ef2e32890378f25b.tar.gz
historical-f02fce83afdd7530483d54a2ef2e32890378f25b.tar.bz2
historical-f02fce83afdd7530483d54a2ef2e32890378f25b.zip
shared-mime-info support
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed-claws/ChangeLog11
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.8-r11
-rw-r--r--net-mail/sylpheed-claws/files/procmime.patch35
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.8.8-r1.ebuild113
4 files changed, 159 insertions, 1 deletions
diff --git a/net-mail/sylpheed-claws/ChangeLog b/net-mail/sylpheed-claws/ChangeLog
index 3fddf0894473..17d6d36ac652 100644
--- a/net-mail/sylpheed-claws/ChangeLog
+++ b/net-mail/sylpheed-claws/ChangeLog
@@ -1,12 +1,21 @@
# ChangeLog for net-mail/sylpheed-claws
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.29 2003/01/08 22:13:47 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.30 2003/01/10 03:51:09 lu_zero Exp $
+
+
+*sylpheed-claws-0.8.8-r1 (10 Jan 2003)
+
+ 10 Jan 2003; Luca Barbato <lu_zero@gentoo.org> sylpheed-claws-0.8.8-r1.ebuild,
+ files/digest-sylpheed-claws-0.8.8-r1, files/procmime.patch:
+
+ Make it use shared-mime-info
*sylpheed-claws-0.8.8 (26 Dec 2002)
08 Jan 2003; Brad Cowan <bcowan@gentoo.org>:
Added depend on mime-types, fixes bug #13412.
+
1 Jan 2003; Martin Schlemmer <azarah@gentoo.org> sylpheed-claws-0.8.8.ebuild :
Fix Gnome .desktop having no data; moved it to sylpheed-claws; Also change
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.8-r1 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.8-r1
new file mode 100644
index 000000000000..ce98797eccd6
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.8-r1
@@ -0,0 +1 @@
+MD5 e61d2fcb760bd509194437c65214c4b8 sylpheed-0.8.8claws.tar.bz2 1801972
diff --git a/net-mail/sylpheed-claws/files/procmime.patch b/net-mail/sylpheed-claws/files/procmime.patch
new file mode 100644
index 000000000000..1f5876278575
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/procmime.patch
@@ -0,0 +1,35 @@
+--- procmime.c.orig 2003-01-10 01:21:35.000000000 +0100
++++ procmime.c 2003-01-10 02:19:06.000000000 +0100
+@@ -1187,7 +1187,7 @@
+
+ if (mime_type_list)
+ return mime_type_list;
+-
++ if ((fp = fopen("/usr/share/mime/globs", "rb")) == NULL)
+ if ((fp = fopen("/etc/mime.types", "rb")) == NULL) {
+ if ((fp = fopen(SYSCONFDIR "/mime.types", "rb")) == NULL) {
+ FILE_OP_ERROR(SYSCONFDIR "/mime.types", "fopen");
+@@ -1201,11 +1201,12 @@
+ g_strstrip(buf);
+
+ p = buf;
+- while (*p && !isspace(*p)) p++;
++ while (*p && !isspace(*p)&& (*p!=':')) p++;
+ if (*p) {
+ *p = '\0';
+ p++;
+ }
++ g_print("%s ",buf);
+ delim = strchr(buf, '/');
+ if (delim == NULL) continue;
+ *delim = '\0';
+@@ -1214,7 +1215,8 @@
+ mime_type->type = g_strdup(buf);
+ mime_type->sub_type = g_strdup(delim + 1);
+
+- while (*p && isspace(*p)) p++;
++ while (*p && (isspace(*p)||(*p='*')||(*p='.'))) p++;
++ g_print("%s\n",p);
+ if (*p)
+ mime_type->extension = g_strdup(p);
+ else
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.8.8-r1.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.8.8-r1.ebuild
new file mode 100644
index 000000000000..2193c716d509
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.8.8-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.8.8-r1.ebuild,v 1.1 2003/01/10 03:51:09 lu_zero Exp $
+
+IUSE="nls gnome xface gtkhtml crypt spell imlib ssl ldap ipv6 pda"
+
+inherit eutils
+
+MY_P="sylpheed-${PV}claws"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Bleeding edge version of Sylpheed"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${MY_P}.tar.bz2"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ pda? ( >=app-misc/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.3.10 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( app-text/aspell )
+ xface? ( >=media-libs/compface-1.4 )
+ gtkhtml? ( net-www/dillo )
+ x11-misc/shared-mime-info
+ "
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/sylpheed"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # This patch allows for dillo web browser to be embeedded
+ if use gtkhtml
+ then
+ cd ${S}
+ epatch ${FILESDIR}/sylpheed-0.8.3claws32-dillo.patch
+ fi
+
+ # Change package name to sylpheed-claws ...
+ for i in `find ${S}/ -name 'configure*'`
+ do
+ cp $i ${i}.orig
+ sed -e "s/PACKAGE\=sylpheed/PACKAGE\=sylpheed-claws/" \
+ ${i}.orig > ${i}
+ done
+ # use shared-mime-info
+ cd src
+ patch -p0 <${FILESDIR}/procmime.patch
+}
+
+src_compile() {
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gdk-pixbuf" \
+ || myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib \
+ && myconf="${myconf} --enable-imlib" \
+ || myconf="${myconf} --disable-imlib"
+
+ use spell \
+ && myconf="${myconf} --enable-aspell" \
+ || myconf="${myconf} --disable-aspell"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use ssl && myconf="${myconf} --enable-openssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ echo ${myconf}
+
+ econf \
+ --program-suffix=-claws \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ local menuentry="/usr/share/gnome/apps/Internet/sylpheed.desktop"
+ use gnome \
+ && {
+ dosed "s/Sylpheed/Sylpheed Claws/" ${menuentry}
+ dosed "s/sylpheed/sylpheed-claws/" ${menuentry}
+ mv ${D}${menuentry} ${D}${menuentry/sylpheed/sylpheed-claws}
+ } \
+ || rm -rf ${D}/usr/share/gnome
+
+ mv ${D}/usr/share/pixmaps/sylpheed.png \
+ ${D}/usr/share/pixmaps/sylpheed-claws.png
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+}