summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-09-12 16:01:46 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-09-12 16:01:46 +0000
commitfff50c601519d1743681b0b4093713e6173eb17e (patch)
tree62eb66a5c5e4294292ed968116acdb8ea3f05a4f /net-mail
parentPatch version updates (diff)
downloadhistorical-fff50c601519d1743681b0b4093713e6173eb17e.tar.gz
historical-fff50c601519d1743681b0b4093713e6173eb17e.tar.bz2
historical-fff50c601519d1743681b0b4093713e6173eb17e.zip
Patch version updates
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/postfix/Manifest5
-rw-r--r--net-mail/postfix/files/digest-postfix-2.0.15-r14
-rw-r--r--net-mail/postfix/postfix-2.0.15-r1.ebuild251
3 files changed, 258 insertions, 2 deletions
diff --git a/net-mail/postfix/Manifest b/net-mail/postfix/Manifest
index 8a4e7271eaad..d97ba5e18dc3 100644
--- a/net-mail/postfix/Manifest
+++ b/net-mail/postfix/Manifest
@@ -1,12 +1,13 @@
MD5 b141e7104f8415ee713080be1428377f postfix-2.0.10-r1.ebuild 6160
MD5 fb2a0d195963e2dad30eba4238352499 postfix-2.0.13.ebuild 6368
MD5 4896326c3dc6885664ff4ce74614c274 postfix-2.0.13-r1.ebuild 6345
+MD5 546484b95f4013875dc6a1b4952134d6 postfix-2.0.15.ebuild 6383
MD5 f7902206b1ea1c3894f86f798f2eb0bd postfix-2.0.9.ebuild 6241
MD5 ef533edc3256c24f6ef2a04444b71404 postfix-1.1.11.20020917-r1.ebuild 4598
MD5 de51d2542b3a6d669a2f523b63e6e1d2 postfix-2.0.12-r1.ebuild 6027
MD5 a0bed4adcd5039175b633ec641660e04 postfix-2.0.14.ebuild 6379
-MD5 d5bf3aef72dfc87fcc10cb38de2e6694 postfix-2.0.15-r1.ebuild 6381
-MD5 4a3779c85392b38efa00777d43268d5e ChangeLog 17538
+MD5 53caf99049103faa8331297d7f0784e1 postfix-2.0.15-r1.ebuild 6384
+MD5 d6a9557972ab76117b43225e6261cb15 ChangeLog 17538
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 9486f47c362cb65c1ad4760647a7b3a5 postfix-2.0.11.ebuild 6031
MD5 3b74d1f1c47c8d5630d8f356adb2e28b postfix-1.1.11.20020917.ebuild 4578
diff --git a/net-mail/postfix/files/digest-postfix-2.0.15-r1 b/net-mail/postfix/files/digest-postfix-2.0.15-r1
new file mode 100644
index 000000000000..e9083ca0d607
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-2.0.15-r1
@@ -0,0 +1,4 @@
+MD5 723c2b7f67016e0c19b0e1aa08dad246 postfix-2.0.15.tar.gz 1351964
+MD5 6823c6645d64c80b63597db8b4a29d16 pfixtls-0.8.16-2.0.15-0.9.7b.tar.gz 234027
+MD5 63228fbba5c6b2e8f808eec2ea67649a ipv6-1.18-pf-2.0.15.patch.gz 42095
+MD5 49a1a7890015425243a98f87413ab172 tls+ipv6-1.18-pf-2.0.15.patch.gz 110577
diff --git a/net-mail/postfix/postfix-2.0.15-r1.ebuild b/net-mail/postfix/postfix-2.0.15-r1.ebuild
new file mode 100644
index 000000000000..9d072ac54026
--- /dev/null
+++ b/net-mail/postfix/postfix-2.0.15-r1.ebuild
@@ -0,0 +1,251 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.15-r1.ebuild,v 1.1 2003/09/12 16:01:44 lostlogic Exp $
+
+IUSE="ssl mysql sasl ldap ipv6 maildir mbox postgres"
+
+inherit eutils
+TLS_P="pfixtls-0.8.16-${PV}-0.9.7b"
+IPV6="1.18"
+IPV6_P="ipv6-${IPV6}-pf-2.0.15"
+IPV6_TLS_P="tls+ipv6-${IPV6}-pf-${PV}"
+PGSQL_P="postfix-pg.postfix-2.0.0.2"
+
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+HOMEPAGE="http://www.postfix.org"
+SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/official/${P}.tar.gz
+ ssl? ( ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/${TLS_P}.tar.gz )
+ ipv6? ( ftp://ftp.stack.nl/pub/postfix/tls+ipv6/${IPV6}/${IPV6_P}.patch.gz )
+ ipv6? ( ftp://ftp.stack.nl/pub/postfix/tls+ipv6/${IPV6}/${IPV6_TLS_P}.patch.gz )"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+PROVIDE="virtual/mta
+ virtual/mda"
+
+DEPEND=">=sys-libs/db-3.2
+ >=sys-apps/sed-4
+ >=dev-libs/libpcre-3.4
+ ldap? ( >=net-nds/openldap-1.2 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ sasl? ( dev-libs/cyrus-sasl )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00
+ !virtual/mta"
+
+is_postfix_installed() {
+ if [ -d /etc/postfix ] ; then
+ return 1
+ fi
+
+ return 0
+}
+
+pkg_setup() {
+ if ! grep -q ^postdrop: /etc/group ; then
+ groupadd postdrop || die "problem adding group postdrop"
+ fi
+
+ if ! grep -q ^mail:.*postfix /etc/group ; then
+ usermod -G mail postfix || die "problem adding user postfix to group mail"
+ fi
+
+ # Prevent mangling the smtpd.conf file
+ if [ ! -L ${ROOT}/usr/lib/sasl2/smtpd.conf ]
+ then
+ if [ -f ${ROOT}/usr/lib/sasl2/smtpd.conf ]
+ then
+ ebegin "Protecting your smtpd.conf file"
+ if [ ! -d ${ROOT}/etc/sasl2 ]
+ then
+ mkdir -p ${ROOT}/etc/sasl2
+ fi
+
+ # This shouldn't be necessary, but apparently
+ # Without it things can still get messy.
+ if [ -L ${ROOT}/etc/sasl2/smtpd.conf ]
+ then
+ rm ${ROOT}/etc/sasl2/smtpd.conf
+ fi
+
+ # If both files exist, make sure that we
+ # preserve a copy of each with the ._cfg
+ # system
+ if [ -f ${ROOT}/etc/sasl2/smtpd.conf ]
+ then
+ mv ${ROOT}/etc/sasl2/smtpd.conf \
+ ${ROOT}/etc/sasl2/._cfg0000_smtpd.conf
+ fi
+ mv ${ROOT}/usr/lib/sasl2/smtpd.conf ${ROOT}/etc/sasl2
+ eend
+ fi
+ fi
+
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ if [ "`use ssl`" ]; then
+ if [ "`use ipv6`" ]; then
+ epatch ${DISTDIR}/${IPV6_TLS_P}.patch.gz
+ else
+ unpack ${TLS_P}.tar.gz
+ epatch ${WORKDIR}/${P}/${TLS_P}/pfixtls.diff
+ fi
+ CCARGS="${CCARGS} -DHAS_SSL"
+ AUXLIBS="${AUXLIBS} -lssl -lcrypto"
+ elif [ "`use ipv6`" ]; then
+ epatch ${DISTDIR}/${IPV6_P}.patch.gz
+ fi
+
+ if [ "`use postgres`" ]; then
+ epatch ${FILESDIR}/${PGSQL_P}.patch.bz2
+ CCARGS="${CCARGS} -DHAS_PGSQL -I/usr/include/postgresql"
+ AUXLIBS="${AUXLIBS} -lpq"
+ fi
+
+ cd ${S}/conf
+ sed -i -e "s:/usr/libexec/postfix:/usr/lib/postfix:" main.cf
+
+ if [ "`use sasl`" ] ; then
+ # sasl 2
+ if [ -f /usr/include/sasl/sasl.h ]; then
+ AUXLIBS="${AUXLIBS} -lsasl2"
+ CCARGS="${CCARGS} -I/usr/include/sasl -DUSE_SASL_AUTH"
+ # sasl 1
+ elif [ -f /usr/include/sasl.h ]; then
+ AUXLIBS="${AUXLIBS} -lsasl"
+ CCARGS="${CCARGS} -DUSE_SASL_AUTH"
+ fi
+ fi
+
+ cd ${S}/src/global
+ sed -i -e "s:/usr/libexec/postfix:/usr/lib/postfix:" mail_params.h
+
+ if [ "`use mysql`" ] ; then
+ CCARGS="${CCARGS} -DHAS_MYSQL -I/usr/include/mysql"
+ AUXLIBS="${AUXLIBS} -lmysqlclient -lm -lz"
+ fi
+
+ if [ "`use ldap`" ] ; then
+ CCARGS="${CCARGS} -DHAS_LDAP"
+ AUXLIBS="${AUXLIBS} -lldap -llber"
+ fi
+
+ if [ "`use pam`" ] ; then
+ AUXLIBS="${AUXLIBS} -lpam"
+ fi
+
+ CCARGS="${CCARGS} -DHAS_PCRE"
+ AUXLIBS="${AUXLIBS} -L/usr/lib -lpcre -ldl -lcrypt"
+
+ DEBUG=""
+
+ cd ${S}
+ make makefiles CC="${CC}" OPT="${CFLAGS}" DEBUG="${DEBUG}" \
+ CCARGS="${CCARGS}" AUXLIBS="${AUXLIBS}" \
+ || die "creating makefiles failed"
+
+ # Postfix do not get the FQDN if no hostname is configured
+ epatch ${FILESDIR}/${PN}-2.0.9-get-FQDN.patch
+}
+
+src_compile() {
+ #this is a bug fix for gcc-2.95.3-r5 (bug 16547)
+ export CC=gcc
+ emake || die "compile problem"
+}
+
+src_install () {
+ dodir /usr/bin /usr/sbin /usr/lib/postfix /etc/postfix/sample
+ keepdir /var/spool/postfix/tmp
+
+ cd ${S}/bin
+ dosbin post* sendmail
+ fowners root:postdrop /usr/sbin/{postdrop,postqueue}
+ fperms 2755 /usr/sbin/{postdrop,postqueue}
+
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+
+ cd ${S}/libexec
+ exeinto /usr/lib/postfix
+ doexe *
+
+ cd ${S}/man
+ doman man*/*
+
+ cd ${S}
+ dodoc *README COMPATIBILITY HISTORY INSTALL LICENSE PORTING RELEASE_NOTES*
+ cd README_FILES
+ find . -type l |xargs rm
+ dodoc *
+
+ cd ${S}
+ dohtml html/*
+
+ cd ${S}/conf
+ insinto /etc/postfix/sample
+ doins access aliases canonical pcre_table regexp_table \
+ relocated transport virtual *.cf
+
+ exeinto /etc/postfix
+ doexe postfix-script post-install postfix-files
+
+ insinto /etc/postfix
+ doins ${S}/conf/{main,master}.cf ${FILESDIR}/saslpass
+ cd ${D}/etc/postfix
+ epatch ${FILESDIR}/postfix-2.0.14/main.cf.diff
+ sed -i -e "s|/usr/share/doc/POSTFIX|/usr/share/doc/${PF}|" main.cf
+ chmod 644 main.cf
+ rm -f main.cf~
+ fperms 600 /etc/postfix/saslpass
+
+ exeinto /etc/init.d ; doexe ${FILESDIR}/postfix
+ insinto /etc/pam.d ; newins ${FILESDIR}/smtp.pam smtp
+
+ if [ "`use sasl`" ]; then
+ insinto /etc/sasl2
+ doins ${FILESDIR}/smtpd-2.0.conf smtpd.conf
+ dodir /usr/lib/sasl2
+ dosym ../../../etc/sasl2/smtpd.conf /usr/lib/sasl2/smtpd.conf
+ fi
+
+ cd ${D}/etc/postfix
+ if [ "`use maildir`" ]; then
+ sed -i -e "s:^#\(home_mailbox = \)Maildir/:\1.maildir/:" main.cf
+ elif [ "`use mbox`" ]; then
+ sed -i -e "s:^#\(mail_spool_directory = /var/spool/mail\):\1:" main.cf
+ fi
+
+ #install an rmail for UUCP, closing bug #19127
+ cd ${S}/auxiliary/rmail
+ dobin rmail
+
+ if [ "`use postgres`" ]; then
+ cd ${S}/README_FILES
+ dodoc PGSQL_README
+ cd ${S}
+ fi
+}
+
+pkg_postinst() {
+ install -d -m 0755 ${ROOT}/var/spool/postfix
+
+ ewarn "If you upgraded from <postfix-2, you must revisit your configuration files."
+ ewarn "See /usr/share/doc/${PF}/RELEASE_NOTES for a list of changes."
+
+ if [ ! -e /etc/mail/aliases.db ] ; then
+ echo
+ ewarn "You must edit /etc/mail/aliases to suit your needs and then run"
+ ewarn "/usr/bin/newaliases. Postfix will not work correctly without it."
+ fi
+}