summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-11-20 21:29:56 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-11-20 21:29:56 +0000
commit9f82ab8a50dad99f0da2247183d054d425e13cb1 (patch)
tree3a5b2a237d52be778b7549a4794572c0b43442f4 /net-misc/asterisk-chan_sccp
parentRespect user CFLAGS & use proper CC, closes bug #113047. This one is for you,... (diff)
downloadhistorical-9f82ab8a50dad99f0da2247183d054d425e13cb1.tar.gz
historical-9f82ab8a50dad99f0da2247183d054d425e13cb1.tar.bz2
historical-9f82ab8a50dad99f0da2247183d054d425e13cb1.zip
Version bump.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-misc/asterisk-chan_sccp')
-rw-r--r--net-misc/asterisk-chan_sccp/ChangeLog9
-rw-r--r--net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20051118.ebuild54
-rw-r--r--net-misc/asterisk-chan_sccp/files/chan_sccp-20051118-gentoo.diff86
-rw-r--r--net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.200511181
4 files changed, 149 insertions, 1 deletions
diff --git a/net-misc/asterisk-chan_sccp/ChangeLog b/net-misc/asterisk-chan_sccp/ChangeLog
index d84e5dee5a06..a78f46231039 100644
--- a/net-misc/asterisk-chan_sccp/ChangeLog
+++ b/net-misc/asterisk-chan_sccp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/asterisk-chan_sccp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_sccp/ChangeLog,v 1.12 2005/09/30 00:00:11 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_sccp/ChangeLog,v 1.13 2005/11/20 21:29:56 stkn Exp $
+
+*asterisk-chan_sccp-0.0.20051118 (20 Nov 2005)
+
+ 20 Nov 2005; Stefan Knoblich <stkn@gentoo.org>
+ +files/chan_sccp-20051118-gentoo.diff,
+ +asterisk-chan_sccp-0.0.20051118.ebuild:
+ Version bump.
30 Sep 2005; Stefan Knoblich <stkn@gentoo.org>
asterisk-chan_sccp-0.0.20050826.ebuild:
diff --git a/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20051118.ebuild b/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20051118.ebuild
new file mode 100644
index 000000000000..0d03c4962f7e
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20051118.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20051118.ebuild,v 1.1 2005/11/20 21:29:56 stkn Exp $
+
+inherit eutils
+
+IUSE="debug"
+
+MY_P="chan_sccp-${PV/0.0./}"
+
+DESCRIPTION="SCCP channel plugin for the Asterisk soft PBX"
+HOMEPAGE="http://chan-sccp.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/chan-sccp/${MY_P}.tar.bz2"
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=net-misc/asterisk-1.0.5-r2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/chan_sccp-20051118-gentoo.diff
+
+ if ! use debug; then
+ sed -i -e "s:^\(DEBUG=.*\):#\1:" Makefile
+ fi
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake INSTALL_PREFIX=${D} install || die
+
+ dodoc conf/* contrib/*
+
+ # fix permissions
+ if [[ -n "$(egetent group asterisk)" ]]; then
+ einfo "Fixing permissions..."
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+ fi
+}
+
+pkg_postinst() {
+ ewarn "You have to disable asterisk's chan_skinny to use this module!"
+ einfo "Add \"noload => chan_skinny.so\" to ${ROOT}etc/asterisk/modules.conf"
+}
diff --git a/net-misc/asterisk-chan_sccp/files/chan_sccp-20051118-gentoo.diff b/net-misc/asterisk-chan_sccp/files/chan_sccp-20051118-gentoo.diff
new file mode 100644
index 000000000000..a4cd336a6f0e
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/files/chan_sccp-20051118-gentoo.diff
@@ -0,0 +1,86 @@
+--- chan_sccp-20051118/Makefile.orig 2005-11-18 18:22:38.000000000 +0000
++++ chan_sccp-20051118/Makefile 2005-11-20 23:05:00.000000000 +0000
+@@ -17,6 +17,8 @@
+ INSTALL_PREFIX=
+ ASTERISK_HEADER_DIR=$(INSTALL_PREFIX)/usr/include
+
++AST_CFG=/usr/bin/asterisk-config
++
+ ifeq (${OSNAME},FreeBSD)
+ ASTERISK_HEADER_DIR=$(INSTALL_PREFIX)/usr/local/include
+ endif
+@@ -37,9 +39,8 @@
+
+ DEBUG=-ggdb #-include $(ASTERISK_HEADER_DIR)/asterisk/astmm.h
+
+-DEFINE=-Iinclude -D_REENTRANT -D_GNU_SOURCE -O -DCRYPTO -fPIC
+-CFLAG= -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+-CFLAG+=$(shell if $(CC) -march=$(PROC) -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo " -march=$(PROC)"; fi)
++DEFINE=-Iinclude -D_REENTRANT -D_GNU_SOURCE -O -DCRYPTO -fPIC
++CFLAG+= -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ CFLAG+=$(shell if uname -m | grep -q ppc; then echo " -fsigned-char"; fi)
+ #CFLAG+= -pedantic
+ #CFLAG+= -W
+@@ -69,14 +70,14 @@
+ FLS+=sccp_socket
+ FLS+=sccp_indicate
+
+-CFLAGS+=$(DEFINE) $(CFLAG) -I$(ASTERISK_HEADER_DIR)
++CFLAGS+=$(DEFINE) $(CFLAG)
+ HEADERS=$(shell for i in $(FLS) ; do echo $$i.h ; done)
+ OBJECTS=$(shell for i in $(FLS) ; do echo .tmp/$$i.o ; done)
+ SOURCES=$(shell for i in $(FLS) ; do echo $$i.c ; done)
+
+ chan_sccp.so: .config .tmp $(OBJECTS) $(HEADERS) $(SOURCES)
+ @echo "Linking chan_sccp.so"
+- @$(CC) -shared -Xlinker -x -o chan_sccp.so $(OBJECTS)
++ @$(CC) $(shell $(AST_CFG) --solink) -o chan_sccp.so $(OBJECTS)
+
+ .tmp/%.o: $(HEADERS)
+ @printf "Now compiling .... %-15s\t%s lines \n" $*.c "`wc -l <$*.c`"
+@@ -84,18 +85,14 @@
+
+ all: chan_sccp.so
+
+-install: chan_sccp.so
++install:
+ @echo "Now Installing chan_sccp.so"
+- @install -m 755 chan_sccp.so $(AST_MODULES_DIR);
++ @install -D -m 755 chan_sccp.so $(AST_MODULES_DIR)/chan_sccp.so;
+ @if ! [ -f $(INSTALL_PREFIX)/etc/asterisk/sccp.conf ]; then \
+ echo "Installing config file $(INSTALL_PREFIX)/etc/asterisk/sccp.conf"; \
+ mkdir -p $(INSTALL_PREFIX)/etc/asterisk; \
+ cp conf/sccp.conf $(INSTALL_PREFIX)/etc/asterisk/; \
+ fi
+- @echo "Chan_sccp is now installed"
+- @echo "Remember to disable chan_skinny by adding the following"
+- @echo "line to /etc/asterisk/modules.conf:"
+- @echo "noload => chan_skinny.so"
+
+ clean:
+ rm -rf config.h chan_sccp.so .tmp
+--- chan_sccp-20051118/create_config.sh.orig 2005-11-18 18:22:38.000000000 +0000
++++ chan_sccp-20051118/create_config.sh 2005-11-20 23:05:00.000000000 +0000
+@@ -38,20 +38,8 @@
+ echo "#define CHAN_SCCP_CONFIG_H" >>$CONFIGFILE
+ echo >>$CONFIGFILE
+
+-echo -n "Build PARK functions (y/n)[n]?"
+-read key
+-if [ "$key" = "y" ]
+-then
+- echo "#define CS_SCCP_PARK" >>$CONFIGFILE
+-fi
+-
+-echo -n "Build PICKUP functions (y/n)[n]?"
+-read key
+-if [ "$key" = "y" ]
+-then
+- echo "#define CS_SCCP_PICKUP" >>$CONFIGFILE
+-fi
+-
++echo "#define CS_SCCP_PARK" >>$CONFIGFILE
++echo "#define CS_SCCP_PICKUP" >>$CONFIGFILE
+
+ if grep -q "struct ast_channel_tech" $INCLUDEDIR/channel.h; then
+ echo "#define CS_AST_HAS_TECH_PVT" >>$CONFIGFILE
diff --git a/net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.20051118 b/net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.20051118
new file mode 100644
index 000000000000..8ac83e66e6db
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.20051118
@@ -0,0 +1 @@
+MD5 1b5edb422fa36b8bb48b596d93e12e37 chan_sccp-20051118.tar.bz2 67177