summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-08-27 21:30:24 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-08-27 21:30:24 +0000
commit02349de16807357c72ee26626b1234add129094c (patch)
tree5e57249098cc5bfa4a8132ae3693c0e088f8eadb /net-misc/bcm570x
parentversion bump (diff)
downloadhistorical-02349de16807357c72ee26626b1234add129094c.tar.gz
historical-02349de16807357c72ee26626b1234add129094c.tar.bz2
historical-02349de16807357c72ee26626b1234add129094c.zip
version bump
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'net-misc/bcm570x')
-rw-r--r--net-misc/bcm570x/Manifest2
-rw-r--r--net-misc/bcm570x/bcm570x-8.2.18.ebuild52
-rw-r--r--net-misc/bcm570x/files/digest-bcm570x-8.2.181
3 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/bcm570x/Manifest b/net-misc/bcm570x/Manifest
index eb2035c40878..a4fb429b5982 100644
--- a/net-misc/bcm570x/Manifest
+++ b/net-misc/bcm570x/Manifest
@@ -1,8 +1,10 @@
MD5 e87041ed4428abc340840dd9f988cab0 bcm570x-7.3.5.ebuild 1076
MD5 434bcd4fa6f0d6cb9c837cd042b1d266 bcm570x-8.1.55.ebuild 1443
MD5 3c53a6cf844bd82aad7b3aac079e3716 bcm570x-7.1.22.ebuild 1213
+MD5 30c1fba734af88b05ee5f77c4a5791d3 bcm570x-8.2.18.ebuild 1478
MD5 cdd00b68600522209a557899b295b836 ChangeLog 997
MD5 e31850eaea026d25a876d92edad633c5 metadata.xml 432
MD5 44885101781a4107275d223357034d59 files/digest-bcm570x-7.3.5 60
MD5 e6eee42d87d02c24aaf191bb75376589 files/digest-bcm570x-7.1.22 66
MD5 51694895250b73ea9c3b2de6dd42b2d3 files/digest-bcm570x-8.1.55 61
+MD5 c6d8124e7c8a8bcef35f1bbef251607b files/digest-bcm570x-8.2.18 61
diff --git a/net-misc/bcm570x/bcm570x-8.2.18.ebuild b/net-misc/bcm570x/bcm570x-8.2.18.ebuild
new file mode 100644
index 000000000000..c8227ba72a4a
--- /dev/null
+++ b/net-misc/bcm570x/bcm570x-8.2.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bcm570x/bcm570x-8.2.18.ebuild,v 1.1 2005/08/27 21:30:24 genstef Exp $
+
+inherit linux-mod
+
+MY_P=${P/570x/5700}
+SRC_URI="http://www.broadcom.com/docs/driver_download/570x/linux-${PV}.zip"
+DESCRIPTION="Driver for the Broadcom 570x-based gigabit cards (found on many mainboards)."
+HOMEPAGE="http://www.broadcom.com/drivers"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="app-arch/unzip"
+S=${WORKDIR}/Server/Linux/Driver/${MY_P}/src
+
+MODULE_NAMES="bcm5700(net:)"
+BUILD_TARGETS="default"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="LINUX=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/Server/Linux/Driver
+ tar xzpf ${MY_P}.tar.gz || \
+ die "could not extract second level archive"
+ tar xzpf bcm_sup-${PV}.tar.gz || \
+ die "could not extract supplementary archive"
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins ${WORKDIR}/Server/Linux/Driver/bcm_sup-${PV}/patches/${MY_P}-2.4.31.patch \
+ ${WORKDIR}/Server/Linux/Driver/bcm_sup-${PV}/patches/${MY_P}-2.6.12.patch
+
+ linux-mod_src_install
+ doman bcm5700.4
+ dodoc ../../DISTRIB.TXT ../README.TXT
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "For more detailed information about this driver:"
+ einfo "man 4 bcm5700"
+ einfo "If you prefer patching your kernel,"
+ einfo "you can find kernel patches in /usr/share/${PN}"
+}
diff --git a/net-misc/bcm570x/files/digest-bcm570x-8.2.18 b/net-misc/bcm570x/files/digest-bcm570x-8.2.18
new file mode 100644
index 000000000000..74f16c0b564c
--- /dev/null
+++ b/net-misc/bcm570x/files/digest-bcm570x-8.2.18
@@ -0,0 +1 @@
+MD5 a7875f1ffeccea25858ed751c2abcd52 linux-8.2.18.zip 813463