summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2005-10-31 15:00:55 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2005-10-31 15:00:55 +0000
commita732a7a96d98497428efa416d273ee5044e11f3a (patch)
treea4df9bac185d168b8ced32aee126f71ed9a819a9 /net-misc/d4x/d4x-2.5.6.ebuild
parentKeyworded ~sparc, don't use java though, doesn't work (diff)
downloadhistorical-a732a7a96d98497428efa416d273ee5044e11f3a.tar.gz
historical-a732a7a96d98497428efa416d273ee5044e11f3a.tar.bz2
historical-a732a7a96d98497428efa416d273ee5044e11f3a.zip
Version bump.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'net-misc/d4x/d4x-2.5.6.ebuild')
-rw-r--r--net-misc/d4x/d4x-2.5.6.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/d4x/d4x-2.5.6.ebuild b/net-misc/d4x/d4x-2.5.6.ebuild
new file mode 100644
index 000000000000..6568c06bb722
--- /dev/null
+++ b/net-misc/d4x/d4x-2.5.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/d4x-2.5.6.ebuild,v 1.1 2005/10/31 15:00:55 nelchael Exp $
+
+IUSE="nls esd gnome oss kde"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="GTK based download manager for X."
+SRC_URI="http://www.krasu.ru/soft/chuchelo/files/${P}.tar.gz"
+HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="Artistic"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ >=dev-libs/glib-2.0.6
+ >=sys-devel/gettext-0.11.2
+ >=dev-libs/openssl-0.9.7f
+ esd? ( >=media-sound/esound-0.2.7 )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Use our own $CXXFLAGS
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:CXXFLAGS=\"-O2\":CXXFLAGS=\"${CXXFLAGS}\":g;s:OPTFLAGS=\"-O2\":OPTFLAGS=\"\":g" \
+ configure.orig >configure
+}
+
+src_compile() {
+
+ myconf=""
+ append-flags -D_FILE_OFFSET_BITS=64
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use esd \
+ && myconf="${myconf} --enable-esd" \
+ || myconf="${myconf} --disable-esd"
+
+ use oss \
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
+
+ econf --enable-release \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/bin
+ dodir /usr/share/d4x
+
+ einstall || die
+
+ insinto /usr/share/pixmaps
+ doins share/*.png share/*.xpm
+
+ if use kde
+ then
+ insinto /usr/share/applnk/Internet
+ newins share/nt.desktop d4x.desktop
+ fi
+
+ if use gnome
+ then
+ echo "Categories=Application;Network;" >> ${S}/share/nt.desktop
+ insinto /usr/share/applications
+ newins share/nt.desktop d4x.desktop
+ fi
+
+ rm -rf ${D}/usr/share/d4x/{FAQ*,INSTALL*,README*,LICENSE,NAMES,TROUBLES}
+ dodoc AUTHORS COPYING ChangeLog* NEWS PLANS TODO \
+ DOC/{FAQ*,LICENSE,NAMES,README*,TROUBLES,THANKS}
+}