summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2009-04-16 20:25:04 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2009-04-16 20:25:04 +0000
commit21a5eb431f8095f87ca0d62c40f2daacd586cc21 (patch)
tree3ba2855c9fce38a7830e9c5496bca316d953405f /net-misc/mico/files
parentManifesting (diff)
downloadhistorical-21a5eb431f8095f87ca0d62c40f2daacd586cc21.tar.gz
historical-21a5eb431f8095f87ca0d62c40f2daacd586cc21.tar.bz2
historical-21a5eb431f8095f87ca0d62c40f2daacd586cc21.zip
use gcc pthread flag instead of -lpthread.
do not link -lstdc++ explicitly on aix. Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'net-misc/mico/files')
-rw-r--r--net-misc/mico/files/mico-2.3.13-aix.patch12
-rw-r--r--net-misc/mico/files/mico-2.3.13-pthread.patch46
2 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/mico/files/mico-2.3.13-aix.patch b/net-misc/mico/files/mico-2.3.13-aix.patch
new file mode 100644
index 000000000000..feac0f71a293
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-aix.patch
@@ -0,0 +1,12 @@
+Do not add '-lstdc++' explicitly, this is c++ compiler's job.
+--- admin/mico-shld.aix.in.orig 2009-04-02 17:33:03 +0200
++++ admin/mico-shld.aix.in 2009-04-02 17:33:22 +0200
+@@ -87,7 +87,7 @@
+
+
+ ldcmd="@SHARED_CC@ @LDSOFLAGS@ @DLFLAGS@ $libdirs @LDFLAGS@ \
+- -Wl,-bE:lib.exp,-bnoentry -o '$outfile' $args @LIBS@ -lstdc++"
++ -Wl,-bE:lib.exp,-bnoentry -o '$outfile' $args @LIBS@"
+
+ echo "$ldcmd"
+ eval "$ldcmd"
diff --git a/net-misc/mico/files/mico-2.3.13-pthread.patch b/net-misc/mico/files/mico-2.3.13-pthread.patch
new file mode 100644
index 000000000000..f2c419e44235
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-pthread.patch
@@ -0,0 +1,46 @@
+When using gcc, use '-pthread' (or '-pthreads' on solaris)
+compiler flag to do all pthread specific things.
+--- configure.in.orig 2009-04-02 17:25:45 +0200
++++ configure.in 2009-04-02 17:32:00 +0200
+@@ -524,7 +524,19 @@
+ )
+ AC_CHECK_HEADERS(semaphore.h)
+ AC_DEFINE(HAVE_PTHREADS)
++ case "${GXX}:${target}" in
++ yes:*solaris*|yes:*sunos*)
++ CXXFLAGS="-pthreads ${CXXFLAGS}"
++ LDFLAGS="-pthreads ${LDFLAGS}"
++ ;;
++ yes:*)
++ CXXFLAGS="-pthread ${CXXFLAGS}"
++ LDFLAGS="-pthread ${LDFLAGS}"
++ ;;
++ *)
+ SHLIBS="-lpthread"
++ ;;
++ esac
+ else
+ AC_CHECK_LIB(c_r, pthread_create, use_pthreads=yes, use_pthreads=no)
+ if test X"$use_pthreads" = Xyes; then
+--- configure.orig 2009-04-02 17:25:42 +0200
++++ configure 2009-04-02 17:32:00 +0200
+@@ -2738,7 +2738,19 @@
+ #define HAVE_PTHREADS 1
+ EOF
+
++ case "${GXX}:${target}" in
++ yes:*solaris*|yes:*sunos*)
++ CXXFLAGS="-pthreads ${CXXFLAGS}"
++ LDFLAGS="-pthreads ${LDFLAGS}"
++ ;;
++ yes:*)
++ CXXFLAGS="-pthread ${CXXFLAGS}"
++ LDFLAGS="-pthread ${LDFLAGS}"
++ ;;
++ *)
+ SHLIBS="-lpthread"
++ ;;
++ esac
+ else
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+ echo "configure:2745: checking for pthread_create in -lc_r" >&5