summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-22 12:04:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-22 12:04:06 +0000
commit731e453cd791a2736c5df11c1bd74a601c5ad3ca (patch)
tree28236089a923b33a12b5c7d080a1c09cac4ba472 /net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild
parentAdd nasty hack so config.{sub,guess} is writable (and hence econf wont fail t... (diff)
downloadhistorical-731e453cd791a2736c5df11c1bd74a601c5ad3ca.tar.gz
historical-731e453cd791a2736c5df11c1bd74a601c5ad3ca.tar.bz2
historical-731e453cd791a2736c5df11c1bd74a601c5ad3ca.zip
Inherit pam for newpamd function. Added new revision with include syntax for OpenPAM compatibility.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild')
-rw-r--r--net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild b/net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild
new file mode 100644
index 000000000000..fe11825c11b9
--- /dev/null
+++ b/net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rsh/netkit-rsh-0.17-r7.ebuild,v 1.1 2005/05/22 12:04:06 flameeyes Exp $
+
+inherit eutils pam
+
+DESCRIPTION="Netkit's Remote Shell Suite: rexec{,d} rlogin{,d} rsh{,d}"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz
+ mirror://gentoo/rexec-1.5.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ pam? ( virtual/pam )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ unpack rexec-1.5.tar.gz
+ for p in $(grep -v '^#' "${FILESDIR}"/redhat.spec) ; do
+ EPATCH_SINGLE_MSG="Applying Redhat's ${p} ..." \
+ epatch "${FILESDIR}"/${p}
+ done
+ sed -i \
+ -e '/LDFLAGS/s:$: -Wl,-z,now:' \
+ r{cp,login,sh}/Makefile
+}
+
+src_compile() {
+ local myconf
+ use pam || myconf="--without-pam"
+ ./configure ${myconf} || die
+
+ sed -i \
+ -e "s:-pipe -O2:${CFLAGS}:" \
+ -e "s:-Wpointer-arith::" \
+ MCONFIG
+ make || die
+}
+
+src_install() {
+ local b exe
+ insinto /etc/xinetd.d
+ for b in rcp rexec{,d} rlogin{,d} rsh{,d} ; do
+ if [[ ${b:0-1} == "d" ]] ; then
+ dosbin ${b}/${b} || die "dosbin ${b} failed"
+ dosym ${b} /usr/sbin/in.${b}
+ doman ${b}/${b}.8
+ else
+ dobin ${b}/${b} || die "dobin ${b} failed"
+ doman ${b}/${b}.1
+ [[ ${b} != "rexec" ]] \
+ && fperms 4711 /usr/bin/${b}
+ if [[ ${b} != "rcp" ]]; then
+ newins "${FILESDIR}"/${b}.xinetd ${b}
+ newpamd "${FILESDIR}/${b}.pamd-include" ${b}
+ fi
+ fi
+ done
+ dodoc README ChangeLog BUGS
+ newdoc rexec/README README.rexec
+}