summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-10 02:06:30 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-10 02:06:30 +0000
commit989da88ac64d2c178cf59c19f0d0c4dd24720446 (patch)
tree65e5db85d25c12f3e27641689562fd810ce91dbb /net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild
parentnetkit-timed rc5/rc6 support (diff)
downloadhistorical-989da88ac64d2c178cf59c19f0d0c4dd24720446.tar.gz
historical-989da88ac64d2c178cf59c19f0d0c4dd24720446.tar.bz2
historical-989da88ac64d2c178cf59c19f0d0c4dd24720446.zip
now supports rc5/rc6 systems. small changes only, mostly to just
the rc6 initscript.
Diffstat (limited to 'net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild')
-rw-r--r--net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild b/net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild
new file mode 100644
index 000000000000..364aa7e2dd65
--- /dev/null
+++ b/net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-timed/netkit-timed-0.17-r6.ebuild,v 1.1 2001/09/10 02:06:30 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Netkit - timed"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/timed.c ${S}/timed/timed/timed.c
+}
+
+src_compile() {
+ ./configure || die
+ make || die
+}
+
+src_install() {
+ dosbin timed/timed/timed
+ doman timed/timed/timed.8
+ dosbin timed/timedc/timedc
+ doman timed/timedc/timedc.8
+ dodoc README ChangeLog BUGS
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/timed.rc6 timed
+}