summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-04 12:37:15 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-04 12:37:15 +0000
commitcd6005d1284cfaeb295d08dbc249b1fd70bba146 (patch)
treed11021dbd4bda864d8c7e5ec2a6e1f35b27c5102 /net-misc/nforce-net
parentstable on x86 (diff)
downloadhistorical-cd6005d1284cfaeb295d08dbc249b1fd70bba146.tar.gz
historical-cd6005d1284cfaeb295d08dbc249b1fd70bba146.tar.bz2
historical-cd6005d1284cfaeb295d08dbc249b1fd70bba146.zip
Version bump
Diffstat (limited to 'net-misc/nforce-net')
-rw-r--r--net-misc/nforce-net/ChangeLog7
-rw-r--r--net-misc/nforce-net/files/digest-nforce-net-1.0.02561
-rw-r--r--net-misc/nforce-net/nforce-net-1.0.0256.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/net-misc/nforce-net/ChangeLog b/net-misc/nforce-net/ChangeLog
index 605639877d75..53720df879b0 100644
--- a/net-misc/nforce-net/ChangeLog
+++ b/net-misc/nforce-net/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/nforce-net
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nforce-net/ChangeLog,v 1.3 2003/02/19 15:08:54 alain Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nforce-net/ChangeLog,v 1.4 2003/05/04 12:37:15 aliz Exp $
+
+*nforce-net-1.0.256 (04 May 2003)
+
+ 04 May 2003; Daniel Ahlberg <aliz@gentoo.org> nforce-net-1.0.256.ebuild :
+ Version bump.
*nforce-net-1.0.0248-r2 (19 Feb 2003)
diff --git a/net-misc/nforce-net/files/digest-nforce-net-1.0.0256 b/net-misc/nforce-net/files/digest-nforce-net-1.0.0256
new file mode 100644
index 000000000000..d18cd981bcb1
--- /dev/null
+++ b/net-misc/nforce-net/files/digest-nforce-net-1.0.0256
@@ -0,0 +1 @@
+MD5 3ad2e2371946b7881471e4cadddf108e NVIDIA_nforce-1.0-0256.tar.gz 75752
diff --git a/net-misc/nforce-net/nforce-net-1.0.0256.ebuild b/net-misc/nforce-net/nforce-net-1.0.0256.ebuild
new file mode 100644
index 000000000000..e7d2acc94fe4
--- /dev/null
+++ b/net-misc/nforce-net/nforce-net-1.0.0256.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nforce-net/nforce-net-1.0.0256.ebuild,v 1.1 2003/05/04 12:37:15 aliz Exp $
+
+inherit gcc
+
+# Make sure Portage does _NOT_ strip symbols. Need both lines for
+# Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+
+NV_V="${PV/1.0./1.0-}"
+NV_PACKAGE="NVIDIA_nforce-${NV_V}"
+S="${WORKDIR}/nforce"
+DESCRIPTION="Linux kernel module for the NVIDIA's nForce network chip"
+SRC_URI="http://download.nvidia.com/XFree86/nforce/${NV_V}/${NV_PACKAGE}.tar.gz"
+HOMEPAGE="http://www.nvidia.com/"
+
+# The slow needs to be set to $KV to prevent unmerges of
+# modules for other kernels.
+LICENSE="NVIDIA"
+SLOT="${KV}"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+DEPEND="virtual/linux-sources >=sys-apps/portage-1.9.10"
+
+src_unpack() {
+ unpack ${A}
+ if [ `gcc-major-version` -eq 2 ] ; then
+ einfo "Applying gcc2 compatability patch"
+ cp nforce/nvnet/Makefile{,.old}
+ sed -e "s/-falign-functions/-malign-functions/" nforce/nvnet/Makefile.old > nforce/nvnet/Makefile
+ fi
+}
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ #IGNORE_CC_MISMATCH disables a sanity check that's needed when gcc has been
+ #updated but the running kernel is still compiled with an older gcc. This is
+ #needed for chrooted building, where the sanity check detects the gcc of the
+ #kernel outside the chroot rather than within.
+ cd ${S}/nvnet
+ make KERNSRC="/usr/src/linux" || die
+}
+
+src_install() {
+ # The driver goes into the standard modules location
+ insinto /lib/modules/${KV}/kernel/drivers/net
+ doins nvnet/nvnet.o
+
+ # Docs
+ dodoc ${S}/README
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ # Update module dependency
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ echo
+ einfo "You need to add \"nvnet\" to your /etc/modules.autoload to load"
+ einfo "this module when the system is started."
+}
+