summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-22 02:12:21 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-22 02:12:21 +0000
commitbd4cff7abc2b106d6cda7837a1ecea78101d3680 (patch)
tree2c578d282e494d48a26af77c6fa7d5fa0a59f0f2 /net-misc/ntp
parentSome dependencies and autobuild fixes (diff)
downloadhistorical-bd4cff7abc2b106d6cda7837a1ecea78101d3680.tar.gz
historical-bd4cff7abc2b106d6cda7837a1ecea78101d3680.tar.bz2
historical-bd4cff7abc2b106d6cda7837a1ecea78101d3680.zip
Initial import of NTP into the portage tree. We can all rejoice and
keep our clocks in sync. 8)
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/files/digest-ntp-4.0.99k1
-rw-r--r--net-misc/ntp/ntp-4.0.99k.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/ntp/files/digest-ntp-4.0.99k b/net-misc/ntp/files/digest-ntp-4.0.99k
new file mode 100644
index 000000000000..7052a16b0338
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.0.99k
@@ -0,0 +1 @@
+MD5 6335d5b9b04a2d4670c4eed7300cdb82 ntp-4.0.99k.tar.gz
diff --git a/net-misc/ntp/ntp-4.0.99k.ebuild b/net-misc/ntp/ntp-4.0.99k.ebuild
new file mode 100644
index 000000000000..e80f5578fea4
--- /dev/null
+++ b/net-misc/ntp/ntp-4.0.99k.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.0.99k.ebuild,v 1.1 2000/11/22 02:12:21 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Time Protocol suite/programs"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${A}"
+HOMEPAGE="http://www.ntp.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make prefix=${D}/usr install
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+
+ cd ${S}/html
+ docinto html
+ dodoc *.htm
+
+ cd ${S}/html/hints
+ docinto html/hints
+ dodoc *
+
+ cd ${S}/html/pic
+ docinto html/pic
+ dodoc *
+
+ cd ${S}/scripts
+ insinto /usr/share/ntp
+ doins *
+}