summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-25 06:40:21 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-25 06:40:21 +0000
commitc5507dea6c888ba00efc3552d0dda24b1707b3ea (patch)
tree448b0bd31e676fdc016dd7fb49ac79391164efee /net-misc/openssh/files
parentold (diff)
downloadhistorical-c5507dea6c888ba00efc3552d0dda24b1707b3ea.tar.gz
historical-c5507dea6c888ba00efc3552d0dda24b1707b3ea.tar.bz2
historical-c5507dea6c888ba00efc3552d0dda24b1707b3ea.zip
Add x509/ldap/hpn support back in. Auto-remove ecdsa support from init.d if openssl lacks support #352645 by William Throwe.
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'net-misc/openssh/files')
-rw-r--r--net-misc/openssh/files/openssh-5.7_p1-x509-hpn-glue.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/openssh/files/openssh-5.7_p1-x509-hpn-glue.patch b/net-misc/openssh/files/openssh-5.7_p1-x509-hpn-glue.patch
new file mode 100644
index 000000000000..ee3e7574764e
--- /dev/null
+++ b/net-misc/openssh/files/openssh-5.7_p1-x509-hpn-glue.patch
@@ -0,0 +1,60 @@
+Move things around so hpn applies cleanly when using X509.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -46,11 +46,12 @@
+ CC=@CC@
+ LD=@LD@
+ CFLAGS=@CFLAGS@
+-CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ @LDAP_CPPFLAGS@ $(PATHS) @DEFS@
++CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
+ LIBS=@LIBS@
+ SSHDLIBS=@SSHDLIBS@
+ LIBEDIT=@LIBEDIT@
+ LIBLDAP=@LDAP_LDFLAGS@ @LDAP_LIBS@
++CPPFLAGS+=@LDAP_CPPFLAGS@
+ AR=@AR@
+ AWK=@AWK@
+ RANLIB=@RANLIB@
+--- a/servconf.c
++++ b/servconf.c
+@@ -153,9 +153,6 @@ initialize_server_options(ServerOptions *options)
+ options->zero_knowledge_password_authentication = -1;
+ options->revoked_keys_file = NULL;
+ options->trusted_user_ca_keys = NULL;
+- options->authorized_principals_file = NULL;
+- options->ip_qos_interactive = -1;
+- options->ip_qos_bulk = -1;
+
+ options->hostbased_algorithms = NULL;
+ options->pubkey_algorithms = NULL;
+@@ -168,6 +165,9 @@ initialize_server_options(ServerOptions *options)
+ options->va.certificate_file = NULL;
+ options->va.responder_url = NULL;
+ #endif /*def SSH_OCSP_ENABLED*/
++ options->authorized_principals_file = NULL;
++ options->ip_qos_interactive = -1;
++ options->ip_qos_bulk = -1;
+ }
+
+ void
+@@ -367,9 +367,6 @@ typedef enum {
+ sGssAuthentication, sGssCleanupCreds, sAcceptEnv, sPermitTunnel,
+ sMatch, sPermitOpen, sForceCommand, sChrootDirectory,
+ sUsePrivilegeSeparation, sAllowAgentForwarding,
+- sZeroKnowledgePasswordAuthentication, sHostCertificate,
+- sRevokedKeys, sTrustedUserCAKeys, sAuthorizedPrincipalsFile,
+- sKexAlgorithms, sIPQoS,
+ sHostbasedAlgorithms,
+ sPubkeyAlgorithms,
+ sX509KeyAlgorithm,
+@@ -380,6 +377,9 @@ typedef enum {
+ sCAldapVersion, sCAldapURL,
+ sVAType, sVACertificateFile,
+ sVAOCSPResponderURL,
++ sZeroKnowledgePasswordAuthentication, sHostCertificate,
++ sRevokedKeys, sTrustedUserCAKeys, sAuthorizedPrincipalsFile,
++ sKexAlgorithms, sIPQoS,
+ sDeprecated, sUnsupported
+ } ServerOpCodes;
+