summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-08-21 13:29:39 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-08-21 13:29:39 +0000
commitb7ab143515c7dffab8b56c8e3ebd9c60461c4233 (patch)
tree37598be2b5ff7cf40e44d7a0e456cab89578449a /net-misc/putty
parentupdate to conf.d file (diff)
downloadhistorical-b7ab143515c7dffab8b56c8e3ebd9c60461c4233.tar.gz
historical-b7ab143515c7dffab8b56c8e3ebd9c60461c4233.tar.bz2
historical-b7ab143515c7dffab8b56c8e3ebd9c60461c4233.zip
fix #44836
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog5
-rw-r--r--net-misc/putty/Manifest6
-rw-r--r--net-misc/putty/putty-0.57.ebuild38
3 files changed, 36 insertions, 13 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 5eff6511b0de..81b8ae007fdc 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.23 2005/05/01 18:24:02 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.24 2005/08/21 13:29:39 taviso Exp $
+
+ 21 Aug 2005; Tavis Ormandy <taviso@gentoo.org> putty-0.57.ebuild:
+ fix #44836
01 May 2005; Michael Hanselmann <hansmi@gentoo.org> putty-0.57.ebuild:
Stable on ppc.
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 851dc9a1b644..c37abf420985 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,6 +1,6 @@
+MD5 754f83f3cf48b87d08a29c429a2165c2 putty-0.57.ebuild 1695
+MD5 f5b160bf233f924c3030a87a4ac24fa3 ChangeLog 3465
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
-MD5 8bee762956d01df08b96a1438b37e41f ChangeLog 3383
-MD5 0615bff333ce8028714a40e73452a0c3 putty-0.57.ebuild 1407
-MD5 4f674a5fd23877ac6d76c6d9baa33041 files/putty-ut_time.patch 824
MD5 3a07269379d199e6363fbe0250c5899a files/digest-putty-0.57 63
+MD5 4f674a5fd23877ac6d76c6d9baa33041 files/putty-ut_time.patch 824
MD5 85355228c88a7a925e751df0f058f0ea files/putty.desktop 207
diff --git a/net-misc/putty/putty-0.57.ebuild b/net-misc/putty/putty-0.57.ebuild
index 8ec34debb356..ae834a45ab7f 100644
--- a/net-misc/putty/putty-0.57.ebuild
+++ b/net-misc/putty/putty-0.57.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.57.ebuild,v 1.5 2005/05/01 18:24:02 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.57.ebuild,v 1.6 2005/08/21 13:29:39 taviso Exp $
inherit eutils
@@ -12,9 +12,9 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 alpha ppc ~sparc amd64"
-IUSE="doc"
+IUSE="doc gtk"
-RDEPEND="=x11-libs/gtk+-1.2* virtual/x11"
+RDEPEND="gtk? ( =x11-libs/gtk+-1.2* virtual/x11 )"
DEPEND="${RDEPEND} dev-lang/perl"
@@ -27,21 +27,39 @@ src_unpack() {
ebegin "Setting CFLAGS"
sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
+
+ # prevent gtk-config from being used without gtk
+ if ! use gtk; then
+ sed -i "s/gtk-config/true/g" ${S}/unix/Makefile.gtk
+ fi
eend $?
}
src_compile() {
- cd ${S}/unix; emake -f Makefile.gtk || die "make failed"
+ cd ${S}/unix;
+ if use gtk; then
+ emake -f Makefile.gtk
+ else
+ emake -f Makefile.gtk puttygen plink pscp psftp
+ fi
}
src_install() {
cd ${S}/doc
- doman plink.1 pterm.1 putty.1 puttytel.1 puttygen.1
+ if use gtk; then
+ doman pterm.1 putty.1 puttytel.1
+ fi
+
+ doman puttygen.1 plink.1
cd ${S}/unix
- dobin plink pterm putty puttytel psftp pscp puttygen
+ if use gtk; then
+ dobin pterm putty puttytel
+ fi
+
+ dobin puttygen plink pscp psftp
cd ${S}
@@ -51,9 +69,11 @@ src_install() {
prepallman
# install desktop file provided by Gustav Schaffter in #49577
- dodir /usr/share/applications
- insinto /usr/share/applications
- doins ${FILESDIR}/putty.desktop
+ if use gtk; then
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/putty.desktop
+ fi
if test ! -c /dev/ptmx; then
ewarn