summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-02 05:09:09 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-02 05:09:09 +0000
commit1fc84435d79c8de21d9ef7a82939c2f1ca355008 (patch)
tree9486cc152bf705d4c92474fabe825ca764cdd3c5 /net-misc/rsync
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-1fc84435d79c8de21d9ef7a82939c2f1ca355008.tar.gz
historical-1fc84435d79c8de21d9ef7a82939c2f1ca355008.tar.bz2
historical-1fc84435d79c8de21d9ef7a82939c2f1ca355008.zip
remove proxy patch
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/rsync-2.6.2-r1.ebuild21
-rw-r--r--net-misc/rsync/rsync-2.6.2.ebuild21
2 files changed, 22 insertions, 20 deletions
diff --git a/net-misc/rsync/rsync-2.6.2-r1.ebuild b/net-misc/rsync/rsync-2.6.2-r1.ebuild
index b06daa1ca683..a314563162e4 100644
--- a/net-misc/rsync/rsync-2.6.2-r1.ebuild
+++ b/net-misc/rsync/rsync-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.2-r1.ebuild,v 1.2 2004/05/02 00:26:03 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.2-r1.ebuild,v 1.3 2004/05/02 05:09:09 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -8,7 +8,6 @@ DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="http://rsync.samba.org/"
SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz
acl? ( http://www.saout.de/misc/${P}-acl.diff.bz2 )"
-# http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${PN}-2.5.6-proxy-auth-1.patch
LICENSE="GPL-2"
SLOT="0"
@@ -24,27 +23,29 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack "${P}.tar.gz"
cd ${S}
- # proxy patch seems to be merged in now 2.6.2
- # epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
use acl && epatch ${DISTDIR}/${P}-acl.diff.bz2
# change confdir to /etc/rsync rather than just /etc (the --sysconfdir
# configure option doesn't work
sed -i \
- -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h \
- || die "sed rsync.h failed"
+ -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' \
+ rsync.h \
+ || die "sed rsync.h failed"
# yes, updating the man page is very important.
sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
+ -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' \
+ rsyncd.conf.5 \
+ || die "sed rsyncd.conf.5 failed"
}
src_compile() {
[ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
use static && append-ldflags -static
export LDFLAGS
- econf $(use_with build included-popt) \
- $(use_with acl acl-support) || die
+ econf \
+ $(use_with build included-popt) \
+ $(use_with acl acl-support) \
+ || die
emake || die "emake failed"
}
diff --git a/net-misc/rsync/rsync-2.6.2.ebuild b/net-misc/rsync/rsync-2.6.2.ebuild
index 1d6e2a1b2f17..b0f5111e6c97 100644
--- a/net-misc/rsync/rsync-2.6.2.ebuild
+++ b/net-misc/rsync/rsync-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.2.ebuild,v 1.6 2004/05/02 05:04:34 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.2.ebuild,v 1.7 2004/05/02 05:09:09 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -9,7 +9,6 @@ HOMEPAGE="http://rsync.samba.org/"
SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz"
# ACL patches need to be forward ported again.
# acl? ( http://www.saout.de/misc/${PN}-2.6.0-acl.diff.bz2 )"
-# http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${PN}-2.5.6-proxy-auth-1.patch
LICENSE="GPL-2"
SLOT="0"
@@ -26,27 +25,29 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack "${P}.tar.gz"
cd ${S}
- # proxy patch seems to be merged in now 2.6.2
- # epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
#use acl && epatch ${DISTDIR}/${PN}-2.6.0-acl.diff.bz2
# change confdir to /etc/rsync rather than just /etc (the --sysconfdir
# configure option doesn't work
sed -i \
- -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h \
- || die "sed rsync.h failed"
+ -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' \
+ rsync.h \
+ || die "sed rsync.h failed"
# yes, updating the man page is very important.
sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
+ -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' \
+ rsyncd.conf.5 \
+ || die "sed rsyncd.conf.5 failed"
}
src_compile() {
[ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
use static && append-ldflags -static
export LDFLAGS
- econf $(use_with build included-popt) \
- $(use_with acl acl-support) || die
+ econf \
+ $(use_with build included-popt) \
+ $(use_with acl acl-support) \
+ || die
emake || die "emake failed"
}