summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-16 17:04:19 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-16 17:04:19 +0000
commit4cbb2149336721a7b8c4efa304cb3ee3646a2731 (patch)
tree5ed0c982bfcb1177cef0746d78374b9409893263 /net-misc/socat/socat-1.7.0.0.ebuild
parentStable for HPPA (bug #246558). (diff)
downloadhistorical-4cbb2149336721a7b8c4efa304cb3ee3646a2731.tar.gz
historical-4cbb2149336721a7b8c4efa304cb3ee3646a2731.tar.bz2
historical-4cbb2149336721a7b8c4efa304cb3ee3646a2731.zip
Version bump, removed old.
Package-Manager: portage-2.2_rc14/cvs/Linux 2.6.26-openvz.git-35f41f1 i686
Diffstat (limited to 'net-misc/socat/socat-1.7.0.0.ebuild')
-rw-r--r--net-misc/socat/socat-1.7.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/socat/socat-1.7.0.0.ebuild b/net-misc/socat/socat-1.7.0.0.ebuild
new file mode 100644
index 000000000000..e10c43a6b0e3
--- /dev/null
+++ b/net-misc/socat/socat-1.7.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.0.0.ebuild,v 1.1 2008/11/16 17:04:19 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+SRC_URI="http://www.dest-unreach.org/socat/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ virtual/libc"
+
+src_compile() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+ emake || die
+}
+
+src_test() {
+ TMPDIR="${T}" make test || die 'self test failed'
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT EXAMPLES \
+ FAQ FILES PORTING README SECURITY VERSION
+ docinto examples
+ dodoc *.sh
+ dohtml socat.html
+}