summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-26 09:10:46 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-26 09:10:46 +0000
commit8939c38a3ce15b27d5f97fbbaa7961be012eba50 (patch)
treef6c3cbebf65e090b727ce50f8e91da6b11816c4a /net-misc/vde/vde-2.0.2.ebuild
parentAdd patch to fix vbi decoding with kernels 2.6.16 and greater. Thanks to Sir ... (diff)
downloadhistorical-8939c38a3ce15b27d5f97fbbaa7961be012eba50.tar.gz
historical-8939c38a3ce15b27d5f97fbbaa7961be012eba50.tar.bz2
historical-8939c38a3ce15b27d5f97fbbaa7961be012eba50.zip
Take over maintainer and version bump thanks to Lorenzo Grandi <popposoft@gmail.com> in bug 113554 also allows to set a group in the init script, thanks to Jean-François Richard <jean-francois@richard.name> in bug 113482 and works with qemu 0.8, thanks to Tim Redman <tredman1@tampabay.rr.com> and Nico Baggus <mlspamcb@noci.xs4all.nl> in bug 116840, big thanks to Rob M. (Adamant) <thehandoftyr@gmail.com> to notify me of this one in IRC #gentoo-dev-help.
Package-Manager: portage-2.1.1_pre1-r2
Diffstat (limited to 'net-misc/vde/vde-2.0.2.ebuild')
-rw-r--r--net-misc/vde/vde-2.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/vde/vde-2.0.2.ebuild b/net-misc/vde/vde-2.0.2.ebuild
new file mode 100644
index 000000000000..4e1f007364de
--- /dev/null
+++ b/net-misc/vde/vde-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/vde-2.0.2.ebuild,v 1.1 2006/06/26 09:10:46 genstef Exp $
+
+DESCRIPTION="vde2 is a virtual distributed ethernet emulator for emulators like qemu, bochs, and uml."
+SRC_URI="mirror://sourceforge/vde/${P}.tar.bz2"
+HOMEPAGE="http://vde.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/vde.init vde
+ newconfd "${FILESDIR}"/vde.conf vde
+
+ dodoc INSTALL README
+}
+
+pkg_postinst() {
+ # default group already used in kqemu
+ enewgroup qemu
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+ einfo "Users of the group can then run: $ vdeq qemu -sock /var/run/vde.ctl ..other opts"
+}