summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-12-08 22:00:46 +0000
committerAron Griffis <agriffis@gentoo.org>2003-12-08 22:00:46 +0000
commit183d6a84cfe52b6bfbd689c92b20e081b4d73c7d (patch)
treed9a5c5e117e5456a0cfffa9ceeb38e94c76b8f77 /net-misc
parentfix socks.h and socksify (diff)
downloadhistorical-183d6a84cfe52b6bfbd689c92b20e081b4d73c7d.tar.gz
historical-183d6a84cfe52b6bfbd689c92b20e081b4d73c7d.tar.bz2
historical-183d6a84cfe52b6bfbd689c92b20e081b4d73c7d.zip
fix socks.h and socksify
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dante/Manifest4
-rw-r--r--net-misc/dante/dante-1.1.14-r1.ebuild60
-rw-r--r--net-misc/dante/files/dante-1.1.14-bindresvport.patch17
-rw-r--r--net-misc/dante/files/dante-1.1.14-socksify.patch16
-rw-r--r--net-misc/dante/files/digest-dante-1.1.14-r11
5 files changed, 96 insertions, 2 deletions
diff --git a/net-misc/dante/Manifest b/net-misc/dante/Manifest
index 5a6f2bd1ca76..ecab7a302ba1 100644
--- a/net-misc/dante/Manifest
+++ b/net-misc/dante/Manifest
@@ -1,7 +1,7 @@
-MD5 79ffca8d23b840b2e767516703c24886 ChangeLog 2430
+MD5 442bc7052a673e915c08cd23ba0d561f ChangeLog 2842
MD5 9cdc31775c5dc2db57555e3981ec01f0 dante-1.1.13.ebuild 1629
MD5 f351918f42b158fb810cddcd071404ec dante-1.1.14.ebuild 1392
-MD5 ae00a786aa519ed9f9dde3378793defe dante-1.1.14-r1.ebuild 1420
+MD5 bda1262ebac2098a761d04b5d195b4d6 dante-1.1.14-r1.ebuild 1556
MD5 cf57d339f81e5b0ec5054a4722cdf335 files/dante-sockd-init 906
MD5 a5e8f0769876952c68e2a06a1508fbfd files/digest-dante-1.1.13 64
MD5 7d257618e686db991bad06011612d805 files/digest-dante-1.1.14 64
diff --git a/net-misc/dante/dante-1.1.14-r1.ebuild b/net-misc/dante/dante-1.1.14-r1.ebuild
new file mode 100644
index 000000000000..81db5ae15711
--- /dev/null
+++ b/net-misc/dante/dante-1.1.14-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/dante-1.1.14-r1.ebuild,v 1.1 2003/12/08 22:00:43 agriffis Exp $
+
+inherit gcc
+
+DESCRIPTION="A free socks4,5 and msproxy implemetation"
+HOMEPAGE="http://www.inet.no/dante/"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc alpha ~hppa ia64"
+IUSE="tcpd debug"
+
+DEPEND="virtual/glibc
+ sys-libs/pam
+ tcpd? ( sys-apps/tcp-wrappers )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd failed"
+ epatch ${FILESDIR}/dante-1.1.14-socksify.patch || die "epatch failed"
+ epatch ${FILESDIR}/dante-1.1.14-bindresvport.patch || die "epatch failed"
+}
+
+src_compile() {
+ econf \
+ `use_enable debug` \
+ `use_enable tcpd libwrap` \
+ --with-socks-conf=/etc/socks/socks.conf \
+ --with-sockd-conf=/etc/socks/sockd.conf \
+ ${myconf} \
+ || die "bad ./configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # bor: comment libdl.so out it seems to work just fine without it
+ sed -i -e 's:libdl\.so::' ${D}/usr/bin/socksify || die 'sed failed'
+
+ # no configuration file by default
+ dodir /etc/socks
+
+ # our init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dante-sockd-init dante-sockd
+
+ # install documentation
+ dodoc BUGS CREDITS LICENSE NEWS README SUPPORT TODO VERSION
+ docinto txt
+ cd doc
+ dodoc README* *.txt SOCKS4.*
+ docinto example
+ cd ../example
+ dodoc *.conf
+}
diff --git a/net-misc/dante/files/dante-1.1.14-bindresvport.patch b/net-misc/dante/files/dante-1.1.14-bindresvport.patch
new file mode 100644
index 000000000000..58535ae31037
--- /dev/null
+++ b/net-misc/dante/files/dante-1.1.14-bindresvport.patch
@@ -0,0 +1,17 @@
+--- dante-1.1.14/capi/socks.h.agriffis 2003-07-02 08:13:28.000000000 -0400
++++ dante-1.1.14/capi/socks.h 2003-12-08 15:29:13.000000000 -0500
+@@ -47,6 +47,14 @@
+ #include <sys/socket.h>
+
+
++/*
++ * The definition of bindresvport below conflicts with line 336 of
++ * <netinet/in.h> ... best workaround seems to be to make sure the
++ * file is included prior to the #define
++ */
++#include <netinet/in.h>
++
++
+ #define accept Raccept
+ #define bind Rbind
+ #define bindresvport Rbindresvport
diff --git a/net-misc/dante/files/dante-1.1.14-socksify.patch b/net-misc/dante/files/dante-1.1.14-socksify.patch
new file mode 100644
index 000000000000..626d9b0911f6
--- /dev/null
+++ b/net-misc/dante/files/dante-1.1.14-socksify.patch
@@ -0,0 +1,16 @@
+--- dante-1.1.14/bin/socksify.in.agriffis 2001-12-04 06:57:18.000000000 -0500
++++ dante-1.1.14/bin/socksify.in 2003-12-08 15:15:29.000000000 -0500
+@@ -60,7 +60,11 @@
+ @PRELOAD_VARIABLE@="${LIBRARY}${SOCKSIFY_PRELOAD_LIBS:+${PRELOAD_SEPERATOR}}${SOCKSIFY_PRELOAD_LIBS}${PRELOAD_POSTFIX:+${PRELOAD_SEPERATOR}}${PRELOAD_POSTFIX}"
+ export @PRELOAD_VARIABLE@
+
+-LD_LIBRARY_PATH="${LD_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}${LIBDIR}"
+-export LD_LIBRARY_PATH
++# There is no reason to set LD_LIBRARY_PATH, at least on Linux, where
++# LD_PRELOAD can contain a full path to the library. Setting the
++# following breaks socksify on Linux/Alpha at least with
++# binutils-2.14.90.0.7-r3 (08 Dec 2003 agriffis)
++#LD_LIBRARY_PATH="${LD_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}${LIBDIR}"
++#export LD_LIBRARY_PATH
+
+ exec "$@"
diff --git a/net-misc/dante/files/digest-dante-1.1.14-r1 b/net-misc/dante/files/digest-dante-1.1.14-r1
new file mode 100644
index 000000000000..67e51bafd3c6
--- /dev/null
+++ b/net-misc/dante/files/digest-dante-1.1.14-r1
@@ -0,0 +1 @@
+MD5 465c2c615c1aa64afd328feee97ba007 dante-1.1.14.tar.gz 804081