summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Jones <ashmodai@gentoo.org>2002-05-26 19:57:28 +0000
committerMike Jones <ashmodai@gentoo.org>2002-05-26 19:57:28 +0000
commitfcbd6aab9e9edbffc8b0bd1200135cd98df4ee00 (patch)
tree66753af3136933646a62b989181399ce2a0c4802 /net-misc
parentCloses bug 1147 at least with exim-4. Needs someone to test it with exim3 (diff)
downloadhistorical-fcbd6aab9e9edbffc8b0bd1200135cd98df4ee00.tar.gz
historical-fcbd6aab9e9edbffc8b0bd1200135cd98df4ee00.tar.bz2
historical-fcbd6aab9e9edbffc8b0bd1200135cd98df4ee00.zip
Initial merge of OpenVPN ebuild into Portage tree.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvpn/ChangeLog14
-rw-r--r--net-misc/openvpn/files/digest-openvpn-1.1.01
-rw-r--r--net-misc/openvpn/openvpn-1.1.0.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
new file mode 100644
index 000000000000..074554b203a6
--- /dev/null
+++ b/net-misc/openvpn/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-misc/openvpn
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.1 2002/05/26 19:57:28 ashmodai Exp $
+
+*openvpn-1.1.0 (26 May 2002)
+
+ 26 May 2002; Mike Jones <ashmodai@gentoo.org> ChangeLog, openvpn-1.1.0.ebuild:
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/net-misc/openvpn/files/digest-openvpn-1.1.0 b/net-misc/openvpn/files/digest-openvpn-1.1.0
new file mode 100644
index 000000000000..90839383d5e5
--- /dev/null
+++ b/net-misc/openvpn/files/digest-openvpn-1.1.0
@@ -0,0 +1 @@
+MD5 2bcbdb086ea6f6647f6d740e0f2b883a openvpn-1.1.0.tar.gz 114994
diff --git a/net-misc/openvpn/openvpn-1.1.0.ebuild b/net-misc/openvpn/openvpn-1.1.0.ebuild
new file mode 100644
index 000000000000..ccd35cadb50a
--- /dev/null
+++ b/net-misc/openvpn/openvpn-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Mike Jones <ashmodai@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.1.0.ebuild,v 1.1 2002/05/26 19:57:28 ashmodai Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/openvpn/${P}.tar.gz"
+HOMEPAGE="http://openvpn.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL"
+
+DEPEND=">=dev-libs/lzo-1.07
+ virtual/linux-sources
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use ssl || myconf='--disable-ssl --disable-crypto'
+
+ ./autogen.sh || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING CHANGES INSTALL PORTS README
+
+}